aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid27/Makefile
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-02-17 19:07:18 +0800
committersergei <sergei@FreeBSD.org>2004-02-17 19:07:18 +0800
commit77842fdfe1b0daa11c3b28b0f01bcdebf09badb8 (patch)
treeda3859626732907106ee8b4a8628742d57877f1e /www/squid27/Makefile
parent578cf67367161f31496a44b0df8b187c1b6c73d0 (diff)
downloadfreebsd-ports-gnome-77842fdfe1b0daa11c3b28b0f01bcdebf09badb8.tar.gz
freebsd-ports-gnome-77842fdfe1b0daa11c3b28b0f01bcdebf09badb8.tar.zst
freebsd-ports-gnome-77842fdfe1b0daa11c3b28b0f01bcdebf09badb8.zip
- integrate a new patch from squid-cache.org, see
http://www.squid-cache.org/Versions/v2/2.5/bugs/#squid-2.5.STABLE4-ftp_telnet for details - integrate a patch by Glen Gibb to enable ARP based ACLs and make this an OPTION; see also http://www.squid-cache.org/bugs/show_bug.cgi?id=909 for his original bug report - integrate additional vendor patches - make --enable-underscores an OPTION - set a tighter ACL on libexec/pinger - use $SQUID_USER and $SQUID_GROUP in pkg-install - wordsmith comments - bump PORTREVISION PR: ports/62442 Submitted by: maintainer - Fix checksum for updated errorpages patch PR: ports/62923 Submitted by: Michal Pasternak <dotz@irc.pl> Approved by: maintainer
Diffstat (limited to 'www/squid27/Makefile')
-rw-r--r--www/squid27/Makefile33
1 files changed, 21 insertions, 12 deletions
diff --git a/www/squid27/Makefile b/www/squid27/Makefile
index 78aacde3fc22..07b755491a4a 100644
--- a/www/squid27/Makefile
+++ b/www/squid27/Makefile
@@ -23,7 +23,7 @@
PORTNAME= squid
PORTVERSION= 2.5.4
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -71,7 +71,12 @@ PATCHFILES= squid-2.5.STABLE4-reconfigure_message.patch \
squid-2.5.STABLE4-ldap_tls.patch \
squid-2.5.STABLE4-ldap_group_bufsize.patch \
squid-2.5.STABLE4-http_workarounds.patch \
- squid-2.5.STABLE4-empty_proxy_auth.patch
+ squid-2.5.STABLE4-empty_proxy_auth.patch \
+ squid-2.5.STABLE4-ftp_telnet.patch \
+ squid-2.5.STABLE4-ntlm_auth_popups.patch \
+ squid-2.5.STABLE4-ldap_group-S.patch \
+ squid-2.5.STABLE4-ipcache_purge.patch \
+ squid-2.5.STABLE4-cache_peer_access_ntlm.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -103,9 +108,11 @@ OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
SQUID_VIA_DB "Enable forward/via database" off \
SQUID_CACHE_DIGESTS "Enable cache digests" off \
SQUID_WCCP "Enable Web Cache Coordination Protocol" on \
+ SQUID_UNDERSCORES "Allow underscores in hostnames" on \
SQUID_STRICT_HTTP "Be strictly HTTP compliant" off \
SQUID_IDENT "Enable ident (RFC 931) lookups" on \
- SQUID_USERAGENT_LOG "Enable User-Agent-header logging" off
+ SQUID_USERAGENT_LOG "Enable User-Agent-header logging" off \
+ SQUID_ARP_ACL "Enable ACLs based on ethernet address" off
PLIST_FILES= etc/rc.d/squid.sh etc/squid/mib.txt etc/squid/mime.conf.default \
etc/squid/msntauth.conf.default etc/squid/squid.conf.default \
@@ -117,7 +124,6 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--localstatedir=${PREFIX}/squid \
--enable-storeio="ufs diskd null" \
--enable-removal-policies="lru heap" \
- --enable-underscores
.include <bsd.port.pre.mk>
@@ -140,7 +146,7 @@ CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-external-acl-helpers="${external_acl}" \
--enable-ntlm-auth-helpers="SMB winbind"
-# Options set via 'make config':
+# Other options set via 'make config':
.if defined(WITH_SQUID_DELAY_POOLS)
CONFIGURE_ARGS+= --enable-delay-pools
@@ -172,6 +178,9 @@ CONFIGURE_ARGS+= --enable-cache-digests
.if defined(WITHOUT_SQUID_WCCP)
CONFIGURE_ARGS+= --disable-wccp
.endif
+.if defined(WITH_SQUID_UNDERSCORES)
+CONFIGURE_ARGS+= --enable-underscores
+.endif
.if defined(WITH_SQUID_STRICT_HTTP)
CONFIGURE_ARGS+= --disable-http-violations
.endif
@@ -181,11 +190,14 @@ CONFIGURE_ARGS+= --disable-ident-lookups
.if defined(WITH_SQUID_USERAGENT_LOG)
CONFIGURE_ARGS+= --enable-useragent-log
.endif
+.if defined(WITH_SQUID_ARP_ACL)
+CONFIGURE_ARGS+= --enable-arp-acl
+.endif
# Languages:
#
# If you do not define SQUID_LANGUAGES yourself, all available language files
-# will be installed; the default language will be english.
+# will be installed; the default language will be English.
SQUID_LANGUAGES?= \
Bulgarian Catalan Czech Danish Dutch English Estonian Finnish \
@@ -223,11 +235,8 @@ CONFIGURE_ARGS+= --enable-err-languages="${SQUID_LANGUAGES}" \
# --enable-stacktraces
# Enable automatic call backtrace on fatal errors
#
-# These options do not yet work on FreeBSD:
+# This option does not yet work on FreeBSD:
#
-# --enable-arp-acl
-# Enable ACL based on ethernet address (eg: for machines with dynamic DHCP
-# assigned IP addresses)
# --enable-ipf-transparent
# Enable Transparent Proxy support for IP-Filter systems (incl 3.0)
# (IPFilter headers are not currently installed to the base system,
@@ -254,12 +263,12 @@ pre-install:
>${WRKDIR}/squid.sh
pre-su-install:
- @${SETENV} SQUID_UID=${SQUID_UID} SQUID_GID=${SQUID_GID} \
+ @${SETENV} SQUID_USER=${SQUID_UID} SQUID_GROUP=${SQUID_GID} \
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
.if defined(WITH_SQUID_PINGER)
- ${CHMOD} 4710 ${PREFIX}/libexec/squid/pinger; \
+ ${CHMOD} 4510 ${PREFIX}/libexec/squid/pinger; \
${CHGRP} ${SQUID_GID} ${PREFIX}/libexec/squid/pinger
.endif
${INSTALL_SCRIPT} ${WRKDIR}/squid.sh ${PREFIX}/etc/rc.d