aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid27/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-01-19 11:03:11 +0800
committerijliao <ijliao@FreeBSD.org>2004-01-19 11:03:11 +0800
commit843ee08438b9bbd124bbec72cb824d39f46da8bc (patch)
treec79bcf7cce4a345ef6f6510846d7ad36af7f2d07 /www/squid27/Makefile
parentd855ed43042a482d0f19b4df8165d987ed1b3bc6 (diff)
downloadfreebsd-ports-gnome-843ee08438b9bbd124bbec72cb824d39f46da8bc.tar.gz
freebsd-ports-gnome-843ee08438b9bbd124bbec72cb824d39f46da8bc.tar.zst
freebsd-ports-gnome-843ee08438b9bbd124bbec72cb824d39f46da8bc.zip
- integrate another patch from squid-cache.org, see
http://www.squid-cache.org/Versions/v2/2.5/bugs/ for details - cleanup dynamic plist generation: sort files, replace needlessly complex ex-scripting with a ${REINPLACE_CMD} one-liner - integrate a patch to make the SMB-NTLM helper compile on 5.x and hook this helper up to the build (thanks to Stefano Tagliaferri for reporting the bug and testing the patch) - bump PORTREVISION PR: 61543 Submitted by: maintainer
Diffstat (limited to 'www/squid27/Makefile')
-rw-r--r--www/squid27/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/www/squid27/Makefile b/www/squid27/Makefile
index bed437c96f56..09977535ec08 100644
--- a/www/squid27/Makefile
+++ b/www/squid27/Makefile
@@ -28,7 +28,7 @@
PORTNAME= squid
PORTVERSION= 2.5.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -75,7 +75,8 @@ PATCHFILES= squid-2.5.STABLE4-reconfigure_message.patch \
squid-2.5.STABLE4-partial_reload.patch \
squid-2.5.STABLE4-ldap_tls.patch \
squid-2.5.STABLE4-ldap_group_bufsize.patch \
- squid-2.5.STABLE4-http_workarounds.patch
+ squid-2.5.STABLE4-http_workarounds.patch \
+ squid-2.5.STABLE4-empty_proxy_auth.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -122,7 +123,7 @@ CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-basic-auth-helpers="${basic_auth}" \
--enable-digest-auth-helpers="password" \
--enable-external-acl-helpers="${external_acl}" \
- --enable-ntlm-auth-helpers="winbind"
+ --enable-ntlm-auth-helpers="SMB winbind"
# Languages:
#
@@ -239,21 +240,18 @@ post-install:
.endif
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
# Generate parts of pkg-plist on the fly:
- @cd ${PREFIX} && ${FIND} libexec/squid -type f -o -type l \
+ @cd ${PREFIX} && ${FIND} libexec/squid -type f -o -type l | sort \
>${WRKDIR}/plist.dynamic
@${ECHO_CMD} "@dirrm libexec/squid" >>${WRKDIR}/plist.dynamic
# Only register what we should have installed, there may be local additions
# present:
.for d in ${SQUID_LANGUAGES}
- @cd ${PREFIX} && ${FIND} etc/squid/errors/${d} -type f \
+ @cd ${PREFIX} && ${FIND} etc/squid/errors/${d} -type f | sort \
>>${WRKDIR}/plist.dynamic
@${ECHO_CMD} "@dirrm etc/squid/errors/${d}" >>${WRKDIR}/plist.dynamic
.endfor
- @${ECHO_CMD} "r ${TMPPLIST}" >${WRKDIR}/ex.script
- @${ECHO_CMD} "/Start of dynamically generated plist" >>${WRKDIR}/ex.script
- @${ECHO_CMD} "r ${WRKDIR}/plist.dynamic" >>${WRKDIR}/ex.script
- @${ECHO_CMD} "x!" >>${WRKDIR}/ex.script
- @${CP} -p ${TMPPLIST} ${TMPPLIST}.orig
- @cd ${WRKDIR} && ex <ex.script >/dev/null
+ @${REINPLACE_CMD} -e \
+ '/@comment Start of dynamically generated plist/r${WRKDIR}/plist.dynamic' \
+ ${TMPPLIST}
.include <bsd.port.mk>