aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid31/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-06-03 10:21:13 +0800
committerasami <asami@FreeBSD.org>1996-06-03 10:21:13 +0800
commit481ccf5caea856d90f8348a60fbf6b32a91fb891 (patch)
tree5561645790c0d55e8a3b16bc823f9dca4b5ab8f1 /www/squid31/Makefile
parentf9d4c4e77809771014f306b48d0aaa9bab6e3966 (diff)
downloadfreebsd-ports-gnome-481ccf5caea856d90f8348a60fbf6b32a91fb891.tar.gz
freebsd-ports-gnome-481ccf5caea856d90f8348a60fbf6b32a91fb891.tar.zst
freebsd-ports-gnome-481ccf5caea856d90f8348a60fbf6b32a91fb891.zip
A post-harvest www cache proxy.
Submitted by: Andrew V. Stesin <stesin@elvisti.kiev.ua> and Peter Stubbs <PETERS@staidan.qld.edu.au>
Diffstat (limited to 'www/squid31/Makefile')
-rw-r--r--www/squid31/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
new file mode 100644
index 000000000000..0207ae8f4d12
--- /dev/null
+++ b/www/squid31/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: squid
+# Version required: 1.0.beta11
+# Date created: Fri May 17 04:02:53 EET DST 1996
+# Whom: Andrew Stesin <stesin@elvisti.kiev.ua>
+#
+# $Id$
+#
+
+DISTNAME= squid-1.0.beta11
+PKGNAME= squid-1.0b11
+CATEGORIES+= www
+MASTER_SITES= ftp://www.unimelb.edu.au/pub/cwis/servers/unix/squid/ \
+ ftp://www.nlanr.net/Software/Squid/ \
+ ftp://sunsite.auc.dk/pub/infosystems/squid/ \
+ ftp://ftp.net.lut.ac.uk/squid/
+EXTRACT_SUFX= -src.tar.gz
+
+MAINTAINER= stesin@elvisti.kiev.ua
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
+CONFIGURE_ENV= env "STD_CFLAGS=${CFLAGS}"
+STRIP= # won't install scripts correctly othervise.
+
+post-install:
+.for file in cachemgr.cgi client dnsserver ftpget squid
+ strip ${PREFIX}/bin/${file}
+.endfor
+
+.include <bsd.port.mk>