aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid31/Makefile
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2007-05-25 09:52:13 +0800
committerdelphij <delphij@FreeBSD.org>2007-05-25 09:52:13 +0800
commitd3e2a93110196bdee38cd2e262bad198d88214f7 (patch)
tree50531b505faab232ab6f9d3a6bfa11a9651c591d /www/squid31/Makefile
parentd79b98a43d8e688634ae94f37b75a5760e3b44cd (diff)
downloadfreebsd-ports-gnome-d3e2a93110196bdee38cd2e262bad198d88214f7.tar.gz
freebsd-ports-gnome-d3e2a93110196bdee38cd2e262bad198d88214f7.tar.zst
freebsd-ports-gnome-d3e2a93110196bdee38cd2e262bad198d88214f7.zip
- update to 2.6.STABLE13
- replace sunsite.auc.dk which is no longer serving Squid distfiles (cf fenner's distfile survey) and replace it with ftp.belnet.be. The Squid mirror list seems to have vanished (temporarily) during their website redesign spree but it used to be listed there as an official Belgian mirror. - remove files/extra-patch-changeset_11375 which was added in 2.6.12_1, the fix is present in 2.6.STABLE13. - simplify the SQUID_KQUEUE parsing; Squid-2 will automatically enable kqueue(2) support and the new OPTIONS parser does no longer require .ifndef WITHOUT_* constructs - remove IGNORE for the combination of SQUID_SSL and SQUID_ICAP - (try to) adapt the ICAP-core patch to the changes in the Squid code base - add a +ICAP identifier to the internal Squid version string to help the Squid developers in identifying patched up Squid versions (some reported bugs were not really Squid but rather ICAP bugs it seems) Submitted by: Thomas-Martin Seck (maintainer) PR: ports/112751
Diffstat (limited to 'www/squid31/Makefile')
-rw-r--r--www/squid31/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index d82c16d861c8..0a74f0971cb6 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -75,20 +75,19 @@
# Enable experimental multicast notification of cachemisses.
PORTNAME= squid
-PORTVERSION= 2.6.12
-PORTREVISION= 1
+PORTVERSION= 2.6.13
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://ftp.vistech.net/pub/squid/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
- ftp://sunsite.auc.dk/pub/infosystems/squid/%SUBDIR%/ \
+ ftp://ftp.belnet.be/packages/squid/pub/%SUBDIR%/ \
ftp://ftp.nl.uu.net/pub/unix/www/squid/%SUBDIR%/ \
ftp://ftp.mirrorservice.org/sites/ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://ftp.ntua.gr/pub/www/Squid/%SUBDIR%/ \
ftp://ftp.ccs.neu.edu/pub/mirrors/squid.nlanr.net/pub/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/squid/&,}
MASTER_SITE_SUBDIR= squid-2/STABLE
-DISTNAME= squid-2.6.STABLE12
+DISTNAME= squid-2.6.STABLE13
DIST_SUBDIR= squid2.6
PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
@@ -280,10 +279,6 @@ CONFIGURE_ARGS+= --enable-ssl \
--with-openssl="${OPENSSLBASE}"
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
-.if defined(WITH_SQUID_ICAP)
-IGNORE= is currently broken with both ICAP and SSL support enabled because of conflicting patches. This will be resolved for Squid 2.6.13
-.endif
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-changeset_11375
.endif
.if defined(WITH_SQUID_PINGER)
CONFIGURE_ARGS+= --enable-icmp
@@ -337,7 +332,7 @@ IGNORE= pf available only in FreeBSD 5.3 and newer
# information.
.if defined(WITH_SQUID_IPFILTER)
.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
-IGNORE= IPFilter headers are not part of the base system
+IGNORE= the IPFilter headers are not part of the base system
.else
CONFIGURE_ARGS+= --enable-ipf-transparent
.endif
@@ -351,9 +346,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/icap-2.6-bootstrap.patch \
CONFIGURE_ARGS+= --enable-icap-support
error_files+= ERR_ICAP_FAILURE
.endif
-.if !defined(WITHOUT_SQUID_KQUEUE)
-CONFIGURE_ARGS+= --enable-kqueue
-.else
+.if defined(WITHOUT_SQUID_KQUEUE)
CONFIGURE_ARGS+= --disable-kqueue
.endif
.if defined(WITH_SQUID_LARGEFILE)