aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid31
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-07 02:47:55 +0800
committermnag <mnag@FreeBSD.org>2005-10-07 02:47:55 +0800
commit53d71f3e29ac35dab047f8efcc6dff4c91cb399f (patch)
treeeca5937957c097ac530f89fb7f51812f70be034a /www/squid31
parentb05138ad80f0386326f068da96f577c1c768cb81 (diff)
downloadfreebsd-ports-gnome-53d71f3e29ac35dab047f8efcc6dff4c91cb399f.tar.gz
freebsd-ports-gnome-53d71f3e29ac35dab047f8efcc6dff4c91cb399f.tar.zst
freebsd-ports-gnome-53d71f3e29ac35dab047f8efcc6dff4c91cb399f.zip
Fix smb_auth helper
PR: 86850 Pointed by: Dean M. Phillips <dmphilli@gmail.com> Submitted by: Thomas-Martin Seck <tmseck@netcologne.de> (maintainer)
Diffstat (limited to 'www/squid31')
-rw-r--r--www/squid31/Makefile5
-rw-r--r--www/squid31/files/patch-helpers-basic_auth-SMB-Makefile.in11
-rw-r--r--www/squid31/files/patch-helpers-basic_auth-SMB-smb_auth.sh2
3 files changed, 16 insertions, 2 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 12d4a662a617..f4abc3f3c588 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -70,7 +70,7 @@
PORTNAME= squid
PORTVERSION= 2.5.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -348,6 +348,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%SQUID_UID%%|${SQUID_UID}|g' \
-e 's|%%SQUID_GID%%|${SQUID_GID}|g' ${WRKSRC}/src/cf.data.pre
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/helpers/basic_auth/SMB/Makefile.in \
+ ${WRKSRC}/helpers/basic_auth/SMB/smb_auth.sh
pre-install:
# Prevent installation of .orig files by deleting them.
diff --git a/www/squid31/files/patch-helpers-basic_auth-SMB-Makefile.in b/www/squid31/files/patch-helpers-basic_auth-SMB-Makefile.in
new file mode 100644
index 000000000000..09a82638fd3c
--- /dev/null
+++ b/www/squid31/files/patch-helpers-basic_auth-SMB-Makefile.in
@@ -0,0 +1,11 @@
+--- helpers/basic_auth/SMB/Makefile.in.orig Tue Oct 4 07:29:26 2005
++++ helpers/basic_auth/SMB/Makefile.in Tue Oct 4 07:29:49 2005
+@@ -129,7 +129,7 @@
+ makesnmplib = @makesnmplib@
+
+ SMB_AUTH_HELPER = smb_auth.sh
+-SAMBAPREFIX = /usr/local/samba
++SAMBAPREFIX = %%LOCALBASE%%
+ SMB_AUTH_HELPER_PATH = $(libexecdir)/$(SMB_AUTH_HELPER)
+
+ libexec_SCRIPTS = $(SMB_AUTH_HELPER)
diff --git a/www/squid31/files/patch-helpers-basic_auth-SMB-smb_auth.sh b/www/squid31/files/patch-helpers-basic_auth-SMB-smb_auth.sh
index 8115ac0b7938..8f41fa2ff024 100644
--- a/www/squid31/files/patch-helpers-basic_auth-SMB-smb_auth.sh
+++ b/www/squid31/files/patch-helpers-basic_auth-SMB-smb_auth.sh
@@ -6,7 +6,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-+ SAMBAPREFIX=${SAMBAPREFIX:-/usr/local/bin}
++ SAMBAPREFIX=${SAMBAPREFIX:-%%LOCALBASE%%}
+
read DOMAINNAME
read PASSTHROUGH