aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid31
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-03-14 01:58:51 +0800
committerbeech <beech@FreeBSD.org>2008-03-14 01:58:51 +0800
commitd73ff10b188c3affc953ab5e61517ce15a131f8f (patch)
treedcc204e13021bdceb72a80a14bdf1353e04ad05c /www/squid31
parentb34f1dd1a8102c0f0750f0fe0381495064f9c2be (diff)
downloadfreebsd-ports-gnome-d73ff10b188c3affc953ab5e61517ce15a131f8f.tar.gz
freebsd-ports-gnome-d73ff10b188c3affc953ab5e61517ce15a131f8f.tar.zst
freebsd-ports-gnome-d73ff10b188c3affc953ab5e61517ce15a131f8f.zip
- Update to 3.0.STABLE2
- Add a patch for Squid bug #2203: compilation of authentication helper applications that required additional libraries from $LOCALBASE broke when --with-maxfd=N was set via SQUID_CONFIGURE_ARGS PR: ports/121649 Submitted by: Thomas-Martin Seck <tmseck@web.de> (maintainer)
Diffstat (limited to 'www/squid31')
-rw-r--r--www/squid31/Makefile14
-rw-r--r--www/squid31/distinfo6
-rw-r--r--www/squid31/files/patch-configure23
3 files changed, 37 insertions, 6 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 419933d8250c..b8cf265d694f 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -62,7 +62,7 @@
# requests.
PORTNAME= squid
-PORTVERSION= 3.0.1
+PORTVERSION= 3.0.2
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
@@ -81,7 +81,7 @@ MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://www1.jp.squid-cache.org/Versions/v3/3.0/ \
http://www2.tw.squid-cache.org/Versions/v3/3.0/
MASTER_SITE_SUBDIR= squid-3/STABLE
-DISTNAME= squid-3.0.STABLE1
+DISTNAME= squid-3.0.STABLE2
DIST_SUBDIR= squid3.0
PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
@@ -378,7 +378,8 @@ SQUID_LANGUAGES?= Armenian Azerbaijani Bulgarian Catalan Czech Danish \
Hebrew Hungarian Italian Japanese Korean Lithuanian \
Polish Portuguese Romanian Russian-1251 Russian-koi8-r \
Serbian Simplify_Chinese Slovak Spanish Swedish \
- Traditional_Chinese Turkish
+ Traditional_Chinese Turkish Ukrainian-1251 \
+ Ukrainian-koi8-u Ukrainian-utf8
SQUID_DEFAULT_LANG?= English
CONFIGURE_ARGS+= --enable-err-languages="${SQUID_LANGUAGES}" \
--enable-default-err-language=${SQUID_DEFAULT_LANG}
@@ -411,6 +412,13 @@ pre-install:
# Prevent installation of .orig files by deleting them.
@${FIND} ${WRKSRC} -name '*.bak' -delete
@${FIND} ${WRKSRC} -name '*.orig' -delete
+# XXX:
+# Remove error pages that were prematurely integrated into 3.0.STABLE2.
+# This is done to keep the package list manageable by installing the same
+# set of error files for every language:
+ @for d in Ukrainian-1251 Ukrainian-koi8-u Ukrainian-utf8; \
+ do ${RM} -f ${WRKSRC}/errors/$${d}/ERR_SECURE_CONNECT_FAIL; \
+ done
pre-su-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX=${PREFIX} \
diff --git a/www/squid31/distinfo b/www/squid31/distinfo
index bd86c915317e..5d8a98f0eab0 100644
--- a/www/squid31/distinfo
+++ b/www/squid31/distinfo
@@ -1,3 +1,3 @@
-MD5 (squid3.0/squid-3.0.STABLE1.tar.bz2) = ec7458b00a68341854d91e7f6ece56ba
-SHA256 (squid3.0/squid-3.0.STABLE1.tar.bz2) = 3ebf3e22998b608afcfc10f29991722b5df5636217df6498902302dd05f4ab6c
-SIZE (squid3.0/squid-3.0.STABLE1.tar.bz2) = 1816804
+MD5 (squid3.0/squid-3.0.STABLE2.tar.bz2) = 33c89b22aaf27d12b818b5f120aa0322
+SHA256 (squid3.0/squid-3.0.STABLE2.tar.bz2) = eabace0fd4f61a49389d1dffb20705b4a22ba8d65e281e6c5fff47c1aeef2ed1
+SIZE (squid3.0/squid-3.0.STABLE2.tar.bz2) = 1822143
diff --git a/www/squid31/files/patch-configure b/www/squid31/files/patch-configure
new file mode 100644
index 000000000000..7f31aa96e0c2
--- /dev/null
+++ b/www/squid31/files/patch-configure
@@ -0,0 +1,23 @@
+Patch for Squid bug #2203:
+
+LDFLAGS gets unset when --with-filedescriptors=n is added to
+SQUID_CONFIGURE_ARGS.
+
+--- configure.orig Fri Dec 14 01:25:27 2007
++++ configure Thu Jan 24 19:56:32 2008
+@@ -43934,6 +43934,7 @@
+ esac
+ { echo "$as_me:$LINENO: result: $SQUID_MAXFD" >&5
+ echo "${ECHO_T}$SQUID_MAXFD" >&6; }
++ LDFLAGS="$TLDFLAGS"
+ fi
+
+ cat >>confdefs.h <<_ACEOF
+@@ -43947,7 +43948,6 @@
+ echo " on how to increase your filedescriptor limit"
+ sleep 10
+ fi
+-LDFLAGS="$TLDFLAGS"
+
+ if test `expr $SQUID_MAXFD % 64` != 0; then
+ echo "WARNING: $SQUID_MAXFD is not an multiple of 64. This may cause issues"