aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-26 07:38:48 +0800
committeredwin <edwin@FreeBSD.org>2005-12-26 07:38:48 +0800
commitb24006b99a6a4ed1dc823cf6e6bbe9cb842fc723 (patch)
treed640640b230532aafe8004fa73bb04e0ab5c4ea2 /www/squid
parent84c44a3e34194632fb3781c9db61a908017714bc (diff)
downloadfreebsd-ports-gnome-b24006b99a6a4ed1dc823cf6e6bbe9cb842fc723.tar.gz
freebsd-ports-gnome-b24006b99a6a4ed1dc823cf6e6bbe9cb842fc723.tar.zst
freebsd-ports-gnome-b24006b99a6a4ed1dc823cf6e6bbe9cb842fc723.zip
[Maintainer] www/squid: rc(8) related fixups
- Fix rc(8) preamble in the squid run script - Use the .sh suffix only for the old style script - Do not refer to "rcNG" in pkg-install anymore, rcNG is the default rc style by now - Bump PORTREVISION (to mark this change and because the package content changes) PR: ports/90858 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de>
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile10
-rw-r--r--www/squid/files/squid.sh5
-rw-r--r--www/squid/pkg-install6
3 files changed, 11 insertions, 10 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 1f75bf5d90f8..6151e7e8bb6a 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -73,7 +73,7 @@
PORTNAME= squid
PORTVERSION= 2.5.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -132,7 +132,7 @@ OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
SQUID_STACKTRACES "Create backtraces on fatal errors" off \
SQUID_RCNG "Install an rcNG startup script" on
-etc_files= rc.d/squid.sh squid/cachemgr.conf.default \
+etc_files= rc.d/squid${rc_suffix} squid/cachemgr.conf.default \
squid/mib.txt squid/mime.conf.default \
squid/msntauth.conf.default squid/squid.conf.default
@@ -317,9 +317,11 @@ STRIP= ""
USE_RC_SUBR= yes
rc_del= rcold
rc_state= rcng
+rc_suffix=
.else
rc_del= rcng
rc_state= rcold
+rc_suffix= .sh
.endif
# Languages:
@@ -364,7 +366,7 @@ pre-install:
# Prevent installation of .orig files by deleting them.
@${FIND} ${WRKSRC} -name '*.bak' -delete
@${FIND} ${WRKSRC} -name '*.orig' -delete
-# create an rcOld/rcNG squid.sh:
+# create the start script:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%SQUID_UID%%|${SQUID_UID}|g' \
-e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
@@ -386,7 +388,7 @@ post-install:
${CHMOD} 4510 ${PREFIX}/libexec/squid/pinger; \
${CHGRP} ${SQUID_GID} ${PREFIX}/libexec/squid/pinger
.endif
- ${INSTALL_SCRIPT} ${WRKDIR}/squid.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${WRKDIR}/squid.sh ${PREFIX}/etc/rc.d/squid${rc_suffix}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${docs} ${DOCSDIR}
diff --git a/www/squid/files/squid.sh b/www/squid/files/squid.sh
index a46c9dc7bf4d..fef206cefc77 100644
--- a/www/squid/files/squid.sh
+++ b/www/squid/files/squid.sh
@@ -4,9 +4,8 @@
#
# --begin rcng
# PROVIDE: squid
-# REQUIRE: NETWORKING SERVERS
-# BEFORE: DAEMON
-# KEYWORD: FreeBSD shutdown
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
#
# Note:
# Set "squid_enable=yes" in either /etc/rc.conf, /etc/rc.conf.local or
diff --git a/www/squid/pkg-install b/www/squid/pkg-install
index 19e4a434a409..2fe7823411a2 100644
--- a/www/squid/pkg-install
+++ b/www/squid/pkg-install
@@ -147,13 +147,13 @@ POST-INSTALL)
echo " initialize the cache directory by running \"squid -z\""
echo " as 'root' or '${squid_user}' before starting squid."
echo ""
- echo " Please note that ${PKG_PREFIX}/etc/rc.d/squid.sh is now"
- echo " an rcNG script by default. This means that squid will not"
+ echo " Please note that ${PKG_PREFIX}/etc/rc.d/squid is a"
+ echo " new style rc script. This means that squid will not"
echo " start automatically at boot time."
echo ""
echo " To enable squid, set squid_enable=yes in either"
echo " /etc/rc.conf, /etc/rc.conf.local or /etc/rc.conf.d/squid"
- echo " See ${PKG_PREFIX}/etc/rc.d/squid.sh for more"
+ echo " See ${PKG_PREFIX}/etc/rc.d/squid for more"
echo " configuration options."
echo ""
echo " If you want the port to install an old style rc script, run"