aboutsummaryrefslogtreecommitdiffstats
path: root/www/squidguard
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-09-23 10:08:28 +0800
committeredwin <edwin@FreeBSD.org>2008-09-23 10:08:28 +0800
commit1669a84a186f4d9c4b199cf0c81ba0e8ad8a80a4 (patch)
tree5c4101a87866f0853366cf94a11ecd39200e90f6 /www/squidguard
parent31faf4cde15107b96f8bd69a666b286761f0f820 (diff)
downloadfreebsd-ports-gnome-1669a84a186f4d9c4b199cf0c81ba0e8ad8a80a4.tar.gz
freebsd-ports-gnome-1669a84a186f4d9c4b199cf0c81ba0e8ad8a80a4.tar.zst
freebsd-ports-gnome-1669a84a186f4d9c4b199cf0c81ba0e8ad8a80a4.zip
Move the CHOWN to the build-phase where the usernames actually exist.
Noticed by: QAT.
Diffstat (limited to 'www/squidguard')
-rw-r--r--www/squidguard/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/www/squidguard/Makefile b/www/squidguard/Makefile
index 3a679138d87d..069b654a9dfb 100644
--- a/www/squidguard/Makefile
+++ b/www/squidguard/Makefile
@@ -7,6 +7,7 @@
PORTNAME= squidGuard
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.squidguard.org/Downloads/
@@ -71,7 +72,6 @@ post-build:
@${MV} -f ${_DATADIR}/blacklists/README ${WRKDIR}/README.blacklists
@${MV} -f ${_DATADIR}/blacklists/* ${_DATADIR}/
@${RM} -r ${_DATADIR}/blacklists
- @${CHOWN} -R ${SQUID_UID}:${SQUID_GID} ${_DATADIR}
.endif
pre-install:
@@ -82,6 +82,7 @@ pre-install:
@${ECHO_MSG} "===> Installing blacklists"
@${MKDIR} ${DATADIR}
@${CP} -Rpf ${_DATADIR}/* ${DATADIR}/
+ @${CHOWN} -R ${SQUID_UID}:${SQUID_GID} ${DATADIR}
@${CHMOD} -R 550 ${DATADIR}
@${ECHO_MSG} " -> Blacklists installed in: ${DATADIR}"
.else