aboutsummaryrefslogtreecommitdiffstats
path: root/www/suphp/Makefile
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-02-25 19:47:24 +0800
committerclement <clement@FreeBSD.org>2004-02-25 19:47:24 +0800
commit2193c1435b7c5f5276333d553cfe16245a7160c1 (patch)
tree93924dc1b6593f671ac6948715d1c09f54986774 /www/suphp/Makefile
parent9e21939a32c1a7526e3b5288b196373588edc1ef (diff)
downloadfreebsd-ports-gnome-2193c1435b7c5f5276333d553cfe16245a7160c1.tar.gz
freebsd-ports-gnome-2193c1435b7c5f5276333d553cfe16245a7160c1.tar.zst
freebsd-ports-gnome-2193c1435b7c5f5276333d553cfe16245a7160c1.zip
- Update to 0.5.1
This version is mainly a bugfix release, fixing a bug causing a segmentation fault in the Apache 2 module and improving the handling of environment variables. Instead of setting unneeded / unwanted environment variables to an empty string, they are now completely removed from the environment.
Diffstat (limited to 'www/suphp/Makefile')
-rw-r--r--www/suphp/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/www/suphp/Makefile b/www/suphp/Makefile
index a1294a574332..afd795bf0b1c 100644
--- a/www/suphp/Makefile
+++ b/www/suphp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= suphp
-PORTVERSION= 0.5
-PORTREVISION= 2
+PORTVERSION= 0.5.1
CATEGORIES= www
MASTER_SITES= http://www.suphp.org/download/
@@ -27,6 +26,9 @@ APACHE_USER?= ${WWWOWN}
MIN_UID?= 80
MIN_GID?= 80
WITH_SETID_MODE?= owner
+MYPORTDOCS= apache/CONFIG apache/INSTALL apache/README apache/LICENSE \
+ LICENSE INSTALL README
+LANG= en de
CONFIGURE_ARGS+= --with-php=${PHP_PATH} \
--with-logfile=${LOG_PATH}/suphp.log \
@@ -48,7 +50,7 @@ CONFIGURE_ARGS+= --disable-checkuid
.if defined(WITHOUT_CHECKGID)
CONFIGURE_ARGS+= --disable-checkgid
.endif
-## WITH_SETID_MODE: Mode to use for setting UID/GID.
+## WITH_SETID_MODE: Mode to use for setting UID/GID.
CONFIGURE_ARGS+= --enable-setid=${WITH_SETID_MODE}
.include <bsd.port.pre.mk>
@@ -69,7 +71,12 @@ pre-everything::
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${CP} -Rfp ${WRKSRC}/doc/* ${DOCSDIR}
+.for l in ${LANG}
+ @${MKDIR} ${DOCSDIR}/${l}/apache
+. for f in ${MYPORTDOCS}
+ @${CP} -Rfp ${WRKSRC}/doc/${l}/${f} ${DOCSDIR}/${l}/${f}
+. endfor
+.endfor
.endif
@${CAT} ${PKGMESSAGE}