aboutsummaryrefslogtreecommitdiffstats
path: root/www/tclhttpd
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2001-06-15 05:20:34 +0800
committermi <mi@FreeBSD.org>2001-06-15 05:20:34 +0800
commitf5b285cc4d4c695268d38d59c4ce304fad5f7190 (patch)
treeef4b108d0911f979cbbe3ba0fb713afd6206babb /www/tclhttpd
parent00a80cd85135aa45ebc1da892aa473f08b6f66e4 (diff)
downloadfreebsd-ports-gnome-f5b285cc4d4c695268d38d59c4ce304fad5f7190.tar.gz
freebsd-ports-gnome-f5b285cc4d4c695268d38d59c4ce304fad5f7190.tar.zst
freebsd-ports-gnome-f5b285cc4d4c695268d38d59c4ce304fad5f7190.zip
The better fix for ports/27337 is, IMO, to also install the man-page as
tclhttpd.1 instead of the too generic (and usurped by Apache) httpd.1...
Diffstat (limited to 'www/tclhttpd')
-rw-r--r--www/tclhttpd/Makefile4
-rw-r--r--www/tclhttpd/files/patch-ab5
2 files changed, 6 insertions, 3 deletions
diff --git a/www/tclhttpd/Makefile b/www/tclhttpd/Makefile
index bbb321f2fa14..4ac69f0ae000 100644
--- a/www/tclhttpd/Makefile
+++ b/www/tclhttpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tclhttpd
PORTVERSION= 3.3
+PORTREVISION= 1
CATEGORIES= www tcl${TCL_VER}
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= httpd
@@ -23,6 +24,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl="${LOCALBASE}/lib/tcl${TCL_DVER}" \
--with-tclinclude="${LOCALBASE}/include/tcl${TCL_DVER}"
+MAN1= tclhttpd.1
RCD= ${LOCALBASE}/etc/rc.d/tclhttpd.sh
.include <bsd.port.pre.mk>
@@ -31,8 +33,6 @@ PLIST_SUB+= TCL_VER=${TCL_VER} PORTVERSION=${PORTVERSION} \
SHLIB_NAME=${SHLIB_NAME}
MAKE_ENV+= TCLSH_PROG=tclsh${TCL_DVER}
-MAN1= httpd.1
-
do-build:
cd ${WRKSRC} && ${MAKE_ENV} ${MAKE} -j 2 TCL_DVER="${TCL_DVER}" \
FILESDIR="${FILESDIR}" -f "${FILESDIR}/Makefile.lib"
diff --git a/www/tclhttpd/files/patch-ab b/www/tclhttpd/files/patch-ab
index 6a2d4729d733..8a95f84c0d89 100644
--- a/www/tclhttpd/files/patch-ab
+++ b/www/tclhttpd/files/patch-ab
@@ -1,5 +1,5 @@
--- Makefile.in Wed Apr 26 16:35:29 2000
-+++ Makefile.in Thu Apr 27 16:24:39 2000
++++ Makefile.in Thu Jun 14 17:02:56 2001
@@ -124,3 +124,3 @@
SERVER_ROOT = @SERVER_ROOT@
-htdocsdir = $(SERVER_ROOT)/htdocs
@@ -25,6 +25,9 @@
-install: all install-binaries install-libraries install-doc
+install: all install-libraries install-doc
+@@ -330,1 +330,1 @@
+- $(INSTALL_DATA) $(srcdir)/doc/httpd.1 $(mandir)/man1/httpd.1
++ $(INSTALL_DATA) $(srcdir)/doc/httpd.1 $(mandir)/man1/tclhttpd.1
@@ -335,3 +335,3 @@
installdirs:
- $(mkinstalldirs) $(pkglibdir) $(cryptlibdir) $(prefix)/bin $(htdocsdir) $(customdir)