aboutsummaryrefslogtreecommitdiffstats
path: root/www/tdiary/Makefile
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-29 13:53:24 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-29 13:53:24 +0800
commit5d8884909960b9823dd8b16be4137a6b42ed7a17 (patch)
treeee65f3a3b34b7c7ff2b297caeb37a6639e7a995b /www/tdiary/Makefile
parent588a7646999b0745adf4cf56711abdb4fd67b9f0 (diff)
downloadfreebsd-ports-gnome-5d8884909960b9823dd8b16be4137a6b42ed7a17.tar.gz
freebsd-ports-gnome-5d8884909960b9823dd8b16be4137a6b42ed7a17.tar.zst
freebsd-ports-gnome-5d8884909960b9823dd8b16be4137a6b42ed7a17.zip
update www/tdiary:
- Change of an installation script - add RUBY_SHEBANG_FILES to Makefile PR: 55000 Submitted by: Fumihiko Kimura <jfkimura@yahoo.co.jp> (maintainer)
Diffstat (limited to 'www/tdiary/Makefile')
-rw-r--r--www/tdiary/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/tdiary/Makefile b/www/tdiary/Makefile
index c960f4cedec8..4a933ae10043 100644
--- a/www/tdiary/Makefile
+++ b/www/tdiary/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tdiary
PORTVERSION= 1.5.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www ruby
MASTER_SITES= \
${MASTER_SITE_SOURCEFORGE} \
@@ -27,6 +27,8 @@ RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/web/escape_ext.so:${PORTSDIR}/www/ruby-nora
NO_BUILD= yes
USE_RUBY= yes
+RUBY_SHEBANG_FILES= index.rb update.rb misc/convert2.rb misc/posttdiary.rb misc/plugin/squeeze.rb misc/plugin/weather.rb \
+misc/plugin/windex.rb misc/plugin/a/a_conf.rb misc/plugin/todo/todo.rb misc/plugin/trackback/tb.rb
TDIARYDIR= ${PREFIX}/share/examples/${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -47,8 +49,11 @@ pre-everything::
@${ECHO_MSG}
do-install:
- @if [ -d ${TDIARYDIR} ]; then ${RM} -rf ${TDIARYDIR}; fi
- ${MKDIR} ${TDIARYDIR}
+# @if [ -d ${TDIARYDIR} ]; then ${RM} -rf ${TDIARYDIR}; fi
+ -${MKDIR} ${TDIARYDIR}
+ @${SED} -e 's,@@@@PREFIX@@@@,${PREFIX},g' \
+ -e 's,@@@@LANG@@@@,${TDIARY_LANG},g' \
+ ${FILESDIR}/tdiaryinst.rb.in > ${TDIARYDIR}/tdiaryinst.rb
@${SED} -e 's,@@@@PREFIX@@@@,${PREFIX},g' \
-e 's,@@@@LANG@@@@,${TDIARY_LANG},g' \
${FILESDIR}/tdiary-FreeBSD.sh.in > ${TDIARYDIR}/tdiary-FreeBSD.sh