aboutsummaryrefslogtreecommitdiffstats
path: root/www/tdom
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-20 19:41:05 +0800
committermiwi <miwi@FreeBSD.org>2007-03-20 19:41:05 +0800
commit8eb772496e3f7f53121a1c92e9cc39e413831e1d (patch)
treea5dd6544ab4282cb7747fab9dee9f3bd3cffd3c7 /www/tdom
parent0d81a1fe593f2b944f452b9bf27f206f453623fd (diff)
downloadfreebsd-ports-gnome-8eb772496e3f7f53121a1c92e9cc39e413831e1d.tar.gz
freebsd-ports-gnome-8eb772496e3f7f53121a1c92e9cc39e413831e1d.tar.zst
freebsd-ports-gnome-8eb772496e3f7f53121a1c92e9cc39e413831e1d.zip
- Added support for the new tcl threads structure.
PR: 110405 Submitted by: Martin Matuska <martin@matuska.org> (Maintainer)
Diffstat (limited to 'www/tdom')
-rw-r--r--www/tdom/Makefile32
1 files changed, 5 insertions, 27 deletions
diff --git a/www/tdom/Makefile b/www/tdom/Makefile
index 3f11abe77a79..130322d278d4 100644
--- a/www/tdom/Makefile
+++ b/www/tdom/Makefile
@@ -7,10 +7,9 @@
PORTNAME= tDOM
PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.tdom.org/files/
-PKGNAMESUFFIX?= -threads
MAINTAINER= martin@matuska.org
COMMENT= High performance XML data processing with Tcl (ARGS for OpenACS)
@@ -25,8 +24,7 @@ IGNORE= supported values for USE_TCL_VER are only 84 and 85
.endif
# by default we want a threaded build
-USE_TCL= ${USE_TCL_VER}-thread
-USE_TCL_BUILD= ${USE_TCL_VER}-thread
+LIB_DEPENDS= tcl${USE_TCL_VER}-threads:${PORTSDIR}/lang/tcl${USE_TCL_VER}-thread
USE_GMAKE= yes
HAS_CONFIGURE= yes
@@ -46,29 +44,9 @@ HTMLDOCS= category-index.html dom.html domDoc.html domNode.html \
.include <bsd.port.pre.mk>
-.if exists(${TCLSH})
-_TCL_IS_THREADED!= ${ECHO_CMD} 'puts [array names tcl_platform -exact threaded]' | ${TCLSH} || return 0
-. if empty(_TCL_IS_THREADED)
-# Check if a threaded build is forced
-. if defined(TCL_WITH_THREADS) || defined(WITH_THREADS)
-IGNORE= tcl with threads is required. Please install tcl with WITH_THREADS defined or from lang/tcl${USE_TCL} port and try again
-. else
-# Installed tcl is not threaded, so set correct dependencies
-CONFIGURE_ARGS+= --disable-threads
-PKGNAMESUFFIX=
-USE_TCL=${USE_TCL_VER}
-USE_TCL_BUILD=${USE_TCL_VER}
-.include "${PORTSDIR}/Mk/bsd.tcl.mk"
-. endif
-. else
-CONFIGURE_ARGS+= --enable-threads
-. endif
-.else
-CONFIGURE_ARGS+= --enable-threads
-.endif
-
-CONFIGURE_ARGS+= -disable-tdomalloc --with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR} --prefix=${PREFIX}
+CONFIGURE_ARGS+= --enable-threads --disable-tdomalloc \
+ --with-tcl=${LOCALBASE}/lib/tcl${USE_TCL_VER:S/8/8./}-threads \
+ --with-tclinclude=${LOCALBASE}/include/tcl${USE_TCL_VER:S/8/8./} --prefix=${PREFIX}
post-install:
.if !defined(NOPORTDOCS)