aboutsummaryrefslogtreecommitdiffstats
path: root/www/tdom
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2008-02-29 19:17:57 +0800
committermm <mm@FreeBSD.org>2008-02-29 19:17:57 +0800
commit880201478b5621e50cae5c7b1281b20d7aef74ff (patch)
tree0a14891741ff50c16cdfe975f96e28c09ee0ed66 /www/tdom
parenta09a7946be335a6513fa861993fc3f93ee6c011c (diff)
downloadfreebsd-ports-gnome-880201478b5621e50cae5c7b1281b20d7aef74ff.tar.gz
freebsd-ports-gnome-880201478b5621e50cae5c7b1281b20d7aef74ff.tar.zst
freebsd-ports-gnome-880201478b5621e50cae5c7b1281b20d7aef74ff.zip
- Update to 0.8.2
Suggested by: mi Patches by: mi
Diffstat (limited to 'www/tdom')
-rw-r--r--www/tdom/Makefile10
-rw-r--r--www/tdom/distinfo6
-rw-r--r--www/tdom/files/patch-Makefile.in9
-rw-r--r--www/tdom/files/patch-configure36
-rw-r--r--www/tdom/files/patch-expat-xmlparse.h16
-rw-r--r--www/tdom/files/patch-generic-dom.h8
-rw-r--r--www/tdom/files/patch-generic-tclexpat.c9
-rw-r--r--www/tdom/pkg-plist1
8 files changed, 90 insertions, 5 deletions
diff --git a/www/tdom/Makefile b/www/tdom/Makefile
index c57b6d16881b..c8063802c6cc 100644
--- a/www/tdom/Makefile
+++ b/www/tdom/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= tDOM
-PORTVERSION= 0.8.0
-PORTREVISION= 2
+PORTVERSION= 0.8.2
CATEGORIES= www
MASTER_SITES= http://www.tdom.org/files/
+EXTRACT_SUFX= .tgz
MAINTAINER= mm@FreeBSD.org
COMMENT= High performance XML data processing with Tcl (ARGS for OpenACS)
@@ -24,6 +24,9 @@ USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= ../configure
+pre-configure:
+ ${RM} -f ${WRKSRC}/../generic/domalloc.?
+
USE_LDCONFIG= ${TDOMBASE}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -36,6 +39,9 @@ HTMLDOCS= category-index.html dom.html domDoc.html domNode.html \
expat.html expatapi.html index.html keyword-index.html \
tdomcmd.html tnc.html
+post-build test:
+ ${SETENV} LANG=C ${MAKE} -C ${WRKSRC} test
+
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --enable-threads --disable-tdomalloc \
diff --git a/www/tdom/distinfo b/www/tdom/distinfo
index b1b03bd38532..e3e45c60a649 100644
--- a/www/tdom/distinfo
+++ b/www/tdom/distinfo
@@ -1,3 +1,3 @@
-MD5 (tDOM-0.8.0.tar.gz) = 90626edf33b7a77229a23b9132f74977
-SHA256 (tDOM-0.8.0.tar.gz) = 1a05313dac523f0eef5b0b4e6b801ede7089badef9921293ddad822921f74d2f
-SIZE (tDOM-0.8.0.tar.gz) = 886455
+MD5 (tDOM-0.8.2.tgz) = 67790846eb5ec13852a3bf3c382d86dc
+SHA256 (tDOM-0.8.2.tgz) = 561e482b95906b5a64b69cbc7c13d01b7a34a95144744796fbc1219042cd5843
+SIZE (tDOM-0.8.2.tgz) = 969804
diff --git a/www/tdom/files/patch-Makefile.in b/www/tdom/files/patch-Makefile.in
new file mode 100644
index 000000000000..dbf4a340dc3a
--- /dev/null
+++ b/www/tdom/files/patch-Makefile.in
@@ -0,0 +1,9 @@
+--- ../Makefile.in 2007-03-02 18:43:53.000000000 -0500
++++ ../Makefile.in 2008-02-14 15:21:19.000000000 -0500
+@@ -110,5 +110,5 @@
+ EXEEXT = @EXEEXT@
+ LDFLAGS_DEFAULT = @LDFLAGS_DEFAULT@
+-MAKE_LIB = @MAKE_LIB@
++MAKE_LIB = @MAKE_LIB@ ${LDFLAGS_DEFAULT}
+ MAKE_SHARED_LIB = @MAKE_SHARED_LIB@
+ MAKE_STATIC_LIB = @MAKE_STATIC_LIB@
diff --git a/www/tdom/files/patch-configure b/www/tdom/files/patch-configure
new file mode 100644
index 000000000000..7dea81ebc6dc
--- /dev/null
+++ b/www/tdom/files/patch-configure
@@ -0,0 +1,36 @@
+--- ../configure 2007-08-05 14:47:49.000000000 -0400
++++ ../configure 2008-02-14 14:16:33.000000000 -0500
+@@ -6169,5 +6169,5 @@
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char $ac_func ();
++void * $ac_func ();
+ /* The GNU C library defines this for functions which it implements
+ to always fail with ENOSYS. Some functions are actually named
+@@ -6176,5 +6176,5 @@
+ choke me
+ #else
+-char (*f) () = $ac_func;
++void * (*f) () = $ac_func;
+ #endif
+ #ifdef __cplusplus
+@@ -6305,5 +6305,4 @@
+ generic/utf8conv.c \
+ generic/dom.c \
+- generic/domalloc.c \
+ generic/domhtml.c \
+ generic/domxpath.c \
+@@ -7263,5 +7262,5 @@
+ if test "$GCC" = "yes" ; then
+ CFLAGS_OPTIMIZE=-O2
+- CFLAGS_WARNING="-Wall -Wno-implicit-int"
++ CFLAGS_WARNING="-Wall -Wno-implicit-int -Wno-uninitialized"
+ else
+ CFLAGS_WARNING=""
+@@ -8404,5 +8401,5 @@
+ LIBS=`echo $LIBS | sed s/-pthread//`
+ CFLAGS="$CFLAGS -pthread"
+- LDFLAGS="$LDFLAGS -pthread"
++ LDFLAGS="$LDFLAGS"
+ fi
+ case $system in
diff --git a/www/tdom/files/patch-expat-xmlparse.h b/www/tdom/files/patch-expat-xmlparse.h
new file mode 100644
index 000000000000..12368b8a3a5e
--- /dev/null
+++ b/www/tdom/files/patch-expat-xmlparse.h
@@ -0,0 +1,16 @@
+--- ../expat/xmlparse.c 2007-07-30 20:16:28.000000000 -0400
++++ ../expat/xmlparse.c 2008-02-14 14:20:27.000000000 -0500
+@@ -1476,5 +1476,5 @@
+ const char *end;
+ int nLeftOver;
+- enum XML_Error result;
++ enum XML_Error result = XML_STATUS_ERROR;
+ parseEndByteIndex += len;
+ positionPtr = s;
+@@ -1500,4 +1500,6 @@
+ return result;
+ }
++ case XML_FINISHED:
++ /* nothing */;
+ }
+ }
diff --git a/www/tdom/files/patch-generic-dom.h b/www/tdom/files/patch-generic-dom.h
new file mode 100644
index 000000000000..bca37d3f418e
--- /dev/null
+++ b/www/tdom/files/patch-generic-dom.h
@@ -0,0 +1,8 @@
+--- ../generic/dom.h 2007-08-08 11:52:38.000000000 -0400
++++ ../generic/dom.h 2008-02-14 14:27:46.000000000 -0500
+@@ -41,5 +41,4 @@
+ #include <expat.h>
+ #include <utf8conv.h>
+-#include <domalloc.h>
+
+ /*
diff --git a/www/tdom/files/patch-generic-tclexpat.c b/www/tdom/files/patch-generic-tclexpat.c
new file mode 100644
index 000000000000..c50370e289e2
--- /dev/null
+++ b/www/tdom/files/patch-generic-tclexpat.c
@@ -0,0 +1,9 @@
+--- ../generic/tclexpat.c 2007-08-07 13:54:16.000000000 -0400
++++ ../generic/tclexpat.c 2008-02-14 14:35:48.000000000 -0500
+@@ -43,4 +43,6 @@
+ #ifdef _MSC_VER
+ #include <io.h>
++#else
++#include <unistd.h> /* read() and close() live there */
+ #endif
+
diff --git a/www/tdom/pkg-plist b/www/tdom/pkg-plist
index e78d317bfb50..2ffe9fe6b71f 100644
--- a/www/tdom/pkg-plist
+++ b/www/tdom/pkg-plist
@@ -1,3 +1,4 @@
+include/tdom.h
lib/tdom%%PORTVERSION%%/libtdom%%PORTVERSION%%.so
lib/tdom%%PORTVERSION%%/libtdomstub%%PORTVERSION%%.a
lib/tdom%%PORTVERSION%%/pkgIndex.tcl