aboutsummaryrefslogtreecommitdiffstats
path: root/www/tdom
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2018-10-14 22:54:59 +0800
committermi <mi@FreeBSD.org>2018-10-14 22:54:59 +0800
commit70e4329aebdf51897867547840d4e82d7f19d902 (patch)
tree3d41ef4a4a314af05780780af5c3bab8d879c7c1 /www/tdom
parentff1c68b3805805cb92c3e667d62f8eccf41cce26 (diff)
downloadfreebsd-ports-gnome-70e4329aebdf51897867547840d4e82d7f19d902.tar.gz
freebsd-ports-gnome-70e4329aebdf51897867547840d4e82d7f19d902.tar.zst
freebsd-ports-gnome-70e4329aebdf51897867547840d4e82d7f19d902.zip
Upgrade from 0.9.0 to 0.9.1.
PR: 231663 Submitted by: gahr
Diffstat (limited to 'www/tdom')
-rw-r--r--www/tdom/Makefile5
-rw-r--r--www/tdom/distinfo6
-rw-r--r--www/tdom/files/patch-Makefile.in22
-rw-r--r--www/tdom/files/patch-generic-dom.h10
-rw-r--r--www/tdom/files/patch-tests-tdom10
-rw-r--r--www/tdom/pkg-plist2
6 files changed, 40 insertions, 15 deletions
diff --git a/www/tdom/Makefile b/www/tdom/Makefile
index 596e878df8e5..87528210f857 100644
--- a/www/tdom/Makefile
+++ b/www/tdom/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tDOM
-PORTVERSION= 0.9.0
+PORTVERSION= 0.9.1
CATEGORIES= www
MASTER_SITES= http://tdom.org/downloads/
DISTNAME= ${PORTNAME:tl}-${PORTVERSION}
@@ -11,10 +11,11 @@ EXTRACT_SUFX= -src.tgz
MAINTAINER= mi@aldan.algebra.com
COMMENT= High performance processing of XML and HTML data with Tcl
-LICENSE= MPL11
+LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= tcl:tea
+
CONFIGURE_ARGS= --enable-threads --disable-tdomalloc
CONFIGURE_ARGS+=--with-expat=/usr
EXTRACT_AFTER_ARGS=--exclude 'expat*/*.c' --exclude 'expat*/[a-mo-z]*.h' \
diff --git a/www/tdom/distinfo b/www/tdom/distinfo
index 50ddd6e6bb60..10d6b100db6c 100644
--- a/www/tdom/distinfo
+++ b/www/tdom/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1517858044
-SHA256 (tdom-0.9.0-src.tgz) = 201e7f1b0df28b1f1921d9ec18f1ffd5a1b558c0509c54c88206b65a81ba2740
-SIZE (tdom-0.9.0-src.tgz) = 1065288
+TIMESTAMP = 1537791265
+SHA256 (tdom-0.9.1-src.tgz) = 3b1f644cf07533fe4afaa8cb709cb00a899d9e9ebfa66f4674aa2dcfb398242c
+SIZE (tdom-0.9.1-src.tgz) = 1100163
diff --git a/www/tdom/files/patch-Makefile.in b/www/tdom/files/patch-Makefile.in
index b1f67eb5147e..3e19fe584ece 100644
--- a/www/tdom/files/patch-Makefile.in
+++ b/www/tdom/files/patch-Makefile.in
@@ -1,11 +1,23 @@
---- Makefile.in.orig 2007-03-02 23:43:53 UTC
-+++ Makefile.in
-@@ -109,7 +109,7 @@ CFLAGS_WARNING = @CFLAGS_WARNING@
- CLEANFILES = @CLEANFILES@
+--- Makefile.in 2018-07-23 18:03:51.409385897 -0400
++++ Makefile.in 2018-10-14 10:04:41.681243000 -0400
+@@ -114,5 +114,5 @@
EXEEXT = @EXEEXT@
LDFLAGS_DEFAULT = @LDFLAGS_DEFAULT@
-MAKE_LIB = @MAKE_LIB@
+MAKE_LIB = @MAKE_LIB@ ${LDFLAGS_DEFAULT}
MAKE_SHARED_LIB = @MAKE_SHARED_LIB@
MAKE_STATIC_LIB = @MAKE_STATIC_LIB@
- MAKE_STUB_LIB = @MAKE_STUB_LIB@
+@@ -217,5 +217,5 @@
+ #========================================================================
+
+-binaries: versionhash.h $(BINARIES) pkgIndex.tcl-hand
++binaries: $(top_builddir)/versionhash.h $(BINARIES) pkgIndex.tcl-hand
+
+ libraries:
+@@ -342,5 +342,5 @@
+ # Create a include file that #define the current fossil hash
+ #========================================================================
+-versionhash.h: $(srcdir)/manifest.uuid
++$(top_builddir)/versionhash.h: $(srcdir)/manifest.uuid
+ @echo "#define FOSSIL_HASH \"" | tr -d '\n\r' > $(top_builddir)/versionhash.h
+ @cat $(srcdir)/manifest.uuid | tr -d '\n\r' >> $(top_builddir)/versionhash.h
diff --git a/www/tdom/files/patch-generic-dom.h b/www/tdom/files/patch-generic-dom.h
index 947ecc50972f..820b361b8984 100644
--- a/www/tdom/files/patch-generic-dom.h
+++ b/www/tdom/files/patch-generic-dom.h
@@ -1,9 +1,9 @@
---- generic/dom.h.orig 2007-08-18 12:51:46 UTC
-+++ generic/dom.h
-@@ -40,7 +40,6 @@
+--- generic/dom.h.orig 2018-09-24 12:17:05.706742000 +0000
++++ generic/dom.h 2018-09-24 12:17:16.003866000 +0000
+@@ -41,7 +41,6 @@
+ #include <string.h>
#include <ctype.h>
- #include <expat.h>
- #include <utf8conv.h>
+ #include <bsdxml.h>
-#include <domalloc.h>
/*
diff --git a/www/tdom/files/patch-tests-tdom b/www/tdom/files/patch-tests-tdom
new file mode 100644
index 000000000000..c386d2e27afd
--- /dev/null
+++ b/www/tdom/files/patch-tests-tdom
@@ -0,0 +1,10 @@
+http://www.tdom.org/index.html/tktview/2ca7a4547a9820c824289fd20871f94a213d7a23
+
+--- tests/dom.test 2018-07-23 18:03:51.445385785 -0400
++++ tests/dom.test 2018-10-14 10:38:17.742481000 -0400
+@@ -552,4 +552,5 @@
+
+ test dom-2.29 {parse not well-formed document with undeclared xml prefix} {
++knownBug} {
+ catch {dom parse {<foo:e/>}} errMsg
+ string range $errMsg 0 30
diff --git a/www/tdom/pkg-plist b/www/tdom/pkg-plist
index 4dabad278a84..fbd567bc2df5 100644
--- a/www/tdom/pkg-plist
+++ b/www/tdom/pkg-plist
@@ -9,6 +9,7 @@ man/mann/domDoc.n.gz
man/mann/domNode.n.gz
man/mann/expat.n.gz
man/mann/expatapi.n.gz
+man/mann/pullparser.n.gz
man/mann/tdomcmd.n.gz
man/mann/tnc.n.gz
%%PORTDOCS%%%%DOCSDIR%%/html/category-index.html
@@ -19,6 +20,7 @@ man/mann/tnc.n.gz
%%PORTDOCS%%%%DOCSDIR%%/html/expatapi.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/keyword-index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/pullparser.html
%%PORTDOCS%%%%DOCSDIR%%/html/tdomcmd.html
%%PORTDOCS%%%%DOCSDIR%%/html/tnc.html
%%PORTDOCS%%%%DOCSDIR%%/CHANGES