aboutsummaryrefslogtreecommitdiffstats
path: root/www/thumbnail_index
diff options
context:
space:
mode:
authorsanpei <sanpei@FreeBSD.org>2001-06-16 16:59:04 +0800
committersanpei <sanpei@FreeBSD.org>2001-06-16 16:59:04 +0800
commita0c81c6019b74a837aea9a7262e71ee091217f83 (patch)
tree43f1415a47eb89cfc2ab8da9dc8fa4ac708b47de /www/thumbnail_index
parent9540dba52307607fd05c16409daac11b97fcd7cf (diff)
downloadfreebsd-ports-gnome-a0c81c6019b74a837aea9a7262e71ee091217f83.tar.gz
freebsd-ports-gnome-a0c81c6019b74a837aea9a7262e71ee091217f83.tar.zst
freebsd-ports-gnome-a0c81c6019b74a837aea9a7262e71ee091217f83.zip
use wc command for check file size.
slower but more portable than using ls
Diffstat (limited to 'www/thumbnail_index')
-rw-r--r--www/thumbnail_index/Makefile1
-rw-r--r--www/thumbnail_index/files/patch-ab11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/thumbnail_index/Makefile b/www/thumbnail_index/Makefile
index 05acd4354b15..0c0a2f8c37a3 100644
--- a/www/thumbnail_index/Makefile
+++ b/www/thumbnail_index/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thumbnail_index
PORTVERSION= 1998.08.10
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.acme.com/software/thumbnail_index/
DISTNAME= ${PORTNAME}_10aug98
diff --git a/www/thumbnail_index/files/patch-ab b/www/thumbnail_index/files/patch-ab
new file mode 100644
index 000000000000..deb32a163ea1
--- /dev/null
+++ b/www/thumbnail_index/files/patch-ab
@@ -0,0 +1,11 @@
+--- thumbnail_index.orig Tue Aug 11 03:51:55 1998
++++ thumbnail_index Sat Jun 16 17:56:31 2001
+@@ -248,7 +248,7 @@
+ EOF
+ )
+ fi
+- kb=`ls -l "$file" | awk '{print int(($4+1023)/1024)}'`
++ kb=`wc -c < "$file" | awk '{print int(($1+1023)/1024)}'`
+ echo "<TD ALIGN=CENTER><TABLE><TR><TD ALIGN=CENTER><A HREF=\"$file\"><IMG BORDER=0 WIDTH=20 HEIGHT=22 SRC=\"$subdir/.file.gif\"></A></TD></TR><TR><TD ALIGN=CENTER><SMALL><A HREF=\"$file\">$file</A></SMALL></TD></TR><TR><TD ALIGN=CENTER><SMALL>${kb}K</SMALL></TD></TR></TABLE></TD>"
+ fi
+ ;;
04 +0800'>2017-05-251-3/+3 * Update to the 20170516 snapshot of GCC 5.4.1.gerald2017-05-211-3/+3 * Update to the 20170509 snapshot of GCC 5.4.1.gerald2017-05-141-3/+3 * Update to the 20170502 snapshot of GCC 5.4.1.gerald2017-05-041-3/+3 * Update to the 20170425 snapshot of GCC 5.4.1.gerald2017-04-281-3/+3 * Update to the 20170418 snapshot of GCC 5.4.1.gerald2017-04-231-3/+3 * Update to the 20170411 snapshot of GCC 5.4.1.gerald2017-04-141-3/+3 * Update to the 20170404 snapshot of GCC 5.4.1.gerald2017-04-061-3/+3 * Update to the 20170328 snapshot of GCC 5.4.1.gerald2017-03-301-3/+3 * Update to the 20170321 snapshot of GCC 5.4.1.gerald2017-03-251-3/+3 * Update to the 20170314 snapshot of GCC 5.4.1.gerald2017-03-171-3/+3 * Update to the 20170307 snapshot of GCC 5.4.1.gerald2017-03-111-3/+3 * Update to the 20170228 snapshot of GCC 5.4.1.gerald2017-03-021-3/+3 * Update to the 20170221 snapshot of GCC 5.4.1.gerald2017-02-251-3/+3 * Update to the 20170214 snapshot of GCC 5.4.1.gerald2017-02-161-3/+3 * Update to the 20170207 snapshot of GCC 5.4.1.gerald2017-02-081-3/+3 * Update to the 20170131 snapshot of GCC 5.4.1.gerald2017-02-021-3/+3 * Update to the 20170124 snapshot of GCC 5.4.1.gerald2017-01-261-3/+3 * Update to the 20170117 snapshot of GCC 5.4.1.gerald2017-01-211-3/+3 * Update to the 20170110 snapshot of GCC 5.4.1.gerald2017-01-111-3/+3 * Update to the 20170103 snapshot of GCC 5.4.1.gerald2017-01-051-3/+3 * Update to the 20161227 snapshot of GCC 5.4.1.gerald2016-12-291-3/+3 * Update to the 20161220 snapshot of GCC 5.4.1.gerald2016-12-231-3/+3 * Update to the 20161213 snapshot of GCC 5.4.1.gerald2016-12-151-3/+3 * Update to the 20161206 snapshot of GCC 5.4.1.gerald2016-12-071-3/+3 * Update to the 20161129 snapshot of GCC 5.4.1.gerald2016-12-041-3/+3 * Update to the 20161122 snapshot of GCC 5.4.1.gerald2016-11-261-3/+3 * Update to the 20161115 snapshot of GCC 5.4.1.gerald2016-11-161-3/+3 * Update to the 20161108 snapshot of GCC 5.4.1.gerald2016-11-111-3/+3 * Update to the 20161101 snapshot of GCC 5.4.1.gerald2016-11-041-3/+3 * Update to the 20161018 snapshot of GCC 5.4.1.gerald2016-10-201-3/+3 * Update to the 20161011 snapshot of GCC 5.4.1.gerald2016-10-141-3/+3 * Update to the 20161004 snapshot of GCC 5.4.1.gerald2016-10-081-3/+3 * Update to the 20160927 snapshot of GCC 5.4.1.gerald2016-09-301-3/+3 * Update to the 20160920 snapshot of GCC 5.4.1.gerald2016-09-221-3/+3 * Update to the 20160913 snapshot of GCC 5.4.1.gerald2016-09-151-3/+3 * Update to the 20160906 snapshot of GCC 5.4.1.gerald2016-09-081-3/+3 * Update to the 20160830 snapshot of GCC 5.4.1.gerald2016-08-311-3/+3 * Update to the 20160823 snapshot of GCC 5.4.1.gerald2016-08-241-3/+3 * Update to the 20160816 snapshot of GCC 5.4.1.gerald2016-08-171-3/+3 * Update to the 20160809 snapshot of GCC 5.4.1.gerald2016-08-101-3/+3 * Update to the 20160802 snapshot of GCC 5.4.1.gerald2016-08-031-3/+3 * Update to the 20160726 snapshot of GCC 5.4.1.gerald2016-07-311-3/+3 * Update to the 20160719 snapshot of GCC 5.4.1.gerald2016-07-251-3/+3 * Update to the 20160712 snapshot of GCC 5.4.1.gerald2016-07-161-3/+3 * Update to the 20160621 snapshot of GCC 5.4.1.gerald2016-06-271-3/+3 * Update to the 20160614 snapshot of GCC 5.4.1.gerald2016-06-161-3/+3 * Update to the 20160608 snapshot of GCC 5.4.1, that is, this is now basedgerald2016-06-101-3/+3 * Update to the 20160524 snapshot of GCC 5.3.1.gerald2016-05-301-3/+3 * Update to the 20160517 snapshot of GCC 5.3.1.gerald2016-05-251-2/+3 * Update to the 20160510 development snapshot of GCC 5.3.1.gerald2016-05-121-2/+2 * Update to the 20160503 development snapshot of GCC 5.3.1.gerald2016-05-051-2/+2 * Update to the 20160426 development snapshot of GCC 5.3.1.gerald2016-05-011-2/+2 * Update to the 20160419 development snapshot of GCC 5.3.1.gerald2016-04-241-2/+2 * Update to the 20160412 snapshot of GCC 5.gerald2016-04-151-2/+2 * Update to the 20160329 snapshot of GCC 5. A fair number of fixesgerald2016-04-031-2/+2 * Update to the 20160315 snapshot of GCC 5.gerald2016-03-201-2/+2 * Update to the 20160308 snapshot of GCC 5.gerald2016-03-141-2/+2 * Update to the 20160301 snapshot of GCC 5.gerald2016-03-051-2/+2 * Update to the 20160223 snapshot of GCC 5.gerald2016-02-281-2/+2 * Update to the 20160216 snapshot of GCC 5.gerald2016-02-201-2/+2 * Update to the 20160209 snapshot of GCC 5.gerald2016-02-121-2/+2 * Update to the 20160202 snapshot of GCC 5.gerald2016-02-061-2/+2 * Update to the 20160126 snapshot of GCC 5.gerald2016-02-011-2/+2 * Update to the 20160119 snapshot of GCC 5.gerald2016-01-251-2/+2 * Update to the 20160112 snapshot of GCC 5.gerald2016-01-191-2/+2 * Update to the 20160105 snapshot of GCC 5.gerald2016-01-081-2/+2 * Update to the 20151229 snapshot of GCC 5.gerald2016-01-041-2/+2 * Update to the 20151208 snapshot of GCC 5, now nominally version 5.3.1.gerald2015-12-091-2/+2 * Update to the 20151124 snapshot of GCC 5.gerald2015-11-281-2/+2 * Update to the 20151117 snapshot of GCC 5.gerald2015-11-211-2/+2 * Update to the 20151110 snapshot of GCC 5.gerald2015-11-131-2/+2 * Update to the 20151103 snapshot of GCC 5.gerald2015-11-081-2/+2 * Update to the 20151027 snapshot of GCC 5.gerald2015-11-011-2/+2 * Update to the 20151020 snapshot of GCC 5.gerald2015-10-24