aboutsummaryrefslogtreecommitdiffstats
path: root/www/tinytinyhttpd
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-11-04 16:14:15 +0800
committermiwi <miwi@FreeBSD.org>2009-11-04 16:14:15 +0800
commit95b99f76388b3d35c8da8f41300cea0997dc50fd (patch)
tree6541a76708e8bb7dbae7065a5878e035853cea42 /www/tinytinyhttpd
parentf474f90b6caaae21f9f2c9164d1d3c786e48898f (diff)
downloadfreebsd-ports-gnome-95b99f76388b3d35c8da8f41300cea0997dc50fd.tar.gz
freebsd-ports-gnome-95b99f76388b3d35c8da8f41300cea0997dc50fd.tar.zst
freebsd-ports-gnome-95b99f76388b3d35c8da8f41300cea0997dc50fd.zip
- Update to 0.9
PR: 140260 Submitted by: Shinsuke Matsui <smatsui@karashi.org> (maintainer)
Diffstat (limited to 'www/tinytinyhttpd')
-rw-r--r--www/tinytinyhttpd/Makefile5
-rw-r--r--www/tinytinyhttpd/distinfo6
-rw-r--r--www/tinytinyhttpd/files/example.conf.in (renamed from www/tinytinyhttpd/files/example.conf)4
-rw-r--r--www/tinytinyhttpd/files/patch-httpd.cxx13
4 files changed, 21 insertions, 7 deletions
diff --git a/www/tinytinyhttpd/Makefile b/www/tinytinyhttpd/Makefile
index 95bf160490d6..f2726954f932 100644
--- a/www/tinytinyhttpd/Makefile
+++ b/www/tinytinyhttpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tinytinyhttpd
-PORTVERSION= 0.0.8
+PORTVERSION= 0.0.9
CATEGORIES= www
MASTER_SITES= http://cloud.github.com/downloads/mattn/tinytinyhttpd/ \
${MASTER_SITE_LOCAL}
@@ -17,6 +17,7 @@ COMMENT= Tiny tiny httpd
HAS_CONFIGURE= yes
PLIST_FILES= bin/tthttpd
+SUB_FILES= example.conf
PORTDOCS= README example.conf ChangeLog
do-install:
@@ -24,7 +25,7 @@ do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${FILESDIR}/example.conf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/example.conf ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
.endif
diff --git a/www/tinytinyhttpd/distinfo b/www/tinytinyhttpd/distinfo
index 633aaba30f0f..ac31e2106a21 100644
--- a/www/tinytinyhttpd/distinfo
+++ b/www/tinytinyhttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (tinytinyhttpd-0.0.8.tar.gz) = 2a7b2bdcd5618c8f89915284f5f4203b
-SHA256 (tinytinyhttpd-0.0.8.tar.gz) = d1b6b814e86d7357707c5fc2d8f63af42bb0a15a0197180d11c027a373c01f76
-SIZE (tinytinyhttpd-0.0.8.tar.gz) = 110678
+MD5 (tinytinyhttpd-0.0.9.tar.gz) = 9b0420c36c890b3dc442ce7dc20d4d3b
+SHA256 (tinytinyhttpd-0.0.9.tar.gz) = 374041df75722920a355b3284d242a9fcdf009cc7c67078fd527c2682462792f
+SIZE (tinytinyhttpd-0.0.9.tar.gz) = 147412
diff --git a/www/tinytinyhttpd/files/example.conf b/www/tinytinyhttpd/files/example.conf.in
index c77a7d50dbe4..15e1a318d3df 100644
--- a/www/tinytinyhttpd/files/example.conf
+++ b/www/tinytinyhttpd/files/example.conf.in
@@ -6,5 +6,5 @@ charset=utf-8
spawnexec=on
[mime/types]
-cgi=@/usr/local/bin/perl
-php=@/usr/local/bin/php
+cgi=@%%LOCALBASE%%/bin/perl
+php=@%%LOCALBASE%%/bin/php
diff --git a/www/tinytinyhttpd/files/patch-httpd.cxx b/www/tinytinyhttpd/files/patch-httpd.cxx
new file mode 100644
index 000000000000..5447612653fa
--- /dev/null
+++ b/www/tinytinyhttpd/files/patch-httpd.cxx
@@ -0,0 +1,13 @@
+diff --git httpd.cxx httpd.cxx
+index 98cec3c..958200a 100644
+--- httpd.cxx
++++ httpd.cxx
+@@ -1734,7 +1734,7 @@ request_done:
+ #if defined LINUX_SENDFILE_API
+ sent = sendfile(msgsock, fileno(res_info->read), NULL, total);
+ #elif defined FREEBSD_SENDFILE_API
+- sendfile(msgsock, fileno(res_info->read), total, &sent, NULL, 0);
++ if (sendfile(msgsock, fileno(res_info->read), NULL, total, NULL, NULL, 0) == 0) sent = total;
+ #elif defined _WIN32
+ if (!res_info->process && lpfnTransmitFile && lpfnTransmitFile(
+ msgsock,