aboutsummaryrefslogtreecommitdiffstats
path: root/www/tntnet
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /www/tntnet
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'www/tntnet')
-rw-r--r--www/tntnet/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/tntnet/Makefile b/www/tntnet/Makefile
index 562722852901..410db2484c69 100644
--- a/www/tntnet/Makefile
+++ b/www/tntnet/Makefile
@@ -21,15 +21,15 @@ USE_ICONV= yes
USE_CSTD= gnu89
PATCH_STRIP= -p1
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
CONFIGURE_ARGS+= --localstatedir=/var
.if defined(WITH_GNUTLS)
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lgnutls"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lgnutls
CONFIGURE_ARGS+= --with-ssl=gnutls
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.else
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ARGS+= --with-ssl=openssl
.endif