aboutsummaryrefslogtreecommitdiffstats
path: root/www/tomcat6
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-06-12 21:55:39 +0800
committercrees <crees@FreeBSD.org>2011-06-12 21:55:39 +0800
commit175897612b4b93272d49ae1c7ea904aa36cae539 (patch)
treef06e7e5bf7439321675fe732dbc1b36df441ea64 /www/tomcat6
parent7325eb6d4288f6ba2b3fca97d953e3ad71797904 (diff)
downloadfreebsd-ports-gnome-175897612b4b93272d49ae1c7ea904aa36cae539.tar.gz
freebsd-ports-gnome-175897612b4b93272d49ae1c7ea904aa36cae539.tar.zst
freebsd-ports-gnome-175897612b4b93272d49ae1c7ea904aa36cae539.zip
- Rename CONF_FILES variables to avoid conflict with incoming feature
PR: 157165 Approved by: rene (mentor), maintainer timeout (ale, 25 days)
Diffstat (limited to 'www/tomcat6')
-rw-r--r--www/tomcat6/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/tomcat6/Makefile b/www/tomcat6/Makefile
index f1b552fb529f..6aea646442d7 100644
--- a/www/tomcat6/Makefile
+++ b/www/tomcat6/Makefile
@@ -37,7 +37,8 @@ AJP_1_3_PORT?= 8009
STDOUT_LOG= ${LOG_DIR}/stdout.log
STDERR_LOG= ${LOG_DIR}/stderr.log
JAR_FILE= bin/bootstrap.jar
-CONF_FILES= catalina.policy catalina.properties context.xml logging.properties server.xml tomcat-users.xml web.xml
+TOMCAT_CONF_FILES= catalina.policy catalina.properties context.xml \
+ logging.properties server.xml tomcat-users.xml web.xml
CONF_EXT= sample
PLIST_SUB= T=${APP_HOME:S/^${PREFIX}\///} CONF_EXT=${CONF_EXT} \
WWWOWN=${TOMCAT_USER} WWWGRP=${TOMCAT_GROUP}
@@ -73,7 +74,7 @@ pre-patch:
post-patch:
@${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${WRKSRC}/conf/server.xml
@${FIND} ${WRKSRC} -type f \( -name '*.bak' -or -name '*.bat' -or -name '*.dll' -or -name '*.exe' -or -name '*.orig' \) -delete
-.for f in ${CONF_FILES}
+.for f in ${TOMCAT_CONF_FILES}
@${MV} ${WRKSRC}/conf/${f} ${WRKSRC}/conf/${f}.${CONF_EXT}
.endfor
@@ -91,7 +92,7 @@ do-install:
@${CP} -R ${WRKSRC}/* ${APP_HOME}
@${ECHO_MSG} " [ DONE ]"
-.for f in ${CONF_FILES}
+.for f in ${TOMCAT_CONF_FILES}
. if !exists(${APP_HOME}/conf/${f})
@${CP} ${APP_HOME}/conf/${f}.${CONF_EXT} ${APP_HOME}/conf/${f}
. else