aboutsummaryrefslogtreecommitdiffstats
path: root/www/tomcat6
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2010-10-26 16:19:05 +0800
committerale <ale@FreeBSD.org>2010-10-26 16:19:05 +0800
commit49a787b87176639b351bad352d11a13947a5d912 (patch)
treee17a6cb670248c19ad4dd9b4a860d75a6f637e90 /www/tomcat6
parenta979b8c66180dd8b0fe57ee468374bc49b218b19 (diff)
downloadfreebsd-ports-gnome-49a787b87176639b351bad352d11a13947a5d912.tar.gz
freebsd-ports-gnome-49a787b87176639b351bad352d11a13947a5d912.tar.zst
freebsd-ports-gnome-49a787b87176639b351bad352d11a13947a5d912.zip
Print informative text on status and poll commands.
PR: ports/151709 Submitted by: Alex Deiter <alex.deiter@gmail.com>
Diffstat (limited to 'www/tomcat6')
-rw-r--r--www/tomcat6/Makefile1
-rw-r--r--www/tomcat6/files/tomcat6.sh.in16
2 files changed, 13 insertions, 4 deletions
diff --git a/www/tomcat6/Makefile b/www/tomcat6/Makefile
index ba75deaf6e98..de252a991457 100644
--- a/www/tomcat6/Makefile
+++ b/www/tomcat6/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 6.0.29
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-6/v${PORTVERSION}/bin
diff --git a/www/tomcat6/files/tomcat6.sh.in b/www/tomcat6/files/tomcat6.sh.in
index 42bf6c29fc62..ac8c9e588eea 100644
--- a/www/tomcat6/files/tomcat6.sh.in
+++ b/www/tomcat6/files/tomcat6.sh.in
@@ -140,19 +140,27 @@ tomcat_stop() {
tomcat_status() {
rc_pid=$(tomcat_check_pidfile $pidfile)
- if [ -z "$rc_pid" ]; then
- [ -n "$rc_fast" ] && return 0
- echo "${name} not running? (check $pidfile)."
+ if [ -n "$rc_pid" ]; then
+ echo "${name} is running as pid $rc_pid."
+ else
+ echo "${name} is not running."
return 1
fi
}
tomcat_poll() {
+ rc_pid=$(tomcat_check_pidfile $pidfile)
+
+ _prefix=
while (true) ; do
- rc_pid=$(tomcat_check_pidfile $pidfile)
[ -z "$rc_pid" ] && break
+ echo -n ${_prefix:-"Waiting for PIDS: "}$rc_pid
+ _prefix=", "
sleep 2
done
+ if [ -n "$_prefix" ]; then
+ echo "."
+ fi
}
tomcat_check_pidfile() {