aboutsummaryrefslogtreecommitdiffstats
path: root/www/tomcat7/Makefile
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-02-08 21:35:17 +0800
committerlawrance <lawrance@FreeBSD.org>2006-02-08 21:35:17 +0800
commitbcf930033ce0716262f5629bdfc4ac74aa9bfce8 (patch)
treeadf1499191365b1606e327a0b51b229b538fb530 /www/tomcat7/Makefile
parent8a733f18064a5b4c7fce40a8684d6f1a0af9f426 (diff)
downloadfreebsd-ports-gnome-bcf930033ce0716262f5629bdfc4ac74aa9bfce8.tar.gz
freebsd-ports-gnome-bcf930033ce0716262f5629bdfc4ac74aa9bfce8.tar.zst
freebsd-ports-gnome-bcf930033ce0716262f5629bdfc4ac74aa9bfce8.zip
- Make sure the rc script creates and chowns the PID file before running
'daemon'. No need for the port to create a PID file at install time (it would just be eaten by rc.d/cleanvar anyway). - Use 'ps -o comm' to grab a suitable procname. 'ps -o command' is not reliable enough. - Bump PORTREVISION since these changes fix broken rc script operation. Approved by: maintainer timeout (as part of previous update)
Diffstat (limited to 'www/tomcat7/Makefile')
-rw-r--r--www/tomcat7/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index 7616322cf390..24024dbbc0fa 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
@@ -136,12 +136,6 @@ do-install:
@${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_MSG} " [ DONE ]"
- @${ECHO_MSG} -n ">> Creating PID file..."
- @${TOUCH} ${PID_FILE}
- @${CHOWN} ${TOMCAT_USER}:${TOMCAT_GROUP} ${PID_FILE}
- @${CHMOD} 0600 ${PID_FILE}
- @${ECHO_MSG} " [ DONE ]"
-
post-install:
@${ECHO_MSG} "${APP_TITLE} ${PORTVERSION} has been installed in ${APP_HOME}."
.include <bsd.port.post.mk>