aboutsummaryrefslogtreecommitdiffstats
path: root/www/trac-calendar
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-05-28 01:32:00 +0800
committermiwi <miwi@FreeBSD.org>2007-05-28 01:32:00 +0800
commita28f24444cfda6dcc47598eb132ee285527ed0b2 (patch)
treec6a4c5bf3d10d91ad3ed94d1f5058fc542d6bb4e /www/trac-calendar
parent3ec8d71ef78e1960b4046384edb5d91e1deb1d26 (diff)
downloadfreebsd-ports-gnome-a28f24444cfda6dcc47598eb132ee285527ed0b2.tar.gz
freebsd-ports-gnome-a28f24444cfda6dcc47598eb132ee285527ed0b2.tar.zst
freebsd-ports-gnome-a28f24444cfda6dcc47598eb132ee285527ed0b2.zip
This plugin adds new navigation item "Calendar". Calendar is (or is aimed to
be) the tool for planning of tasks with associated date and time. E.g. ticket to be solved, a conference to attend, or a call to be made can be planned with Calendar. Items for given week are displayed in an overview with resolution of 15 minutes. Three small monthly views are also available, with days containing items marked. Certain items may be prioritized, and are then displayed in a bright color to stand out. WWW: http://trac-hacks.org/wiki/CalendarPlugin Submitted by: Gerrit Beine <gerrit.beine at gmx.de>
Diffstat (limited to 'www/trac-calendar')
-rw-r--r--www/trac-calendar/Makefile27
-rw-r--r--www/trac-calendar/distinfo3
-rw-r--r--www/trac-calendar/pkg-descr11
-rw-r--r--www/trac-calendar/pkg-plist1
4 files changed, 42 insertions, 0 deletions
diff --git a/www/trac-calendar/Makefile b/www/trac-calendar/Makefile
new file mode 100644
index 000000000000..ac6c7fddcdac
--- /dev/null
+++ b/www/trac-calendar/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: trac-calendar
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= calendar
+PORTVERSION= 0.1
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/download/trac/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Calendar plugin for trac
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/trac-calendar/distinfo b/www/trac-calendar/distinfo
new file mode 100644
index 000000000000..223d574637d6
--- /dev/null
+++ b/www/trac-calendar/distinfo
@@ -0,0 +1,3 @@
+MD5 (calendarplugin-0.1.tar.gz) = 883e42d2b7a81f1d049059b4da961d97
+SHA256 (calendarplugin-0.1.tar.gz) = c1c25a123d5912275f351c6166b5d9eb2878ff183640f434da2ccde6614cdc96
+SIZE (calendarplugin-0.1.tar.gz) = 18769
diff --git a/www/trac-calendar/pkg-descr b/www/trac-calendar/pkg-descr
new file mode 100644
index 000000000000..38f5baaeffec
--- /dev/null
+++ b/www/trac-calendar/pkg-descr
@@ -0,0 +1,11 @@
+This plugin adds new navigation item "Calendar". Calendar is (or is aimed to
+be) the tool for planning of tasks with associated date and time. E.g. ticket
+to be solved, a conference to attend, or a call to be made can be planned with
+Calendar. Items for given week are displayed in an overview with resolution of
+15 minutes. Three small monthly views are also available, with days containing
+items marked.
+
+Certain items may be prioritized, and are then displayed in a bright color to
+stand out.
+
+WWW: http://trac-hacks.org/wiki/CalendarPlugin
diff --git a/www/trac-calendar/pkg-plist b/www/trac-calendar/pkg-plist
new file mode 100644
index 000000000000..d7137afab0aa
--- /dev/null
+++ b/www/trac-calendar/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/AztechCalendar-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg