aboutsummaryrefslogtreecommitdiffstats
path: root/www/trac-ccselector
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2008-12-11 11:27:37 +0800
committerglarkin <glarkin@FreeBSD.org>2008-12-11 11:27:37 +0800
commit65fa2a650180fa26b23d3d75e1a944c632ce3b20 (patch)
tree235c2485bd57f5e9d467fd343313dd8e44c941d3 /www/trac-ccselector
parenta79bf2bcef93f1a8a47220c77e8d6bd307ac4d0b (diff)
downloadfreebsd-ports-gnome-65fa2a650180fa26b23d3d75e1a944c632ce3b20.tar.gz
freebsd-ports-gnome-65fa2a650180fa26b23d3d75e1a944c632ce3b20.tar.zst
freebsd-ports-gnome-65fa2a650180fa26b23d3d75e1a944c632ce3b20.zip
This plugin allows visual CC field editing.
A pop-up window with bunch of checkboxes is opened, user checks boxes, email addresses are added and removed to CC field. There is a list of pre-defined addresses in cc_selector.js (these addresses will always be available). If you want to change this list you must edit cc_selector.js manually. Of course, you can always edit CC field without all this hassle - all addresses you entered manually will be shown, too - and can be removed with new, shiny checkboxes. WWW: http://trac-hacks.org/wiki/CcSelectorPlugin
Diffstat (limited to 'www/trac-ccselector')
-rw-r--r--www/trac-ccselector/Makefile34
-rw-r--r--www/trac-ccselector/distinfo3
-rw-r--r--www/trac-ccselector/pkg-descr13
-rw-r--r--www/trac-ccselector/pkg-message9
-rw-r--r--www/trac-ccselector/pkg-plist1
5 files changed, 60 insertions, 0 deletions
diff --git a/www/trac-ccselector/Makefile b/www/trac-ccselector/Makefile
new file mode 100644
index 000000000000..ee6bd2e040e5
--- /dev/null
+++ b/www/trac-ccselector/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: trac-ccselector
+# Date created: Dec 10 2008
+# Whom: glarkin
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccselector
+PORTVERSION= 0.0.2.4001
+CATEGORIES= www devel python
+MASTER_SITES= http://www.sourcehosting.net/freebsd/distfiles/ \
+ LOCAL/glarkin
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Web interface to administer Trac ticket custom fields
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin/0.11
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= cc_selector
+PYDISTUTILS_PKGVERSION= ${PORTVERSION:R}
+PLIST_SUB+= EGGVERSION=${PORTVERSION:R} PYTHONVERSION=${_PYTHON_VERSION}
+PYDISTUTILS_NOEGGINFO= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/trac-ccselector/distinfo b/www/trac-ccselector/distinfo
new file mode 100644
index 000000000000..139d3fc7e0aa
--- /dev/null
+++ b/www/trac-ccselector/distinfo
@@ -0,0 +1,3 @@
+MD5 (ccselectorplugin-0.0.2.4001.zip) = 28fe992d1c29c4faef769603a3a66358
+SHA256 (ccselectorplugin-0.0.2.4001.zip) = f1f27c53b4e250557aa0acb3aab958876e9306bc9cb0ac3489ad8c4adc263c54
+SIZE (ccselectorplugin-0.0.2.4001.zip) = 7084
diff --git a/www/trac-ccselector/pkg-descr b/www/trac-ccselector/pkg-descr
new file mode 100644
index 000000000000..5117858d98c2
--- /dev/null
+++ b/www/trac-ccselector/pkg-descr
@@ -0,0 +1,13 @@
+This plugin allows visual CC field editing.
+
+A pop-up window with bunch of checkboxes is opened, user checks
+boxes, email addresses are added and removed to CC field. There is
+a list of pre-defined addresses in cc_selector.js (these addresses
+will always be available). If you want to change this list you must
+edit cc_selector.js manually.
+
+Of course, you can always edit CC field without all this hassle -
+all addresses you entered manually will be shown, too - and can be
+removed with new, shiny checkboxes.
+
+WWW: http://trac-hacks.org/wiki/CcSelectorPlugin
diff --git a/www/trac-ccselector/pkg-message b/www/trac-ccselector/pkg-message
new file mode 100644
index 000000000000..ff34b9a18287
--- /dev/null
+++ b/www/trac-ccselector/pkg-message
@@ -0,0 +1,9 @@
+**************************************************
+To complete the installation, please add:
+
+[components]
+cc_selector.* = enabled
+
+to your trac.ini to enable the visual CC field
+editor.
+**************************************************
diff --git a/www/trac-ccselector/pkg-plist b/www/trac-ccselector/pkg-plist
new file mode 100644
index 000000000000..8c538e8c9aa2
--- /dev/null
+++ b/www/trac-ccselector/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/cc_selector-%%EGGVERSION%%-py%%PYTHONVERSION%%.egg