aboutsummaryrefslogtreecommitdiffstats
path: root/www/twig/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-05-09 01:46:52 +0800
committerdinoex <dinoex@FreeBSD.org>2003-05-09 01:46:52 +0800
commitab8004dea296f54e315980e99b9bfbf1e03ba28a (patch)
treeca8865f29e0a8a517805867cc3a3c99b6ee36f4c /www/twig/Makefile
parent9b42e42bfd7c7c37f031c348bd92883472f852b2 (diff)
downloadfreebsd-ports-gnome-ab8004dea296f54e315980e99b9bfbf1e03ba28a.tar.gz
freebsd-ports-gnome-ab8004dea296f54e315980e99b9bfbf1e03ba28a.tar.zst
freebsd-ports-gnome-ab8004dea296f54e315980e99b9bfbf1e03ba28a.zip
- Support for PHP3_PORT and PHP4_PORT
Diffstat (limited to 'www/twig/Makefile')
-rw-r--r--www/twig/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/twig/Makefile b/www/twig/Makefile
index 9d43859a5a4c..42927c754561 100644
--- a/www/twig/Makefile
+++ b/www/twig/Makefile
@@ -15,9 +15,9 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= Web Based Email Client and Scheduler
.if !defined(WITH_PHP3)
-RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/${PHP4_PORT}
.else
-RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/${PHP3_PORT}
.endif
.if !defined(WITH_MYSQL)
LIB_DEPENDS= pq.3:${PORTSDIR}/databases/postgresql7
@@ -25,6 +25,8 @@ LIB_DEPENDS= pq.3:${PORTSDIR}/databases/postgresql7
.endif
NO_BUILD= YES
+PHP4_PORT?= www/mod_php4
+PHP3_PORT?= www/mod_php3
NO_PACKAGE= need a matching version of mod_php
TWIG?= www/data-dist/twig
PLIST_SUB+= TWIG=${TWIG}