aboutsummaryrefslogtreecommitdiffstats
path: root/www/twiki/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2008-04-22 16:36:45 +0800
committersat <sat@FreeBSD.org>2008-04-22 16:36:45 +0800
commit040f0e533bb4026bad1545a4aac57da988c50e6b (patch)
tree434f12d482b3d685e77b250e1eddb12e54d6f4c3 /www/twiki/Makefile
parentbc75519afb6fe4ef5fe161be5d37d5b066589ddb (diff)
downloadfreebsd-ports-gnome-040f0e533bb4026bad1545a4aac57da988c50e6b.tar.gz
freebsd-ports-gnome-040f0e533bb4026bad1545a4aac57da988c50e6b.tar.zst
freebsd-ports-gnome-040f0e533bb4026bad1545a4aac57da988c50e6b.zip
- Take maintainership
- Update to 4.2.0 - Refactor into modular design - Add 21 default modules and 2 non-default ones - Make upgrading reasonably safe Wiki: http://wiki.FreeBSD.org/TWiki Approved by: farrokhi (maintainer, implicit via miwi)
Diffstat (limited to 'www/twiki/Makefile')
-rw-r--r--www/twiki/Makefile77
1 files changed, 37 insertions, 40 deletions
diff --git a/www/twiki/Makefile b/www/twiki/Makefile
index 4335b0e5d05b..aaaf76b901a0 100644
--- a/www/twiki/Makefile
+++ b/www/twiki/Makefile
@@ -1,58 +1,55 @@
-# Ports collection makefile for: TWiki
-# Date created: Fri Mar 7 14:36:05 CST 2003
-# Whom: Justin Hawkins <justin@hawkins.id.au>
+# Ports collection makefile for: TWiki
+# Date created: Fri Mar 7 14:36:05 CST 2003
+# Whom: Justin Hawkins <justin@hawkins.id.au>
#
# $FreeBSD$
#
PORTNAME= twiki
-PORTVERSION= 4.1.2
+PORTVERSION= 4.2.0
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://twiki.org/p/pub/Codev/Release/ \
- ${MASTER_SITE_GENTOO}/distfiles/
-MASTER_SITE_SUBDIR= distfiles
+ GENTOO/distfiles
DISTNAME= TWiki-${PORTVERSION}
EXTRACT_SUFX= .tgz
-MAINTAINER= farrokhi@FreeBSD.org
-COMMENT= A flexible, powerful, and easy to use Web-based collaboration platform
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Flexible, powerful, and easy to use enterprise wiki
+
+RUN_DEPENDS= \
+ p5-Algorithm-Diff>=0:${PORTSDIR}/devel/p5-Algorithm-Diff \
+ p5-Error>=0:${PORTSDIR}/lang/p5-Error \
+ p5-Text-Diff>=0:${PORTSDIR}/textproc/p5-Text-Diff \
+ p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm \
+ p5-CGI-Session>=0:${PORTSDIR}/www/p5-CGI-Session \
+ p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Locale-Maketext-Lexicon>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools \
+ p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Archive-Tar>=0:${PORTSDIR}/archivers/p5-Archive-Tar \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
-RUN_DEPENDS= ${SITE_PERL}/CGI/Session.pm:${PORTSDIR}/www/p5-CGI-Session
-
-NO_WRKSUBDIR= yes
-NO_BUILD= yes
USE_PERL5= yes
-TWIKI?= ${WWWOWN}/twiki
-TWIKIDIR?= ${PREFIX}/${TWIKI}
-
-PLIST_SUB= TWIKI=${TWIKI}
-SUB_LIST= WWWUSER=${WWWOWN} WWWGROUP=${WWWGRP} TWIKIDIR=${TWIKIDIR} \
- REINPLACE_CMD="${REINPLACE_CMD}"
-SUB_FILES= pkg-install
-PKGINSTALL= ${WRKDIR}/pkg-install
-
-pre-everything::
- @${ECHO} "****************************************************************"
- @${ECHO} "* If you're upgrading, Ctrl-C now and do the upgrade by hand. *"
- @${ECHO} "* This software can't be upgraded automatically without *"
- @${ECHO} "* damaging data in your wiki! *"
- @${ECHO} "****************************************************************"
- @sleep 1
+post-extract:
+ @cd ${WRKDIR}/ && ${MKDIR} .t/ && ${MV} * .t/ && ${MV} .t ${WRKSRC}
+ @${RM} -rf ${WRKSRC}/lib/CPAN
+ @${CAT} ${.CURDIR}/../twiki-*/pkg-plist |\
+ ${SED} -e 's|%%TWDIR%%|${WRKSRC}|;/^@/d' |\
+ ${XARGS} ${RM} -f
+ @${FIND} ${WRKSRC} -name \*,v | while read f; do\
+ [ -e $${f%%,v} ] || ${RM} -f $$f; done
+ @${FIND} ${WRKSRC} -type d -empty -delete
post-patch:
-.for F in data/TWiki/TWikiInstallationGuide.txt,v data/TWiki/TWikiDocumentation.txt,v data/TWiki/TWikiInstallationGuide.txt INSTALL.html lib/TWiki.spec twiki_httpd_conf.txt
- @${REINPLACE_CMD} -i "" -e "s|\/home\/httpd\/twiki|${TWIKIDIR}|g" \
- ${WRKSRC}/$F
-.endfor
-
-do-install:
- ${INSTALL} -d -m 0755 ${TWIKIDIR}
- (cd ${WRKSRC} && ${FIND} . -not -name ".PLIST.*" -not -name '.*_done.*' -not -name pkg-install | \
- ${CPIO} -pdmu -R${SHAREOWN}:${SHAREGRP} ${TWIKIDIR})
-
-post-install:
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @cd ${WRKSRC}/ &&\
+ ${REINPLACE_CMD} -i "" -e "s|/home/httpd/twiki|${WWWDIR}|g" \
+ lib/TWiki.spec twiki_httpd_conf.txt
+ @${FIND} ${WRKSRC} -name \*.orig -delete
+.include "${.CURDIR}/bsd.twiki.mk"
.include <bsd.port.mk>