aboutsummaryrefslogtreecommitdiffstats
path: root/www/udmsearch/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-11-14 10:18:01 +0800
committersteve <steve@FreeBSD.org>1999-11-14 10:18:01 +0800
commitadf766e2c9312a4a34e934c7a3935b1bdf285af9 (patch)
tree5ef395a316f7b5e6e299f892e539e38d44e9544f /www/udmsearch/Makefile
parent8debd1e69f20fcbfe630fc5276763689d85bcdc8 (diff)
downloadfreebsd-ports-gnome-adf766e2c9312a4a34e934c7a3935b1bdf285af9.tar.gz
freebsd-ports-gnome-adf766e2c9312a4a34e934c7a3935b1bdf285af9.tar.zst
freebsd-ports-gnome-adf766e2c9312a4a34e934c7a3935b1bdf285af9.zip
Update to version 2.1.7.
PR: 14708, 14724 Submitted by: maintainer
Diffstat (limited to 'www/udmsearch/Makefile')
-rw-r--r--www/udmsearch/Makefile60
1 files changed, 42 insertions, 18 deletions
diff --git a/www/udmsearch/Makefile b/www/udmsearch/Makefile
index 3389228fc1f4..f1b57ccd32b3 100644
--- a/www/udmsearch/Makefile
+++ b/www/udmsearch/Makefile
@@ -1,37 +1,61 @@
# New ports collection makefile for: udmsearch
-# Version required: 2.1.5
-# Date created: 10/19/1999
+# Version required: 2.1.7
+# Date created: 11/05/1999
# Whom: Kelly Yancey <kbyanc@posi.net>
#
# $FreeBSD$
#
-DISTNAME= udmsearch-2.1.5
-CATEGORIES= www databases
-MASTER_SITES= http://search.udm.net/about/Download/ \
- http://mysearch.udm.net/Download/ \
- ftp://ftp.izhcom.ru/pub/unix/UdmSearch/ \
- http://mirror.kuenzler.ch/udmsearch/Download/
+DISTNAME= udmsearch-2.1.7
+CATEGORIES= www databases
+MASTER_SITES= http://mysearch.udm.net/Download/ \
+ ftp://ftp.izhcom.ru/pub/unix/UdmSearch/ \
+ http://mirror.kuenzler.ch/udmsearch/Download/
-MAINTAINER= kbyanc@posi.net
+MAINTAINER= kbyanc@posi.net
-LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
+MAN1= indexer.1
+MAN5= indexer.conf.5
-MAN1= indexer.1
-MAN5= indexer.conf.5
+WRKSRC= ${WRKDIR}/udmsearch-2.1.7a
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --bindir=${PREFIX}/bin/udmsearch \
+ --sysconfdir=${PREFIX}/etc/udmsearch
-USE_GMAKE= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --bindir=${PREFIX}/bin/udmsearch \
- --sysconfdir=${PREFIX}/etc/udmsearch \
+.if defined(USE_POSTGRESQL)
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql
+CONFIGURE_ARGS+= --with-pgsql
+
+.elif defined(USE_MSQL)
+BUILD_DEPENDS= ${PREFIX}/lib/libmsql.a:${PORTSDIR}/databases/msql
+CONFIGURE_ARGS+= --with-msql
+
+.else
+# default to mysql
+
+LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
+CONFIGURE_ARGS+= --with-mysql
+
+.if !defined(USE_MYSQL)
+pre-fetch:
+ @${ECHO}
+ @${ECHO} "Defaulting to udmsearch with mysql support."
+ @${ECHO}
+ @${ECHO} "You may alternately build udmsearch with either msql or"
+ @${ECHO} "postgresql support by invoking make with USE_MSQL=yes or"
+ @${ECHO} "USE_POSTGRESQL=yes respectively."
+ @${ECHO}
+.endif
+
+.endif
pre-install:
${MKDIR} ${PREFIX}/bin/udmsearch
${MKDIR} ${PREFIX}/etc/udmsearch
post-install:
- @cp -R ${WRKDIR}/${DISTNAME}/create ${PREFIX}/etc/udmsearch
+ @cp -R ${WRKSRC}/create ${PREFIX}/etc/udmsearch
@strip ${PREFIX}/sbin/indexer
@strip ${PREFIX}/bin/udmsearch/search.cgi
@${ECHO}