aboutsummaryrefslogtreecommitdiffstats
path: root/www/urchin5/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-01-03 16:08:51 +0800
committeredwin <edwin@FreeBSD.org>2004-01-03 16:08:51 +0800
commite8bb8f2381fb4bc2bb177b9d7066a550124d0f8a (patch)
treef7b600e8b9a4e1e6e6f5d4d4fae045a13f7c6dda /www/urchin5/Makefile
parent43fd2acf691ece89845918c79af8c722608ddbc7 (diff)
downloadfreebsd-ports-gnome-e8bb8f2381fb4bc2bb177b9d7066a550124d0f8a.tar.gz
freebsd-ports-gnome-e8bb8f2381fb4bc2bb177b9d7066a550124d0f8a.tar.zst
freebsd-ports-gnome-e8bb8f2381fb4bc2bb177b9d7066a550124d0f8a.zip
New port: www/urchin, web traffic analysis tool
Urchin is the most powerful web traffic analysis program available. We have set this to install into $PREFIX/urchin, i.e. /usr/local/urchin and upon completion two services start up, our Apache server on port 9999 and a scheduling daemon. If starting up a service is a problem, it can be adjusted in the Makefile (START_SERVERS = yes). PR: ports/58646 Submitted by: Doug Silver <freebsd@urchin.com>
Diffstat (limited to 'www/urchin5/Makefile')
-rw-r--r--www/urchin5/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/www/urchin5/Makefile b/www/urchin5/Makefile
new file mode 100644
index 000000000000..d960225f63a3
--- /dev/null
+++ b/www/urchin5/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: urchin5
+# Date created: September 8, 2003
+# Whom: Urchin Software
+#
+# $FreeBSD$
+#
+
+PORTNAME= urchin
+PORTVERSION= 5.101
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.urchin.com/pub/urchin5/
+DISTNAME= urchin5101_freebsd4x
+
+MAINTAINER= freebsd@urchin.com
+COMMENT= The most powerful web traffic analysis program available
+
+ONLY_FOR_ARCHS= i386
+LICENSE= commercial
+RESTRICTED= "Commercial software, also comes bundled with Apache-SSL"
+NO_BUILD= YES
+NO_CDROM= "Our installer must be run for proper permissions to be set"
+NO_PACKAGE= "Our installer must be run for proper permissions to be set"
+
+# Feel free to change this to the user you want Urchin 5 to
+# run as and the files to be owned by. It's *strongly* advised
+# to make this a non-privileged user. The port can be changed later
+# if desired.
+USER?= nobody
+GROUP?= nobody
+PORT= 9999
+INSTALLDIR= ${PREFIX}/urchin
+QUIET= -q
+START_SERVERS= yes
+
+do-configure:
+ ${CP} ${FILESDIR}/install.sh ./work
+
+do-install:
+ @if test -f ${INSTALLDIR}/data/conf/uconf.uni; then \
+ ${ECHO_CMD} "The Urchin configuration files already exist,"; \
+ ${ECHO_CMD} "so I will attempt to do an upgrade instead of a new installation."; \
+ ${ECHO_CMD} ; \
+ cd ./work; \
+ ${SH} ./install.sh ${QUIET} -d ${INSTALLDIR} -p ${PORT} -u ${USER} -g ${GROUP} -s ${START_SERVERS} -m; \
+ else \
+ cd ./work; \
+ ${SH} ./install.sh ${QUIET} -d ${INSTALLDIR} -p ${PORT} -u ${USER} -g ${GROUP} -s ${START_SERVERS} -n; \
+ fi
+
+post-install:
+ ${INSTALL_DATA} ${INSTALLDIR}/util/urchin_daemons ${PREFIX}/etc/rc.d/urchin5_daemons.sh-dist
+ @if [ ! -f ${PREFIX}/etc/rc.d/urchin5_daemons.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/urchin5_daemons.sh startup file."; \
+ ${INSTALL_SCRIPT} ${INSTALLDIR}/util/urchin_daemons ${PREFIX}/etc/rc.d/urchin5_daemons.sh; \
+ fi
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Thank you for installing Urchin 5!"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Be sure to read the license agreement in ${INSTALLDIR}/doc/license.txt"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>