aboutsummaryrefslogtreecommitdiffstats
path: root/www/uzbl
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2011-10-11 01:51:17 +0800
committernovel <novel@FreeBSD.org>2011-10-11 01:51:17 +0800
commit255a676f3803d1f486ee310e29d39560ec301be6 (patch)
treee2e57b3484d0c63398366a33fbd308b853e49747 /www/uzbl
parentb007f30b5991b58325c6061edb8ef9ec470fcf0c (diff)
downloadfreebsd-ports-gnome-255a676f3803d1f486ee310e29d39560ec301be6.tar.gz
freebsd-ports-gnome-255a676f3803d1f486ee310e29d39560ec301be6.tar.zst
freebsd-ports-gnome-255a676f3803d1f486ee310e29d39560ec301be6.zip
- update to version as of 2011/10/01
- add missing run dependency on dmenu (reported by Pierre Smars) - replace tac by tail -r in the example scripts, as tail is in the base system (reported by Pierre Smars) PR: 161384 Submitted by: Klaus Aehlig (maintainer)
Diffstat (limited to 'www/uzbl')
-rw-r--r--www/uzbl/Makefile6
-rw-r--r--www/uzbl/distinfo4
-rw-r--r--www/uzbl/files/patch-examples__data__scripts__instance-select-wii.sh11
-rw-r--r--www/uzbl/files/patch-examples__data__scripts__load_url_from_history.sh11
4 files changed, 27 insertions, 5 deletions
diff --git a/www/uzbl/Makefile b/www/uzbl/Makefile
index 0c26c4590a50..95deab4e88b5 100644
--- a/www/uzbl/Makefile
+++ b/www/uzbl/Makefile
@@ -7,7 +7,6 @@
PORTNAME= uzbl
DISTVERSION= 0.0.0.${GITDATE}
-PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.linta.de/distfiles/
@@ -16,6 +15,7 @@ COMMENT= Web interface tools which adhere to the unix philosophy
LIB_DEPENDS= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
RUN_DEPENDS= socat:${PORTSDIR}/net/socat \
+ dmenu:${PORTSDIR}/x11/dmenu \
${PYTHON_PKGNAMEPREFIX}gtk>=2:${PORTSDIR}/x11-toolkits/py-gtk2
USE_GNOME= gtk20
@@ -23,8 +23,8 @@ USE_LDCONFIG= yes
USE_GMAKE= yes
USE_PYTHON= yes
-GITDATE= 2011.07.25
-GITVERSION= 9b73b93
+GITDATE= 2011.10.01
+GITVERSION= 9576f59
WRKSRC= ${WRKDIR}/Dieterbe-uzbl-${GITVERSION}
diff --git a/www/uzbl/distinfo b/www/uzbl/distinfo
index 879641316ef9..c13c0a528a33 100644
--- a/www/uzbl/distinfo
+++ b/www/uzbl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (uzbl-0.0.0.2011.07.25.tar.gz) = 2e61fa6c62e48d3f13e95a4ea7e7aead65345f6c88a688844ef921685dffe565
-SIZE (uzbl-0.0.0.2011.07.25.tar.gz) = 146851
+SHA256 (uzbl-0.0.0.2011.10.01.tar.gz) = fd72ea7e3246e904b451cda8339a1aab2fcd259ec07ec82aa0c9affe6084c2fe
+SIZE (uzbl-0.0.0.2011.10.01.tar.gz) = 148483
diff --git a/www/uzbl/files/patch-examples__data__scripts__instance-select-wii.sh b/www/uzbl/files/patch-examples__data__scripts__instance-select-wii.sh
new file mode 100644
index 000000000000..fd5cede3ba95
--- /dev/null
+++ b/www/uzbl/files/patch-examples__data__scripts__instance-select-wii.sh
@@ -0,0 +1,11 @@
+--- examples/data/scripts/instance-select-wmii.sh.orig 2011-10-06 03:29:31.000000000 +0100
++++ examples/data/scripts/instance-select-wmii.sh 2011-10-06 03:30:05.000000000 +0100
+@@ -35,7 +35,7 @@
+ ;;
+ "prev")
+ current="$( wmiir read /client/sel/ctl | head -n 1 )"
+- prev="$( wmiir read /tag/sel/index | grep -B 10000 " $current " | tac | grep -m 1 uzbl | cut -d ' ' -f 2 )"
++ prev="$( wmiir read /tag/sel/index | grep -B 10000 " $current " | tail -r | grep -m 1 uzbl | cut -d ' ' -f 2 )"
+ if [ -n "$prev" ]; then
+ wmiir xwrite /tag/sel/ctl "select client $prev"
+ fi
diff --git a/www/uzbl/files/patch-examples__data__scripts__load_url_from_history.sh b/www/uzbl/files/patch-examples__data__scripts__load_url_from_history.sh
new file mode 100644
index 000000000000..5e4fb862349a
--- /dev/null
+++ b/www/uzbl/files/patch-examples__data__scripts__load_url_from_history.sh
@@ -0,0 +1,11 @@
+--- examples/data/scripts/load_url_from_history.sh.orig 2011-10-06 03:31:31.000000000 +0100
++++ examples/data/scripts/load_url_from_history.sh 2011-10-06 03:32:32.000000000 +0100
+@@ -15,7 +15,7 @@
+ else
+ # choose an item in reverse order, showing also the date and page titles
+ # pick the last field from the first 3 fields. this way you can pick a url (prefixed with date & time) or type just a new url.
+- goto="$( tac "$UZBL_HISTORY_FILE" | $DMENU | cut -d ' ' -f -3 | awk '{ print $NF }' )"
++ goto="$( tail -r "$UZBL_HISTORY_FILE" | $DMENU | cut -d ' ' -f -3 | awk '{ print $NF }' )"
+ fi
+
+ [ -n "$goto" ] && echo "uri $goto" > "$UZBL_FIFO"