aboutsummaryrefslogtreecommitdiffstats
path: root/www/varnish-nagios
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-10-26 22:15:38 +0800
committerfeld <feld@FreeBSD.org>2016-10-26 22:15:38 +0800
commite24bd4a9644e632cd1cead4fbc7fe9a778685807 (patch)
tree125613504f694a75a5dd106415a076575b9e5ad0 /www/varnish-nagios
parent88019eeab43323265055d04cb72b8064da456264 (diff)
downloadfreebsd-ports-gnome-e24bd4a9644e632cd1cead4fbc7fe9a778685807.tar.gz
freebsd-ports-gnome-e24bd4a9644e632cd1cead4fbc7fe9a778685807.tar.zst
freebsd-ports-gnome-e24bd4a9644e632cd1cead4fbc7fe9a778685807.zip
Introduce USES=varnish
You can now set the default version of Varnish with DEFAULT_VERSIONS to build Varnish and its modules against your desired Varnish release train. The default version of Varnish throughout the ports tree will remain as www/varnish4 until at least 2017Q1 when it will be changed in HEAD to be www/varnish5. This should allow plenty of time for migration and for stabilization of the changes in Varnish 5.x. Submitted by: vanilla
Diffstat (limited to 'www/varnish-nagios')
-rw-r--r--www/varnish-nagios/Makefile7
-rw-r--r--www/varnish-nagios/files/patch-check__varnish.c11
2 files changed, 14 insertions, 4 deletions
diff --git a/www/varnish-nagios/Makefile b/www/varnish-nagios/Makefile
index 8cacc2bcd166..975cdeefb308 100644
--- a/www/varnish-nagios/Makefile
+++ b/www/varnish-nagios/Makefile
@@ -3,7 +3,7 @@
PORTNAME= varnish-nagios
PORTVERSION= 1.1.20151214
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= ports@FreeBSD.org
@@ -11,13 +11,12 @@ COMMENT= Nagios plugin to check status of Varnish
LICENSE= BSD2CLAUSE
-BUILD_DEPENDS= varnish4>=0:www/varnish4
RUN_DEPENDS= sudo:security/sudo
GNU_CONFIGURE= yes
CFLAGS+= -lm
-USES= autoreconf libtool pkgconfig
+USES= autoreconf libtool pkgconfig varnish
USE_GITHUB= yes
GH_ACCOUNT= varnish
@@ -25,7 +24,7 @@ GH_TAGNAME= 258c486
PLIST_FILES= libexec/nagios/check_varnish
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
diff --git a/www/varnish-nagios/files/patch-check__varnish.c b/www/varnish-nagios/files/patch-check__varnish.c
new file mode 100644
index 000000000000..b7ae8e71cd5f
--- /dev/null
+++ b/www/varnish-nagios/files/patch-check__varnish.c
@@ -0,0 +1,11 @@
+--- check_varnish.c.orig 2016-10-26 07:20:18 UTC
++++ check_varnish.c
+@@ -326,7 +326,7 @@ main(int argc, char **argv)
+ VSC_Setup(vd);
+ #endif
+
+- while ((opt = getopt(argc, argv, VSC_ARGS "c:hn:p:vw:")) != -1) {
++ while ((opt = getopt(argc, argv, "f:n:N:c:hn:p:vw:")) != -1) {
+ switch (opt) {
+ case 'c':
+ if (parse_range(optarg, &critical) != 0)