aboutsummaryrefslogtreecommitdiffstats
path: root/www/w3-4/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-12-18 13:26:32 +0800
committerasami <asami@FreeBSD.org>1996-12-18 13:26:32 +0800
commit85b0b80e456ed704aa8798e6127f90d2e3b501d3 (patch)
tree6ea2970168c7a6913b511221a10d50d68ebd8bc7 /www/w3-4/Makefile
parenta105e523732e3d7ceea832b3ec98c7177c460870 (diff)
downloadfreebsd-ports-gnome-85b0b80e456ed704aa8798e6127f90d2e3b501d3.tar.gz
freebsd-ports-gnome-85b0b80e456ed704aa8798e6127f90d2e3b501d3.tar.zst
freebsd-ports-gnome-85b0b80e456ed704aa8798e6127f90d2e3b501d3.zip
Web browser based on emacs/mule.
Submitted by: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
Diffstat (limited to 'www/w3-4/Makefile')
-rw-r--r--www/w3-4/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/w3-4/Makefile b/www/w3-4/Makefile
new file mode 100644
index 000000000000..a303be9cc242
--- /dev/null
+++ b/www/w3-4/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: w3 on Emacs
+# Version required: 2.2.26
+# Date created: 30 November 1996
+# Whom: MITA Yoshio <mita@ee.t.u-tokyo.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= w3-2.2.26
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.iij.ad.jp/pub/network/WWW/w3/ \
+ ftp://ftp.cs.indiana.edu/pub/elisp/w3/
+
+MAINTAINER= kiri@kiri.toba-cmt.ac.jp
+
+BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+
+WRKSRC= ${WRKDIR}/w3
+
+DOCDIR= ${PREFIX}/share/doc/w3
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @if [ ! -d ${DOCDIR} ]; then mkdir -p ${DOCDIR}; fi
+.for f in .emacs .mosaic-hotlist-default
+ @${CP} ${FILESDIR}/${f} ${DOCDIR}
+.endfor
+ @${INSTALL_SCRIPT} ${FILESDIR}/user-install ${DOCDIR}
+.for f in W3.ad clean-cache Makefile w3.txi
+ @${CP} ${WRKSRC}/${f} ${DOCDIR}
+.endfor
+.endif
+ @/bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>