aboutsummaryrefslogtreecommitdiffstats
path: root/www/w3m
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-02-07 06:25:15 +0800
committerkris <kris@FreeBSD.org>2000-02-07 06:25:15 +0800
commit45e734b715cad00326e706e4f856af51cb76ca85 (patch)
treea9c1d83c6368bec06da860c56ab94908b171e1ec /www/w3m
parentb656f339d7a800f4da4097a7f56fedf64b601422 (diff)
downloadfreebsd-ports-gnome-45e734b715cad00326e706e4f856af51cb76ca85.tar.gz
freebsd-ports-gnome-45e734b715cad00326e706e4f856af51cb76ca85.tar.zst
freebsd-ports-gnome-45e734b715cad00326e706e4f856af51cb76ca85.zip
USE_OPENSSL
Assisted by: Jim Bloom <bloom@acm.org>
Diffstat (limited to 'www/w3m')
-rw-r--r--www/w3m/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 064af9ff539d..2d48a8dcaef7 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -16,10 +16,6 @@ MASTER_SITES= ftp://ei5nazha.yz.yamagata-u.ac.jp/w3m/dev/ \
MAINTAINER= nobutaka@nobutaka.com
-.if defined(USE_SSL)
-RESTRICTED= "Contains cryptography"
-.endif
-
BUILD_DEPENDS= ${LOCALBASE}/lib/libgc.a:${PORTSDIR}/devel/boehm-gc
WRKSRC= ${WRKDIR}/w3m
@@ -47,21 +43,16 @@ DOCS_JP= ${DOCS} HISTORY HISTORY.kokb README.keymap README.kokb \
README.menu
.endif
-.if defined(USE_SSL)
-LIB_DEPENDS+= crypto.1:${PORTSDIR}/security/openssl \
- ssl.1:${PORTSDIR}/security/openssl
-
-SSL_CFLAGS= -I${LOCALBASE}/include/openssl
-SSL_LIBS= -lssl -lcrypto
-.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
-EXTRA_SSL_LIBS= -lRSAglue -lrsaref
-.endif
+.if defined(USE_OPENSSL)
+SSL_CFLAGS= -I${OPENSSLINC}/openssl -I${OPENSSLINC}
+SSL_LIBS= -L${OPENSSLLIB} -lssl -lcrypto
SED_CMD+= -e "s,undef USE_SSL,define USE_SSL,g"
.endif
-MAKE_FLAGS+= DEFS="-I${LOCALBASE}/include ${SSL_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib ${SSL_LIBS} ${EXTRA_SSL_LIBS}"
+EXTRA_SSL_LIBS= -lRSAglue -lrsaref -L${LOCALBASE}/lib
+MAKE_FLAGS+= DEFS="${SSL_CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="${SSL_LIBS} ${EXTRA_SSL_LIBS}"
post-configure:
@${CP} ${TARGET} ${TARGET}.in