aboutsummaryrefslogtreecommitdiffstats
path: root/www/waccess
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-11-30 02:52:43 +0800
committerpetef <petef@FreeBSD.org>2001-11-30 02:52:43 +0800
commit76f3f09fc5d95b905aa5e8d960eab2b683122d3e (patch)
tree96922e3c23c53b9f6631bed65eaf1bd19738fe05 /www/waccess
parentd7906f6b374b2c2ad3d8d8b51c64bb103bf96c57 (diff)
downloadfreebsd-ports-gnome-76f3f09fc5d95b905aa5e8d960eab2b683122d3e.tar.gz
freebsd-ports-gnome-76f3f09fc5d95b905aa5e8d960eab2b683122d3e.tar.zst
freebsd-ports-gnome-76f3f09fc5d95b905aa5e8d960eab2b683122d3e.zip
Add waccess-1.1, a quick-n-dirty web access log analyzer
PR: 29418 Submitted by: Tim Daneliuk <tundra@tundraware.com>
Diffstat (limited to 'www/waccess')
-rw-r--r--www/waccess/Makefile32
-rw-r--r--www/waccess/distinfo1
-rw-r--r--www/waccess/pkg-comment1
-rw-r--r--www/waccess/pkg-descr7
-rw-r--r--www/waccess/pkg-plist3
5 files changed, 44 insertions, 0 deletions
diff --git a/www/waccess/Makefile b/www/waccess/Makefile
new file mode 100644
index 000000000000..34db6053e065
--- /dev/null
+++ b/www/waccess/Makefile
@@ -0,0 +1,32 @@
+# ports collection makefile for: waccess
+# Date Created: 3 August 2001
+# Whom: tundra
+#
+# $FreeBSD$
+#
+
+PORTNAME= waccess
+PORTVERSION= 1.1
+CATEGORIES= www textproc
+MASTER_SITES= http://www.tundraware.com/Software/waccess/
+
+MAINTAINER= tundra@tundraware.com
+
+USE_PYTHON= yes
+
+MAN1= waccess.1
+MANCOMPRESSED= yes
+
+post-patch:
+ @${PERL} -pi -e 's,^#!/usr/local/bin/python,#!${PYTHON_CMD},' \
+ ${WRKSRC}/waccess
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/waccess ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/waccess.1.gz ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/waccess-license.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/waccess/distinfo b/www/waccess/distinfo
new file mode 100644
index 000000000000..8d9696dda7d8
--- /dev/null
+++ b/www/waccess/distinfo
@@ -0,0 +1 @@
+MD5 (waccess-1.1.tar.gz) = f2b89cd38ea9743595ba2eda4df7161c
diff --git a/www/waccess/pkg-comment b/www/waccess/pkg-comment
new file mode 100644
index 000000000000..5c5a7a6a5fbe
--- /dev/null
+++ b/www/waccess/pkg-comment
@@ -0,0 +1 @@
+Quick-N-Dirty Web Access Log Analyzer
diff --git a/www/waccess/pkg-descr b/www/waccess/pkg-descr
new file mode 100644
index 000000000000..f4c6f97da327
--- /dev/null
+++ b/www/waccess/pkg-descr
@@ -0,0 +1,7 @@
+waccess is a "quickie" way to do simple web access log file analysis.
+It is not a replacement for a serious log analysis tool, but it's
+handy if you just want to know simple things, like how many times
+a particular file has been accessed, and by whom.
+
+- tim
+tundra@tundraware.com
diff --git a/www/waccess/pkg-plist b/www/waccess/pkg-plist
new file mode 100644
index 000000000000..79c7a09c6f96
--- /dev/null
+++ b/www/waccess/pkg-plist
@@ -0,0 +1,3 @@
+bin/waccess
+%%PORTDOCS%%share/doc/waccess/waccess-license.txt
+%%PORTDOCS%%@dirrm share/doc/waccess