aboutsummaryrefslogtreecommitdiffstats
path: root/www/waterfox
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-04-21 04:08:04 +0800
committerjbeich <jbeich@FreeBSD.org>2018-04-21 04:08:04 +0800
commit1df40bc303e66e032b17f8394e9ced3b6ac6fb08 (patch)
treefa228452bd8150ea789e5fe871c03ae2cb988a38 /www/waterfox
parente01317c006fb39b3a241cfc7ec7e389e33993847 (diff)
downloadfreebsd-ports-gnome-1df40bc303e66e032b17f8394e9ced3b6ac6fb08.tar.gz
freebsd-ports-gnome-1df40bc303e66e032b17f8394e9ced3b6ac6fb08.tar.zst
freebsd-ports-gnome-1df40bc303e66e032b17f8394e9ced3b6ac6fb08.zip
www/waterfox: apply some FF60 fixes
Diffstat (limited to 'www/waterfox')
-rw-r--r--www/waterfox/Makefile2
-rw-r--r--www/waterfox/files/patch-bug144314932
-rw-r--r--www/waterfox/files/patch-bug145053827
3 files changed, 60 insertions, 1 deletions
diff --git a/www/waterfox/Makefile b/www/waterfox/Makefile
index a65d4709c4f3..1d46046dd36e 100644
--- a/www/waterfox/Makefile
+++ b/www/waterfox/Makefile
@@ -2,7 +2,7 @@
PORTNAME= waterfox
DISTVERSION= 56.1.0
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= www ipv6
MAINTAINER= jbeich@FreeBSD.org
diff --git a/www/waterfox/files/patch-bug1443149 b/www/waterfox/files/patch-bug1443149
new file mode 100644
index 000000000000..71b90d64818b
--- /dev/null
+++ b/www/waterfox/files/patch-bug1443149
@@ -0,0 +1,32 @@
+commit b28daeec3432
+Author: Jamie Nicol <jnicol@mozilla.com>
+Date: Wed Mar 14 16:42:37 2018 +0000
+
+ Bug 1443149 - Ensure WebGLFBAttachPoint::HasImage() before dereferencing Format(). r=jrmuizel a=jcristau
+
+ Previously we were checking IsDefined() rather than HasImage(), but
+ were hitting crashes. This was because Format() can return null if the
+ attach point is defined but the attached texture level or renderbuffer
+ aren't themselves defined. HasImage() checks for this case.
+
+ MozReview-Commit-ID: 8KY3zPXXAFv
+
+ --HG--
+ extra : source : ebb9f83337a22ae8e77c3e7129f65178f1bedec5
+---
+ dom/canvas/WebGLContextFramebufferOperations.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git dom/canvas/WebGLContextFramebufferOperations.cpp dom/canvas/WebGLContextFramebufferOperations.cpp
+index 7133cdec2448..84a58e9da49f 100644
+--- dom/canvas/WebGLContextFramebufferOperations.cpp
++++ dom/canvas/WebGLContextFramebufferOperations.cpp
+@@ -33,7 +33,7 @@ WebGLContext::Clear(GLbitfield mask)
+ if (mask & LOCAL_GL_COLOR_BUFFER_BIT && mBoundDrawFramebuffer) {
+ if (mask & LOCAL_GL_COLOR_BUFFER_BIT) {
+ for (const auto& cur : mBoundDrawFramebuffer->ColorDrawBuffers()) {
+- if (!cur->IsDefined())
++ if (!cur->HasImage())
+ continue;
+
+ switch (cur->Format()->format->componentType) {
diff --git a/www/waterfox/files/patch-bug1450538 b/www/waterfox/files/patch-bug1450538
new file mode 100644
index 000000000000..972d14989a87
--- /dev/null
+++ b/www/waterfox/files/patch-bug1450538
@@ -0,0 +1,27 @@
+commit 62f1f53340be
+Author: Masatoshi Kimura <VYV03354@nifty.ne.jp>
+Date: Sat Apr 14 10:29:36 2018 +0900
+
+ Bug 1450538 - Use nsIURI::GetDisplaySpec to compensate a change to nsIURI::GetSpec. r=valentin a=jcristau
+
+ MozReview-Commit-ID: 5xYAbx78K3q
+
+ --HG--
+ extra : source : aee0f2f18cde9801a95357c309bcdce7adf0f4f6
+---
+ docshell/base/nsDocShell.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git docshell/base/nsDocShell.cpp docshell/base/nsDocShell.cpp
+index 608977e54ec7..aae0e29265be 100644
+--- docshell/base/nsDocShell.cpp
++++ docshell/base/nsDocShell.cpp
+@@ -13816,7 +13816,7 @@ nsDocShell::OnOverLink(nsIContent* aContent,
+ }
+
+ nsAutoCString spec;
+- rv = aURI->GetSpec(spec);
++ rv = aURI->GetDisplaySpec(spec);
+ NS_ENSURE_SUCCESS(rv, rv);
+
+ NS_ConvertUTF8toUTF16 uStr(spec);