aboutsummaryrefslogtreecommitdiffstats
path: root/www/wb0
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2004-02-17 15:36:03 +0800
committertrevor <trevor@FreeBSD.org>2004-02-17 15:36:03 +0800
commitcfe7609671875357882664d5cd5061db39f5d1e3 (patch)
treed58ff7ac12488b8058fcf9dd8b03bdc7b53eefa9 /www/wb0
parent5d239ac9eac78d0508fc14080bf796aad2c13980 (diff)
downloadfreebsd-ports-gnome-cfe7609671875357882664d5cd5061db39f5d1e3.tar.gz
freebsd-ports-gnome-cfe7609671875357882664d5cd5061db39f5d1e3.tar.zst
freebsd-ports-gnome-cfe7609671875357882664d5cd5061db39f5d1e3.zip
Use sed instead of in-place sed, and be quiet about it.
Diffstat (limited to 'www/wb0')
-rw-r--r--www/wb0/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/wb0/Makefile b/www/wb0/Makefile
index 21caca9ec901..c7cf60c503b2 100644
--- a/www/wb0/Makefile
+++ b/www/wb0/Makefile
@@ -24,12 +24,12 @@ DOCDIR= share/doc/${PORTNAME}
DOCS= AUTHORS Changelog README
ONLY_FOR_ARCHS= i386
PLIST= ${WRKDIR}/pkg-plist
-USE_REINPLACE= yes
post-patch:
- ${REINPLACE_CMD} -e 's|/etc/wb0|${LOCALBASE}/etc|g ; \
+ @${MV} ${WRKSRC}/wb0.c ${WRKSRC}/wb0.c.orig
+ @${SED} -e 's|/etc/wb0|${LOCALBASE}/etc|g ; \
s|/usr/local/src/wb0/font/bit|${LOCALBASE}/share/wb0/|g' \
- ${WRKSRC}/wb0.c
+ < ${WRKSRC}/wb0.c.orig > ${WRKSRC}/wb0.c
pre-install:
${ECHO_CMD} bin/wb0 > ${PLIST}