aboutsummaryrefslogtreecommitdiffstats
path: root/www/web-traceroute
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-30 22:53:14 +0800
committerpav <pav@FreeBSD.org>2003-12-30 22:53:14 +0800
commit2b01cee8823b0376d316b5b3ebab2996d4db7308 (patch)
tree65b08f4c9ec545f0aa2034e9fd875e727a0352e0 /www/web-traceroute
parent1aca7b31913c7e6377ba26f2ae78ac809bab7333 (diff)
downloadfreebsd-ports-gnome-2b01cee8823b0376d316b5b3ebab2996d4db7308.tar.gz
freebsd-ports-gnome-2b01cee8823b0376d316b5b3ebab2996d4db7308.tar.zst
freebsd-ports-gnome-2b01cee8823b0376d316b5b3ebab2996d4db7308.zip
Add web-traceroute, a traceroute cgi for your website implemented in C.
PR: ports/58553 Submitted by: Dean Hollister <dean@odyssey.apana.org.au>
Diffstat (limited to 'www/web-traceroute')
-rw-r--r--www/web-traceroute/Makefile24
-rw-r--r--www/web-traceroute/distinfo1
-rw-r--r--www/web-traceroute/files/patch-Makefile32
-rw-r--r--www/web-traceroute/pkg-descr24
-rw-r--r--www/web-traceroute/pkg-plist1
5 files changed, 82 insertions, 0 deletions
diff --git a/www/web-traceroute/Makefile b/www/web-traceroute/Makefile
new file mode 100644
index 000000000000..1c65e2363897
--- /dev/null
+++ b/www/web-traceroute/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: www/web-traceroute
+# Date created: Sun Oct 26 12:00:00 WST 2003
+# Whom: Dean Hollister <dean@odyssey.apana.org.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= web-traceroute
+PORTVERSION= 3.0
+CATEGORIES= www
+MASTER_SITES= http://www.carpe.net/src/ \
+ http://www.wa.apana.org.au/~dean/sources/ \
+ ftp://ftp.wa.apana.org.au/pub/pc/unix/packages/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= dean@odyssey.apana.org.au
+COMMENT= WWW Traceroute CGI script written in C
+
+USE_APACHE= yes
+
+#pre-configure:
+# ${SH} ${SCRIPTDIR}/locate-template.sh
+
+.include <bsd.port.mk>
diff --git a/www/web-traceroute/distinfo b/www/web-traceroute/distinfo
new file mode 100644
index 000000000000..231b66575a42
--- /dev/null
+++ b/www/web-traceroute/distinfo
@@ -0,0 +1 @@
+MD5 (web-traceroute.tar.gz) = 4665d0424dfb93fcb1ccfbcd76fc8377
diff --git a/www/web-traceroute/files/patch-Makefile b/www/web-traceroute/files/patch-Makefile
new file mode 100644
index 000000000000..7ce6c65fffe2
--- /dev/null
+++ b/www/web-traceroute/files/patch-Makefile
@@ -0,0 +1,32 @@
+--- Makefile.old Sun Oct 26 12:10:35 2003
++++ Makefile Sun Oct 26 12:13:14 2003
+@@ -4,24 +4,26 @@
+
+ # BINDEST should be the directory/filename where the cgi program needs
+ # to be installed. This must be configured with your web server.
+-BINDEST = /ns/cgi-bin/trace
++BINDEST = $(PREFIX)/www/cgi-bin/trace
+
+ # CC and CCFLAGS should be set appropriately for your system
+ # or uncomment the one you need.
+ #
+ # HP-UX
+ CC = cc
+-CCFLAGS = -Aa +DA1.1 -D_HPUX_SOURCE
++#CCFLAGS = -Aa +DA1.1 -D_HPUX_SOURCE
+ #
+ # BSDI's BSD/OS (probably ok for any recent version of gcc)
+ # CC=gcc
+-# CCFLAGS = -O2
++CCFLAGS = $(CFLAGS)
+
+ DEFINES = -DLEAVE_DOMAIN_NAME
+
+ # normally traceroute must be setuid root
+ BINOWN = root
+ BINMODE = 4555
++
++all: html.h $(PROG)
+
+ $(PROG): $(PROG).c html.h
+ $(CC) $(CCFLAGS) $(DEFINES) -o $(PROG) $(PROG).c
diff --git a/www/web-traceroute/pkg-descr b/www/web-traceroute/pkg-descr
new file mode 100644
index 000000000000..a47f7e6dc041
--- /dev/null
+++ b/www/web-traceroute/pkg-descr
@@ -0,0 +1,24 @@
+This is a modified BSD traceroute command which outputs customized HTML
+and can be used as a cgi program directly.
+
+The advantage of using a compiled C program directly instead of a shell,
+tcl or perl scipt:
+
+More Secure (tastes better) - There is no possibility that strange
+characters or environment passed to the CGI program can be used to break
+into the server, etc.
+
+Less Overhead (less filling) - The whole CGI program runs as one very
+small process instead of multiple script processes and/or a large perl
+program which must be interpreted each time it is run.
+
+You can customise the HTML presented, by creating the template file
+"template.html", and entering it's full path when prompted. Insert the
+text "TRACEROUTE-OUTPUT" into your template file at the point where you
+require the traceroute results displayed. This makes web-traceroute
+integrate seamlessly with existing website layouts.
+
+WWW: http://www.carpe.net/src/index.html
+
+- Dean
+dean@odyssey.apana.org.au
diff --git a/www/web-traceroute/pkg-plist b/www/web-traceroute/pkg-plist
new file mode 100644
index 000000000000..bb2d8408c979
--- /dev/null
+++ b/www/web-traceroute/pkg-plist
@@ -0,0 +1 @@
+www/cgi-bin/trace