aboutsummaryrefslogtreecommitdiffstats
path: root/www/web2ldap/Makefile
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2000-08-01 22:48:21 +0800
committernbm <nbm@FreeBSD.org>2000-08-01 22:48:21 +0800
commitd16386b420a748bd01db06522e1c0e4ee6057c00 (patch)
tree9e40d4f9e758314822b596eff2818eec9c5312a0 /www/web2ldap/Makefile
parent1885a1b06e25afa994c8289816e90290488e069e (diff)
downloadfreebsd-ports-gnome-d16386b420a748bd01db06522e1c0e4ee6057c00.tar.gz
freebsd-ports-gnome-d16386b420a748bd01db06522e1c0e4ee6057c00.tar.zst
freebsd-ports-gnome-d16386b420a748bd01db06522e1c0e4ee6057c00.zip
Add web2ldap, an web-based LDAP client.
PR: ports/20095 Submitted by: Oddbjorn Steffensen <oddbjorn@tricknology.org>
Diffstat (limited to 'www/web2ldap/Makefile')
-rw-r--r--www/web2ldap/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/web2ldap/Makefile b/www/web2ldap/Makefile
new file mode 100644
index 000000000000..448d9ad4f112
--- /dev/null
+++ b/www/web2ldap/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: web2ldap
+# Date created: 21 July 2000
+# Whom: Oddbjorn Steffensen <oddbjorn@tricknology.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= web2ldap
+PORTVERSION= 0.7.7
+CATEGORIES= www
+MASTER_SITES= http://sites.inka.de/ms/python/web2ldap/download/
+
+MAINTAINER= oddbjorn@tricknology.org
+
+RUN_DEPENDS= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python \
+ ${LOCALBASE}/lib/python1.5/site-packages/ldapmodule.so:${PORTSDIR}/net/ldapmodule
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/${PORTNAME}
+ @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/cgi-bin/web2ldap.py.orig
+ @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/sbin/web2ldap.py.orig
+ @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/sbin/compile.py.orig
+ @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/etc/mime.types.orig
+ @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/etc/web2ldap/web2ldapcnf/misc.py.orig
+ @${RM} -f ${WRKDIR}/${PORTNAME}-${PORTVERSION}/etc/web2ldap/web2ldapcnf/standalone.py.orig
+ @${LOCALBASE}/bin/python ${WRKDIR}/${PORTNAME}-${PORTVERSION}/sbin/compile.py
+ @${CP} -r ${WRKDIR}/${PORTNAME}-${PORTVERSION}/ ${PREFIX}/${PORTNAME}
+ @if [ -w /var/log ]; then ${MKDIR} /var/log/web2ldap; fi
+
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>