aboutsummaryrefslogtreecommitdiffstats
path: root/www/web2ldap
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-17 04:53:46 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-17 04:53:46 +0800
commitcbe762e89132e12ca4da01fa77ec7862c1f5b82f (patch)
tree74cc9d48f203d9d1199d59be5ffe34ff5c1677ca /www/web2ldap
parent5a1aca96e94739ca0c6777ebe17fbae1daaefa4a (diff)
downloadfreebsd-ports-gnome-cbe762e89132e12ca4da01fa77ec7862c1f5b82f.tar.gz
freebsd-ports-gnome-cbe762e89132e12ca4da01fa77ec7862c1f5b82f.tar.zst
freebsd-ports-gnome-cbe762e89132e12ca4da01fa77ec7862c1f5b82f.zip
Do not ship mime.types, use misc/mime-support instead
PR: ports/81083 Submitted by: maintainer
Diffstat (limited to 'www/web2ldap')
-rw-r--r--www/web2ldap/Makefile11
-rw-r--r--www/web2ldap/files/patch-aa86
-rw-r--r--www/web2ldap/files/patch-ah2
-rw-r--r--www/web2ldap/pkg-plist1
4 files changed, 10 insertions, 90 deletions
diff --git a/www/web2ldap/Makefile b/www/web2ldap/Makefile
index ef84152c6c1e..aeafd5e20af7 100644
--- a/www/web2ldap/Makefile
+++ b/www/web2ldap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= web2ldap
PORTVERSION= 0.15.10
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.web2ldap.de/download/ \
http://www.tricknology.org/ports/
@@ -14,19 +15,25 @@ MASTER_SITES= http://www.web2ldap.de/download/ \
MAINTAINER= bsam@ipt.ru
COMMENT= Python-based WWW gateway to LDAP servers
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_ldap.so:${PORTSDIR}/net/py-ldap2
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_ldap.so:${PORTSDIR}/net/py-ldap2 \
+ ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
NO_BUILD= yes
USE_PYTHON= yes
+USE_REINPLACE= yes
SUB_FILES= pkg-message
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/etc/web2ldap/web2ldapcnf/standalone.py
+
do-install:
@${MKDIR} ${PREFIX}/${PORTNAME}
@${RM} -f ${WRKSRC}/fcgi/web2ldap.py.orig
@${RM} -f ${WRKSRC}/scgi/web2ldap.py.orig
@${RM} -f ${WRKSRC}/etc/web2ldap/web2ldapcnf/standalone.py.orig
- @${RM} -f ${WRKSRC}/etc/mime.types.orig
+ @${RM} -f ${WRKSRC}/etc/web2ldap/web2ldapcnf/standalone.py.bak
@${RM} -f ${WRKSRC}/sbin/compile.py.orig
@${RM} -f ${WRKSRC}/sbin/web2ldap.py.orig
@(cd ${WRKSRC} && ${LOCALBASE}/bin/python ./sbin/compile.py)
diff --git a/www/web2ldap/files/patch-aa b/www/web2ldap/files/patch-aa
deleted file mode 100644
index bb46b2ca1d52..000000000000
--- a/www/web2ldap/files/patch-aa
+++ /dev/null
@@ -1,86 +0,0 @@
-*** /dev/null Sat Jul 22 02:21:51 2000
---- etc/mime.types Sat Jul 22 02:24:24 2000
-***************
-*** 0 ****
---- 1,81 ----
-+ #
-+ # sample mime.types
-+ #
-+
-+ application/andrew-inset ez
-+ application/excel xls
-+ application/octet-stream bin
-+ application/oda oda
-+ application/pdf pdf
-+ application/pgp pgp
-+ application/postscript ps PS eps
-+ application/rtf rtf
-+ application/x-arj-compressed arj
-+ application/x-bcpio bcpio
-+ application/x-chess-pgn pgn
-+ application/x-cpio cpio
-+ application/x-csh csh
-+ application/x-debian-package deb
-+ application/x-msdos-program com exe bat
-+ application/x-dvi dvi
-+ application/x-gtar gtar
-+ application/x-gunzip gz
-+ application/x-hdf hdf
-+ application/x-latex latex
-+ application/x-mif mif
-+ application/x-netcdf cdf nc
-+ application/x-perl pl pm
-+ application/x-rar-compressed rar
-+ application/x-sh sh
-+ application/x-shar shar
-+ application/x-sv4cpio sv4cpio
-+ application/x-sv4crc sv4crc
-+ application/x-tar tar
-+ application/x-tar-gz tgz tar.gz
-+ application/x-tcl tcl
-+ application/x-tex tex
-+ application/x-texinfo texi texinfo
-+ application/x-troff t tr roff
-+ application/x-troff-man man
-+ application/x-troff-me me
-+ application/x-troff-ms ms
-+ application/x-ustar ustar
-+ application/x-wais-source src
-+ application/x-zip-compressed zip
-+
-+ audio/basic snd
-+ audio/midi mid midi
-+ audio/ulaw au
-+ audio/x-aiff aif aifc aiff
-+ audio/x-wav wav
-+
-+ image/gif gif
-+ image/ief ief
-+ image/jpeg jpe jpeg jpg
-+ image/png png
-+ image/tiff tif tiff
-+ image/x-cmu-raster ras
-+ image/x-portable-anymap pnm
-+ image/x-portable-bitmap pbm
-+ image/x-portable-graymap pgm
-+ image/x-portable-pixmap ppm
-+ image/x-rgb rgb
-+ image/x-xbitmap xbm
-+ image/x-xpixmap xpm
-+ image/x-xwindowdump xwd
-+
-+ text/html html htm
-+ text/plain asc txt
-+ text/richtext rtx
-+ text/tab-separated-values tsv
-+ text/x-setext etx
-+
-+ video/dl dl
-+ video/fli fli
-+ video/gl gl
-+ video/mpeg mp2 mpe mpeg mpg
-+ video/quicktime mov qt
-+ video/x-msvideo avi
-+ video/x-sgi-movie movie
-+
-+ x-world/x-vrml vrm vrml wrl
diff --git a/www/web2ldap/files/patch-ah b/www/web2ldap/files/patch-ah
index c7fd4eaee491..0f18b8b8111a 100644
--- a/www/web2ldap/files/patch-ah
+++ b/www/web2ldap/files/patch-ah
@@ -11,5 +11,5 @@
document_root = os.path.join(web2ldapcnf.web2ldap_dir,'htdocs')
# Path name of mime.types file
-! mime_types = '/usr/local/web2ldap/etc/mime.types'
+! mime_types = '%%LOCALBASE%%/etc/mime.types'
diff --git a/www/web2ldap/pkg-plist b/www/web2ldap/pkg-plist
index 177c9410b60a..6e2bbc9371ef 100644
--- a/www/web2ldap/pkg-plist
+++ b/www/web2ldap/pkg-plist
@@ -47,7 +47,6 @@ web2ldap/htdocs/compability.html
web2ldap/etc/httpd/sample-mod_fastcgi.conf
web2ldap/etc/httpd/sample-mod_scgi.conf
web2ldap/etc/init.d/web2ldap
-web2ldap/etc/mime.types
web2ldap/etc/web2ldap/web2ldapcnf/plugins/samba.py
web2ldap/etc/web2ldap/web2ldapcnf/plugins/msperson.py
web2ldap/etc/web2ldap/web2ldapcnf/plugins/edirectory.py