aboutsummaryrefslogtreecommitdiffstats
path: root/www/webalizer/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1998-06-28 20:42:09 +0800
committerandreas <andreas@FreeBSD.org>1998-06-28 20:42:09 +0800
commit8c2723b54a8b897d90cdee00a99f72c6c4bafd28 (patch)
treefcb0bbf54e560a5aca769b91cca2951d43bbaa48 /www/webalizer/Makefile
parent71d5c1d95afa00e76ced12553d576063094661cc (diff)
downloadfreebsd-ports-gnome-8c2723b54a8b897d90cdee00a99f72c6c4bafd28.tar.gz
freebsd-ports-gnome-8c2723b54a8b897d90cdee00a99f72c6c4bafd28.tar.zst
freebsd-ports-gnome-8c2723b54a8b897d90cdee00a99f72c6c4bafd28.zip
Import of new port webalizer 1.12.09
The Webalizer is a web server log file analysis program which produces usage statistics in HTML format for viewing with a browser. The results are presented in both columnar and graphical format, which facilitates interpretation. Yearly, monthly, daily and hourly usage statistics are presented, along with the ability to display usage by site, URL, referrer, user agent (browser) and country (user agent and referrer are only available if your web server procduces Combined log format files). PR: closes 7000 Submitted by: dirk.meyer@dinoex.sub.org
Diffstat (limited to 'www/webalizer/Makefile')
-rw-r--r--www/webalizer/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
new file mode 100644
index 000000000000..ac959de12712
--- /dev/null
+++ b/www/webalizer/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: webalizer
+# Version required: 1.12
+# Date created: 02.Jun 1998
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $Id$
+
+DISTNAME= webalizer-1.12-09-src
+PKGNAME= webalizer-1.12
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.mrunix.net/pub/webalizer/ \
+ ftp://ftp.dinoex.sub.de/pub/approved/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dirk.meyer@dinoex.sub.org
+
+BUILD_DEPENDS= ${PREFIX}/lib/libgd.a:${PORTSDIR}/graphics/gd
+
+BIN1= webalizer
+WRKSRC= ${WRKDIR}
+
+do-install:
+.for i in ${BIN1}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/bin
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/webalizer
+.for i in CHANGES COPYING Copyright README TODO webalizer.LSM
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/webalizer/${i}
+.endfor
+.endif
+ ${MKDIR} ${PREFIX}/share/examples/webalizer
+.for i in msfree.gif sample.conf
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/examples/webalizer/${i}
+.endfor
+
+.include <bsd.port.mk>