aboutsummaryrefslogtreecommitdiffstats
path: root/www/webcrawl/Makefile
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1999-02-04 05:26:59 +0800
committerbillf <billf@FreeBSD.org>1999-02-04 05:26:59 +0800
commit5b375c35f0867b817243e0e9705aa891a8ec606b (patch)
treea425176e246b55d0066251c46afd2fad7a423d1d /www/webcrawl/Makefile
parent2dcf2bafed7be3a8dbc10fcade5bd519842228ec (diff)
downloadfreebsd-ports-gnome-5b375c35f0867b817243e0e9705aa891a8ec606b.tar.gz
freebsd-ports-gnome-5b375c35f0867b817243e0e9705aa891a8ec606b.tar.zst
freebsd-ports-gnome-5b375c35f0867b817243e0e9705aa891a8ec606b.zip
WebCrawl is a program designed to download an entire web-site without
user interaction (although an interactive mode is available). It works simply by starting with a single web page, and following all links from that page to attempt to recreate the directory structure on the remote server. PR: ports/9846 Submitted By: Dima Sivachenko <dima@Chg.RU>
Diffstat (limited to 'www/webcrawl/Makefile')
-rw-r--r--www/webcrawl/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/webcrawl/Makefile b/www/webcrawl/Makefile
new file mode 100644
index 000000000000..ed6520e4e835
--- /dev/null
+++ b/www/webcrawl/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: webcrawl
+# Version required: 1.00
+# Date created: 31 January 1999
+# Whom: Dima Sivachenko
+#
+# $Id:$
+#
+
+DISTNAME= webcrawl-1.00
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/www/mirroring
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dima@chg.ru
+
+ALL_TARGET=
+
+MAN1= webcrawl.1
+
+do-install:
+
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/webcrawl ${PREFIX}/bin/
+ @ ${INSTALL_MAN} ${WRKSRC}/webcrawl.1 ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>