aboutsummaryrefslogtreecommitdiffstats
path: root/www/webkit-gtk3
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-10-03 18:57:26 +0800
committerkwm <kwm@FreeBSD.org>2013-10-03 18:57:26 +0800
commitf0589646ba78da5e3295e7ccced51bc8dcfa859b (patch)
treec55d925c124ba3a92508b7ab62906670bb002123 /www/webkit-gtk3
parent29f1f3b944d1fd9a883b37941e2e22f94b0a7ba3 (diff)
downloadfreebsd-ports-gnome-f0589646ba78da5e3295e7ccced51bc8dcfa859b.tar.gz
freebsd-ports-gnome-f0589646ba78da5e3295e7ccced51bc8dcfa859b.tar.zst
freebsd-ports-gnome-f0589646ba78da5e3295e7ccced51bc8dcfa859b.zip
Switch from RUN_DEPEND on gobject-introspection to USE_GNOME=introspection:build
Use new LIB_DEPEND syntax, enable stage support. Don't hardcode -lstdc++ to fix build on HEAD.
Diffstat (limited to 'www/webkit-gtk3')
-rw-r--r--www/webkit-gtk3/Makefile14
-rw-r--r--www/webkit-gtk3/files/patch-GNUmakefile.in12
2 files changed, 18 insertions, 8 deletions
diff --git a/www/webkit-gtk3/Makefile b/www/webkit-gtk3/Makefile
index 122f8ca9f799..ccae8cc7db18 100644
--- a/www/webkit-gtk3/Makefile
+++ b/www/webkit-gtk3/Makefile
@@ -14,19 +14,18 @@ COMMENT= An opensource browser engine
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
- gtkdoc-rebase:${PORTSDIR}/textproc/gtk-doc \
- g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS= enchant:${PORTSDIR}/textproc/enchant \
- icutu:${PORTSDIR}/devel/icu \
- curl:${PORTSDIR}/ftp/curl \
- soup-2.4:${PORTSDIR}/devel/libsoup
+ gtkdoc-rebase:${PORTSDIR}/textproc/gtk-doc
+LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
+ libicutu.so:${PORTSDIR}/devel/icu \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libsoup-2.4.so:${PORTSDIR}/devel/libsoup
USE_XZ= yes
USE_GSTREAMER= yes
USE_XORG= xt
USES= bison gmake pkgconfig gettext perl5
USE_AUTOTOOLS= libtool
-USE_GNOME= gtk30 libxslt ltverhack
+USE_GNOME= gtk30 introspection:build libxslt ltverhack
USE_SQLITE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -49,7 +48,6 @@ OPTIONS_DEFINE= WEBGL DEBUG
OPTIONS_DEFAULT=WEBGL
WEBGL_DESC= Enable Web GL support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MWEBGL}
diff --git a/www/webkit-gtk3/files/patch-GNUmakefile.in b/www/webkit-gtk3/files/patch-GNUmakefile.in
new file mode 100644
index 000000000000..05a3a314c784
--- /dev/null
+++ b/www/webkit-gtk3/files/patch-GNUmakefile.in
@@ -0,0 +1,12 @@
+--- GNUmakefile.in.orig 2013-10-03 09:22:02.000000000 +0000
++++ GNUmakefile.in 2013-10-03 09:23:50.000000000 +0000
+@@ -19060,8 +19060,7 @@
+ libjavascriptcoregtk-@WEBKITGTK_API_MAJOR_VERSION@.@WEBKITGTK_API_MINOR_VERSION@.la \
+ $(WINMM_LIBS) \
+ -lm \
+- -lpthread \
+- -lstdc++
++ -lpthread
+
+ Programs_minidom_LDFLAGS = \
+ -no-install \