aboutsummaryrefslogtreecommitdiffstats
path: root/www/webkit-sharp
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2009-02-09 17:00:01 +0800
committerflz <flz@FreeBSD.org>2009-02-09 17:00:01 +0800
commit84f177df4b25e296ab4e88ac43b3003773c26aab (patch)
tree632be02dafcc169396f21eceaade4ef8ecebd624 /www/webkit-sharp
parentc555079d778ca2b1a799a99246cabc428845a315 (diff)
downloadfreebsd-ports-gnome-84f177df4b25e296ab4e88ac43b3003773c26aab.tar.gz
freebsd-ports-gnome-84f177df4b25e296ab4e88ac43b3003773c26aab.tar.zst
freebsd-ports-gnome-84f177df4b25e296ab4e88ac43b3003773c26aab.zip
- Update lang/mono to 2.0.1.
- Also update a bunch of c-sharp ports to their latest version. - Change maintainership to mono@FreeBSD.org. PR: ports/129724 Submitted by: Phillip Neumann, Romain Tartiere (bsd-sharp team)
Diffstat (limited to 'www/webkit-sharp')
-rw-r--r--www/webkit-sharp/Makefile35
-rw-r--r--www/webkit-sharp/distinfo3
-rw-r--r--www/webkit-sharp/pkg-descr3
-rw-r--r--www/webkit-sharp/pkg-plist12
4 files changed, 53 insertions, 0 deletions
diff --git a/www/webkit-sharp/Makefile b/www/webkit-sharp/Makefile
new file mode 100644
index 000000000000..035dbfaf3e1a
--- /dev/null
+++ b/www/webkit-sharp/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: webkit-sharp
+# Date created: 2008-09-01
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webkit-sharp
+PORTVERSION= 0.2
+#PORTREVISION= 0
+#PORTEPOCH= 0
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.novell.com/pub/mono/sources/${PORTNAME}/
+#MASTER_SITE_SUBDIR=
+#PKGNAMEPREFIX=
+#PKGNAMESUFFIX=
+#DISTNAME=
+#EXTRACT_SUFX=
+#DISTFILES=
+#DIST_SUBDIR= ${PORTNAME}
+#EXTRACT_ONLY=
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Mono bindings for Webkit
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/webkit-1.0.pc:${PORTSDIR}/www/webkit-gtk2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtksharp20
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/www/webkit-sharp/distinfo b/www/webkit-sharp/distinfo
new file mode 100644
index 000000000000..2ca0ba27206e
--- /dev/null
+++ b/www/webkit-sharp/distinfo
@@ -0,0 +1,3 @@
+MD5 (webkit-sharp-0.2.tar.bz2) = 8041fba941b7299e432380c86b6dddf8
+SHA256 (webkit-sharp-0.2.tar.bz2) = ce0f87546d0a8c0a7f8d2c23075c80e109aa6c5fc30480b42f4c3c14ff5562a9
+SIZE (webkit-sharp-0.2.tar.bz2) = 81853
diff --git a/www/webkit-sharp/pkg-descr b/www/webkit-sharp/pkg-descr
new file mode 100644
index 000000000000..8c4b1875eda4
--- /dev/null
+++ b/www/webkit-sharp/pkg-descr
@@ -0,0 +1,3 @@
+WebKit# is a .NET language binding for the WebKit rendering engine.
+
+WWW: http://webkit.org
diff --git a/www/webkit-sharp/pkg-plist b/www/webkit-sharp/pkg-plist
new file mode 100644
index 000000000000..02d65e613ef0
--- /dev/null
+++ b/www/webkit-sharp/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+lib/mono/gac/webkit-sharp/1.0.0.0__eaa1d335d2e19745/webkit-sharp.dll
+lib/mono/gac/webkit-sharp/1.0.0.0__eaa1d335d2e19745/webkit-sharp.dll.config
+lib/mono/webkit-sharp/webkit-sharp.dll
+lib/monodoc/sources/webkit-sharp-docs.source
+lib/monodoc/sources/webkit-sharp-docs.tree
+lib/monodoc/sources/webkit-sharp-docs.zip
+libdata/pkgconfig/webkit-sharp-1.0.pc
+@dirrm lib/pkgconfig
+@dirrm lib/mono/webkit-sharp
+@dirrm lib/mono/gac/webkit-sharp/1.0.0.0__eaa1d335d2e19745
+@dirrm lib/mono/gac/webkit-sharp