aboutsummaryrefslogtreecommitdiffstats
path: root/www/wsdlpull/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-02-22 02:04:33 +0800
committergarga <garga@FreeBSD.org>2006-02-22 02:04:33 +0800
commit2e3e48a7906aa8a5c8c482aa2733e9d2a3b08d25 (patch)
treebbf0db57a500c8182a9a529cf1cbe6047a4afe22 /www/wsdlpull/Makefile
parent2b361146d9a8d0f85316cbdd4f44ec3e0de7e109 (diff)
downloadfreebsd-ports-gnome-2e3e48a7906aa8a5c8c482aa2733e9d2a3b08d25.tar.gz
freebsd-ports-gnome-2e3e48a7906aa8a5c8c482aa2733e9d2a3b08d25.tar.zst
freebsd-ports-gnome-2e3e48a7906aa8a5c8c482aa2733e9d2a3b08d25.zip
- Update to 1.9.8
PR: ports/93658 Submitted by: Ports Fury
Diffstat (limited to 'www/wsdlpull/Makefile')
-rw-r--r--www/wsdlpull/Makefile39
1 files changed, 18 insertions, 21 deletions
diff --git a/www/wsdlpull/Makefile b/www/wsdlpull/Makefile
index c9b8967ea749..17fa2f146ad3 100644
--- a/www/wsdlpull/Makefile
+++ b/www/wsdlpull/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wsdlpull
-DISTVERSION= 1.9.5c
+PORTVERSION= 1.9.8
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,31 +17,28 @@ COMMENT= C++ WSDL Parser
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
-USE_REINPLACE= yes
-USE_AUTOTOOLS= libtool:15
-USE_GETOPT_LONG=yes
WRKSRC= ${WRKDIR}/${DISTNAME:R}
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+
+USE_GNOME= gnometarget
+USE_GCC= 3.4+
+USE_GETOPT_LONG= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --includedir=${PREFIX}/include/wsdl
INSTALLS_SHLIB= yes
-DOCSDIR= ${PREFIX}/share/doc/wsdl
-PORTDOCS= *
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
- -e "s,[$$][(]prefix[)]/docs,${DOCSDIR},"
-
-.include <bsd.port.pre.mk>
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|: install-docsDATA|:|g'
post-install:
-.for dir in ${PREFIX}/include/wsdl ${PREFIX}/share/${PORTNAME}
- @${FIND} ${dir} ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${dir} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.endfor
-
-.include <bsd.port.post.mk>
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/wsdlpull.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>