aboutsummaryrefslogtreecommitdiffstats
path: root/www/wt
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2016-08-21 05:04:16 +0800
committerarved <arved@FreeBSD.org>2016-08-21 05:04:16 +0800
commitc6ff7101ab47d46274d4e922b9381bcfe86b6816 (patch)
treeff6cc954d03aacd652262fdcd7d377fff09de21d /www/wt
parente52b455c60a0903beacaa63dfd1219e8a9590385 (diff)
downloadfreebsd-ports-gnome-c6ff7101ab47d46274d4e922b9381bcfe86b6816.tar.gz
freebsd-ports-gnome-c6ff7101ab47d46274d4e922b9381bcfe86b6816.tar.zst
freebsd-ports-gnome-c6ff7101ab47d46274d4e922b9381bcfe86b6816.zip
- USE_GITHUB
- Remove/shorten overlong OPT_DESCR - Use option helpers - Other Cosmetic fixes No functional changes, so no PORTREVISION bump Based on suggestions by: danfe, gerald
Diffstat (limited to 'www/wt')
-rw-r--r--www/wt/Makefile211
-rw-r--r--www/wt/distinfo6
2 files changed, 73 insertions, 144 deletions
diff --git a/www/wt/Makefile b/www/wt/Makefile
index 9476907f5f4e..83bc406133eb 100644
--- a/www/wt/Makefile
+++ b/www/wt/Makefile
@@ -4,8 +4,6 @@
PORTNAME= wt
PORTVERSION= 3.3.6
CATEGORIES= www
-MASTER_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/archive/${PORTVERSION}/ \
- http://github.com/${GH_ACCOUNT}/${PORTNAME}/archive/${PORTVERSION}/
MAINTAINER= info@babaei.net
COMMENT= Widget-centric C++ library for developing web applications
@@ -13,7 +11,25 @@ COMMENT= Widget-centric C++ library for developing web applications
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
+LIB_DEPENDS+= libpng.so:graphics/png \
+ libboost_system.so:devel/boost-libs \
+ libGraphicsMagick.so:graphics/GraphicsMagick
+
+USE_GITHUB= yes
GH_ACCOUNT= kdeforche
+USE_LDCONFIG= yes
+USE_XORG+=x11
+USES= cmake:outsource pkgconfig ssl
+CMAKE_ARGS+= -DCONFIGDIR:STRING=${LOCALBASE}/etc/wt \
+ -DGM_PREFIX:STRING=${LOCALBASE} \
+ -DPNG_PREFIX:STRING=${LOCALBASE} \
+ -DSSL_PREFIX:STRING=/usr \
+ -DZLIB_PREFIX:STRING=/usr \
+ -DCONNECTOR_ISAPI:BOOL=OFF \
+ -DWEBUSER:STRING=www \
+ -DWEBGROUP:STRING=www \
+ -DWT_WRASTERIMAGE_IMPLEMENTATION:STRING=GraphicsMagick \
+ -DENABLE_SSL:BOOL=ON
NO_OPTIONS_SORT= yes
OPTIONS_DEFINE= \
@@ -30,8 +46,6 @@ OPTIONS_DEFINE= \
LIBWTTEST \
OPENGL
OPTIONS_DEFAULT= \
- DOCS \
- EXAMPLES \
TESTS \
RESOURCES \
CMAKE_MODULE \
@@ -41,19 +55,16 @@ OPTIONS_DEFAULT= \
OPENGL \
LIBWTTEST
OPTIONS_GROUP= CONNECTOR DBO WSTRING
+OPTIONS_SUB= yes
-DOCS_DESC= Build and/or install documentation
-EXAMPLES_DESC= Build and install examples (binaries and source, implies SQLITE3 and WTHTTP)
+EXAMPLES_DESC= Install examples (implies SQLITE3 and WTHTTP)
TESTS_DESC= Build Wt tests
RESOURCES_DESC= Install resources directory
-CMAKE_MODULE_DESC= Install FindWt.cmake in systemwide cmake dir (in addition to CMAKE_INSTALL_PREFIX/cmake)
+CMAKE_MODULE_DESC= Install FindWt.cmake in systemwide cmake dir
CPP11_DESC= Compile Wt in C++11 mode (Clang or GCC 4.6+)
-HARU_DESC= Enable Haru Free PDF Library, which is used to provide support for painting to PDF (WPdfImage)
-PANGO_DESC= Enable Pango Library, which is used for improved font support (WPdfImage and WRasterImage)
-EXT_DESC= Build Wt Ext library with JavaScript-only widgets (http://extjs.com/) DEPRECATED
-QT4_DESC= Build Qt4 interworking library (libwtwithqt)
+HARU_DESC= Enable Haru Free PDF Library
+EXT_DESC= Build Wt Ext library with JavaScript-only widgets
LIBWTTEST_DESC= Build Wt::Test for automated (integration/unit) tests
-OPENGL_DESC= Build Wt with support for server-side opengl rendering
OPTIONS_GROUP_CONNECTOR= FCGI WTHTTP
OPTIONS_DEFAULT += FCGI WTHTTP
@@ -71,50 +82,57 @@ MYSQL_DESC= Build Wt with MariaDB or MySQL support
OPTIONS_GROUP_WSTRING= NO_STD_LOCALE NO_STD_WSTRING
WSTRING_DESC= Wt::WString
-NO_STD_LOCALE_DESC= Build Wt to run on a system without std::locale support
-NO_STD_WSTRING_DESC= Build Wt to run on a system without std::wstring support
+NO_STD_LOCALE_DESC= Build for a system without std::locale support
+NO_STD_WSTRING_DESC= Build for a system without std::wstring support
EXAMPLES_IMPLIES= SQLITE3 WTHTTP
-USE_LDCONFIG= yes
-USES= cmake:outsource pkgconfig ssl
-USE_XORG+=x11
-MAKE_JOBS_SAFE= yes
-
-LIB_DEPENDS+= libpng.so:graphics/png \
- libboost_system.so:devel/boost-libs \
- libGraphicsMagick.so:graphics/GraphicsMagick
-
-CMAKE_ARGS+= -DCONFIGDIR:STRING=${LOCALBASE}/etc/wt \
- -DFCGI_PREFIX:STRING=${LOCALBASE} \
- -DFIREBIRD_PREFIX:STRING=${LOCALBASE} \
- -DGM_PREFIX:STRING=${LOCALBASE} \
- -DHARU_PREFIX:STRING=${LOCALBASE} \
- -DMYSQL_PREFIX:STRING=${LOCALBASE} \
- -DPNG_PREFIX:STRING=${LOCALBASE} \
- -DPOSTGRES_PREFIX:STRING=${LOCALBASE} \
- -DSQLITE3_PREFIX:STRING=${LOCALBASE} \
- -DSSL_PREFIX:STRING=/usr \
- -DZLIB_PREFIX:STRING=/usr \
- -DCONNECTOR_ISAPI:BOOL=OFF \
- -DWEBUSER:STRING=www \
- -DWEBGROUP:STRING=www \
- -DWT_WRASTERIMAGE_IMPLEMENTATION:STRING=GraphicsMagick \
- -DENABLE_SSL:BOOL=ON
+CMAKE_MODULE_CMAKE_ON= -DINSTALL_FINDWT_CMAKE_FILE:BOOL=ON
+CMAKE_MODULE_CMAKE_OFF= -DINSTALL_FINDWT_CMAKE_FILE:BOOL=OFF
+DOCS_CMAKE_ON= -DBUILD_DOCS:BOOL=ON
+DOCS_CMAKE_OFF= -DBUILD_DOCS:BOOL=OFF
+FCGI_CMAKE_ON= -DCONNECTOR_FCGI:BOOL=ON
+FCGI_CMAKE_OFF= -DCONNECTOR_FCGI:BOOL=OFF
+FIREBIRD_CMAKE_ON= -DENABLE_FIREBIRD:BOOL=ON
+FIREBIRD_CMAKE_OFF= -DENABLE_FIREBIRD:BOOL=OFF
+EXT_CMAKE_ON= -DENABLE_EXT:BOOL=ON
+EXT_CMAKE_OFF= -DENABLE_EXT:BOOL=OFF
+HARU_CMAKE_ON= -DENABLE_HARU:BOOL=ON
+HARU_CMAKE_OFF= -DENABLE_HARU:BOOL=OFF
+LIBWTTEST_CMAKE_ON= -DENABLE_LIBWTTEST:BOOL=ON
+LIBWTTEST_CMAKE_OFF= -DENABLE_LIBWTTEST:BOOL=OFF
+MYSQL_CMAKE_ON= -DENABLE_MYSQL:BOOL=ON
+MYSQL_CMAKE_OFF= -DENABLE_MYSQL:BOOL=OFF
+NO_STD_LOCALE_CMAKE_ON= -DWT_NO_STD_LOCALE:BOOL=ON
+NO_STD_LOCALE_CMAKE_OFF=-DWT_NO_STD_LOCALE:BOOL=OFF
+NO_STD_WSTRING_CMAKE_ON= -DWT_NO_STD_WSTRING:BOOL=ON
+NO_STD_WSTRING_CMAKE_OFF= -DWT_NO_STD_WSTRING:BOOL=OFF
+OPENGL_CMAKE_ON= -DENABLE_OPENGL:BOOL=ON
+OPENGL_CMAKE_OFF= -DENABLE_OPENGL:BOOL=OFF
+PANGO_CMAKE_ON= -DENABLE_PANGO:BOOL=ON
+PANGO_CMAKE_OFF= -DENABLE_PANGO:BOOL=OFF
+POSTGRES_CMAKE_ON= -DENABLE_POSTGRES:BOOL=ON
+POSTGRES_CMAKE_OFF= -DENABLE_POSTGRES:BOOL=OFF
+QT4_CMAKE_ON= -DENABLE_QT4:BOOL=ON
+QT4_CMAKE_OFF= -DENABLE_QT4:BOOL=OFF
+RESOURCES_CMAKE_ON= -DINSTALL_RESOURCES:BOOL=ON
+RESOURCES_CMAKE_OFF= -DINSTALL_RESOURCES:BOOL=OFF
+SQLITE_CMAKE_ON= -DENABLE_SQLITE:BOOL=ON
+SQLITE_CMAKE_OFF= -DENABLE_SQLITE:BOOL=OFF
+TESTS_CMAKE_ON= -DBUILD_TESTS:BOOL=ON
+TESTS_CMAKE_OFF= -DBUILD_TESTS:BOOL=OFF
+WTHTTP_CMAKE_ON= -DCONNECTOR_HTTP:BOOL=ON
+WTHTTP_CMAKE_OFF= -DCONNECTOR_HTTP:BOOL=OFF
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= asciidoc:textproc/asciidoc \
doxygen:devel/doxygen
-CMAKE_ARGS+= -DBUILD_DOCS:BOOL=ON
-.else
-CMAKE_ARGS+= -DBUILD_DOCS:BOOL=OFF
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
CMAKE_ARGS+= -DBUILD_EXAMPLES:BOOL=ON -DINSTALL_EXAMPLES:BOOL=ON
-PLIST_SUB+= EXAMPLES=""
.if ${PORT_OPTIONS:MSQLITE3} \
|| ${PORT_OPTIONS:MPOSTGRES} \
|| ${PORT_OPTIONS:MFIREBIRD} \
@@ -136,34 +154,11 @@ PLIST_SUB+= QT4_EXAMPLES="@comment "
.endif
.else
CMAKE_ARGS+= -DBUILD_EXAMPLES:BOOL=OFF -DINSTALL_EXAMPLES:BOOL=OFF
-PLIST_SUB+= EXAMPLES="@comment "
PLIST_SUB+= DBO_EXAMPLES="@comment "
PLIST_SUB+= DBO_SQLITE3_EXAMPLES="@comment "
PLIST_SUB+= QT4_EXAMPLES="@comment "
.endif
-.if ${PORT_OPTIONS:MTESTS}
-CMAKE_ARGS+= -DBUILD_TESTS:BOOL=ON
-.else
-CMAKE_ARGS+= -DBUILD_TESTS:BOOL=OFF
-.endif
-
-.if ${PORT_OPTIONS:MRESOURCES}
-CMAKE_ARGS+= -DINSTALL_RESOURCES:BOOL=ON
-PLIST_SUB+= RESOURCES=""
-.else
-CMAKE_ARGS+= -DINSTALL_RESOURCES:BOOL=OFF
-PLIST_SUB+= RESOURCES="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MCMAKE_MODULE}
-CMAKE_ARGS+= -DINSTALL_FINDWT_CMAKE_FILE:BOOL=ON
-PLIST_SUB+= CMAKE_MODULE=""
-.else
-CMAKE_ARGS+= -DINSTALL_FINDWT_CMAKE_FILE:BOOL=OFF
-PLIST_SUB+= CMAKE_MODULE="@comment "
-.endif
-
.if ${PORT_OPTIONS:MCPP11}
USES+= compiler:c++11-lib
CMAKE_ARGS+= -DWT_CPP_11_MODE:STRING=-std=c++0x
@@ -171,64 +166,26 @@ CMAKE_ARGS+= -DWT_CPP_11_MODE:STRING=-std=c++0x
.if ${PORT_OPTIONS:MHARU}
LIB_DEPENDS+= libhpdf.so:print/libharu
-CMAKE_ARGS+= -DENABLE_HARU:BOOL=ON
-.else
-CMAKE_ARGS+= -DENABLE_HARU:BOOL=OFF
+CMAKE_ARGS+= -DHARU_PREFIX:STRING=${LOCALBASE}
.endif
.if ${PORT_OPTIONS:MPANGO}
USE_GNOME+= pango
-CMAKE_ARGS+= -DENABLE_PANGO:BOOL=ON
-.else
-CMAKE_ARGS+= -DENABLE_PANGO:BOOL=OFF
-.endif
-
-.if ${PORT_OPTIONS:MEXT}
-CMAKE_ARGS+= -DENABLE_EXT:BOOL=ON
-PLIST_SUB+= EXT=""
-.else
-CMAKE_ARGS+= -DENABLE_EXT:BOOL=OFF
-PLIST_SUB+= EXT="@comment "
.endif
.if ${PORT_OPTIONS:MQT4}
-USE_QT4= corelib moc_build
-CMAKE_ARGS+= -DENABLE_QT4:BOOL=ON
-.else
-CMAKE_ARGS+= -DENABLE_QT4:BOOL=OFF
-.endif
-
-.if ${PORT_OPTIONS:MLIBWTTEST}
-CMAKE_ARGS+= -DENABLE_LIBWTTEST:BOOL=ON
-PLIST_SUB+= LIBWTTEST=""
-.else
-CMAKE_ARGS+= -DENABLE_LIBWTTEST:BOOL=OFF
-PLIST_SUB+= LIBWTTEST="@comment "
+USE_QT4= corelib moc_build
.endif
.if ${PORT_OPTIONS:MOPENGL}
USE_GL= gl glew
-CMAKE_ARGS+= -DENABLE_OPENGL:BOOL=ON
-.else
-CMAKE_ARGS+= -DENABLE_OPENGL:BOOL=OFF
.endif
.if ${PORT_OPTIONS:MFCGI}
-LIB_DEPENDS+= libfcgi.so:www/fcgi
-LIB_DEPENDS+= libfcgi++.so:www/fcgi
-CMAKE_ARGS+= -DCONNECTOR_FCGI:BOOL=ON
-PLIST_SUB+= FCGI=""
-.else
-CMAKE_ARGS+= -DCONNECTOR_FCGI:BOOL=OFF
-PLIST_SUB+= FCGI="@comment "
-.endif
+LIB_DEPENDS+= libfcgi.so:www/fcgi \
+ libfcgi++.so:www/fcgi
-.if ${PORT_OPTIONS:MWTHTTP}
-CMAKE_ARGS+= -DCONNECTOR_HTTP:BOOL=ON
-PLIST_SUB+= WTHTTP=""
-.else
-CMAKE_ARGS+= -DCONNECTOR_HTTP:BOOL=OFF
-PLIST_SUB+= WTHTTP="@comment "
+CMAKE_ARGS+= -DFCGI_PREFIX:STRING=${LOCALBASE}
.endif
.if ${PORT_OPTIONS:MSQLITE3} \
@@ -244,50 +201,22 @@ PLIST_SUB+= DBO="@comment "
.if ${PORT_OPTIONS:MSQLITE3}
USES+= sqlite:3
-CMAKE_ARGS+= -DENABLE_SQLITE:BOOL=ON
-PLIST_SUB+= SQLITE3=""
-.else
-CMAKE_ARGS+= -DENABLE_SQLITE:BOOL=OFF
-PLIST_SUB+= SQLITE3="@comment "
+CMAKE_ARGS+= -DSQLITE3_PREFIX:STRING=${LOCALBASE}
.endif
.if ${PORT_OPTIONS:MPOSTGRES}
USE_PGSQL= yes
-CMAKE_ARGS+= -DENABLE_POSTGRES:BOOL=ON
-PLIST_SUB+= POSTGRES=""
-.else
-CMAKE_ARGS+= -DENABLE_POSTGRES:BOOL=OFF
-PLIST_SUB+= POSTGRES="@comment "
+CMAKE_ARGS+= -DPOSTGRES_PREFIX:STRING=${LOCALBASE}
.endif
.if ${PORT_OPTIONS:MFIREBIRD}
USE_FIREBIRD= yes
-CMAKE_ARGS+= -DENABLE_FIREBIRD:BOOL=ON
-PLIST_SUB+= FIREBIRD=""
-.else
-CMAKE_ARGS+= -DENABLE_FIREBIRD:BOOL=OFF
-PLIST_SUB+= FIREBIRD="@comment "
+CMAKE_AGS+= -DFIREBIRD_PREFIX:STRING=${LOCALBASE}
.endif
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
-CMAKE_ARGS+= -DENABLE_MYSQL:BOOL=ON
-PLIST_SUB+= MYSQL=""
-.else
-CMAKE_ARGS+= -DENABLE_MYSQL:BOOL=OFF
-PLIST_SUB+= MYSQL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNO_STD_LOCALE}
-CMAKE_ARGS+= -DWT_NO_STD_LOCALE:BOOL=ON
-.else
-CMAKE_ARGS+= -DWT_NO_STD_LOCALE:BOOL=OFF
-.endif
-
-.if ${PORT_OPTIONS:MNO_STD_WSTRING}
-CMAKE_ARGS+= -DWT_NO_STD_WSTRING:BOOL=ON
-.else
-CMAKE_ARGS+= -DWT_NO_STD_WSTRING:BOOL=OFF
+CMAKE_ARGS+= -DMYSQL_PREFIX:STRING=${LOCALBASE}
.endif
post-stage:
diff --git a/www/wt/distinfo b/www/wt/distinfo
index 0b80106db0f9..427c5eef439f 100644
--- a/www/wt/distinfo
+++ b/www/wt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1471468688
-SHA256 (wt-3.3.6.tar.gz) = 8f82576076deb1d72cfb8ff42cf7ffb3553a45da32123b2a3cf36e66040678ab
-SIZE (wt-3.3.6.tar.gz) = 7952106
+TIMESTAMP = 1471474081
+SHA256 (kdeforche-wt-3.3.6_GH0.tar.gz) = 8f82576076deb1d72cfb8ff42cf7ffb3553a45da32123b2a3cf36e66040678ab
+SIZE (kdeforche-wt-3.3.6_GH0.tar.gz) = 7952106
href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/russian?h=gstreamer0.10-removal&id=2fdeeb4431abd2c5eb1ba905a5e8713aebc89303'>- Change my e-mailaz2005-10-031-1/+1 * - Fix fetching problem [1]novel2005-09-261-3/+1 * unbreak OSSP mm based ports after library version bumprse2005-09-091-1/+1 * - RIP russian version of nagios. It's too old. No new one available.sem2005-08-3020-827/+0 * Fix index build by moving openoffice.org-1.1 ports.maho2005-08-291-1/+1 * Update to KDE 3.4.2 / KOffice 1.4.1lofi2005-08-018-13/+13 * This port is scheduled for deletion on 2005-09-22 if it is still brokenkris2005-07-234-0/+8 * Update to KOffice 1.4.0a.lofi2005-07-069-87/+126 * Remove openoffice.org localized ports as I announced:maho2005-06-293-44/+0 * Update to KDE 3.4.1lofi2005-06-268-48/+60 * Upgrade to 0.99f9ache2005-06-062-3/+3 * - Follow the new teTeX structuresem2005-06-065-51/+54 * - Unbreak and general updatepav2005-06-061-2/+3 * Disable building packages from this portyar2005-05-301-0/+2 * - Match the reality of bogofilter 0.94.13.yar2005-05-301-2/+6 * - Remove linux-mozillafirebird and it's language spinoffs. This port ispav2005-05-284-40/+0 * - Update CONFLICTSpav2005-05-261-1/+1 * Mark ru-bogofilter port as broken to prevent people from upgradingyar2005-05-231-0/+2 * Added slave port of lang/php_doc for the Russian languageedwin2005-05-232-0/+14 * Fix CONFLICTS (again - don't blame me!):skv2005-05-131-1/+1 * Fix CONFLICTS:skv2005-05-131-1/+1 * Add unzip , unzip with CP866 and KOI8-R support.skv2005-05-133-0/+98 * - update to 3.2.1novel2005-04-202-5/+5 * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-122-2/+2 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-112-2/+2 * Remove myself from maintainerache2005-04-081-1/+1 * Fix a typo in the kio translation, which causes all Open File / Save Filelofi2005-03-284-0/+24 * Update to KDE 3.4lofi2005-03-214-62/+522 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-121-1/+1 * Upgrade to 0.99f8ache2005-03-112-4/+3 * Use @freebsd.org address for my ports.novel2005-03-082-2/+2 * BROKEN: Incorrect pkg-plistkris2005-02-282-0/+4 * BROKEN: Changes permissions of installed directorykris2005-02-281-0/+2 * Update to version 7.0rc12krion2005-02-138-20/+140 * BROKEN: Removes pine.conf upon deinstallationkris2005-02-121-0/+2 * - don't create httpd.conf.bakclement2005-02-124-0/+32 * Split the postgresql ports into a server and a client part.girgen2005-01-311-1/+1