aboutsummaryrefslogtreecommitdiffstats
path: root/www/www6to4
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2014-05-08 01:08:56 +0800
committerak <ak@FreeBSD.org>2014-05-08 01:08:56 +0800
commit12a4f70323c79497f3ac4159e849238af07254c6 (patch)
tree416a3a97efffb2924232ee92a07d485dec3bc196 /www/www6to4
parent6cb3160512e700765ed36c626b541a4cc1dd9ec3 (diff)
downloadfreebsd-ports-gnome-12a4f70323c79497f3ac4159e849238af07254c6.tar.gz
freebsd-ports-gnome-12a4f70323c79497f3ac4159e849238af07254c6.tar.zst
freebsd-ports-gnome-12a4f70323c79497f3ac4159e849238af07254c6.zip
- Support STAGEDIR [1]
- Add license [1] - Use @sample to handle config files PR: ports/188936 (based on) [1] Submitted by: Takefu <takefu@airport.fm> [1] Approved by: Janos Mohacsi <jmohacsi@bsd.hu> (maintainer)
Diffstat (limited to 'www/www6to4')
-rw-r--r--www/www6to4/Makefile29
-rw-r--r--www/www6to4/files/patch-Makefile13
-rw-r--r--www/www6to4/pkg-plist8
3 files changed, 18 insertions, 32 deletions
diff --git a/www/www6to4/Makefile b/www/www6to4/Makefile
index 5bef09c64dd3..09e3a3775fd2 100644
--- a/www/www6to4/Makefile
+++ b/www/www6to4/Makefile
@@ -10,27 +10,28 @@ MASTER_SITES= ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/
MAINTAINER= jmohacsi@bsd.hu
COMMENT= Lightweight http proxy to help IPv4 only browsers
+LICENSE= GPLv2
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/./-/}
USE_RC_SUBR= www6to4
-NO_STAGE= yes
+PORTDOCS= README
+
+ALL_TARGET= www6to4
+
post-patch:
- @${REINPLACE_CMD} -e 's,/etc,${PREFIX}/etc,' \
- ${WRKSRC}/www6to4.c
+ @${REINPLACE_CMD} -e 's,/etc,${ETCDIR},' \
+ ${WRKSRC}/www6to4.c ${WRKSRC}/www6to4.conf
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/www6to4 ${PREFIX}/sbin
- @if [ ! -d ${PREFIX}/etc/www6to4 ]; then \
- ${MKDIR} ${PREFIX}/etc/www6to4; fi
+ ${INSTALL_PROGRAM} ${WRKSRC}/www6to4 ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/www6to4.conf \
- ${PREFIX}/etc/www6to4/www6to4.conf.sample
+ ${STAGEDIR}${ETCDIR}/www6to4.conf.sample
${INSTALL_DATA} ${WRKSRC}/www6to4_forward.conf \
- ${PREFIX}/etc/www6to4/www6to4_forward.conf.sample
-.if !defined(NOPORTDOCS)
- if [ ! -d ${DOCSDIR} ]; then \
- ${MKDIR} ${DOCSDIR}; fi
- ${INSTALL_DATA} ${WRKSRC}/README \
- ${DOCSDIR}
-.endif
+ ${STAGEDIR}${ETCDIR}/www6to4_forward.conf.sample
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/www6to4/files/patch-Makefile b/www/www6to4/files/patch-Makefile
deleted file mode 100644
index 74ded54980c2..000000000000
--- a/www/www6to4/files/patch-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-*** Makefile.orig Fri Mar 22 00:24:37 2002
---- Makefile Fri Mar 22 00:25:17 2002
-***************
-*** 6,11 ****
---- 6,13 ----
-
- OBJS = www6to4.o parsers.c loaders.o socket.o
-
-+ all: $(PROG)
-+
- $(PROG): $(OBJS)
- $(CC) $(CFLAGS) -o $(PROG) $(OBJS) $(LDFLAGS)
-
diff --git a/www/www6to4/pkg-plist b/www/www6to4/pkg-plist
index be0dd80b310c..bcb10c8b2f42 100644
--- a/www/www6to4/pkg-plist
+++ b/www/www6to4/pkg-plist
@@ -1,6 +1,4 @@
sbin/www6to4
-etc/www6to4/www6to4.conf.sample
-etc/www6to4/www6to4_forward.conf.sample
-%%PORTDOCS%%%%DOCSDIR%%/README
-@dirrm etc/www6to4
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@sample %%ETCDIR%%/www6to4.conf.sample
+@sample %%ETCDIR%%/www6to4_forward.conf.sample
+@dirrmtry %%ETCDIR%%