aboutsummaryrefslogtreecommitdiffstats
path: root/www/wwwoffle
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2002-03-29 16:36:24 +0800
committersumikawa <sumikawa@FreeBSD.org>2002-03-29 16:36:24 +0800
commit7d36e71786cc9a16bb049f4c72953f69e503a45d (patch)
tree1bc43f0ce14ba2b0133ea97e6feca1e42ed41abc /www/wwwoffle
parent285d21fd04e9700dbf093135f980004cab8eaab4 (diff)
downloadfreebsd-ports-gnome-7d36e71786cc9a16bb049f4c72953f69e503a45d.tar.gz
freebsd-ports-gnome-7d36e71786cc9a16bb049f4c72953f69e503a45d.tar.zst
freebsd-ports-gnome-7d36e71786cc9a16bb049f4c72953f69e503a45d.zip
- Fix breakage in bento
- Suppress message when booting from rc.d/wwwoffled.sh from netchild.
Diffstat (limited to 'www/wwwoffle')
-rw-r--r--www/wwwoffle/Makefile1
-rw-r--r--www/wwwoffle/files/patch-conf::Makefile.in11
-rw-r--r--www/wwwoffle/files/wwwoffled.sh2
3 files changed, 13 insertions, 1 deletions
diff --git a/www/wwwoffle/Makefile b/www/wwwoffle/Makefile
index d19075dffb4e..30a3baa1594f 100644
--- a/www/wwwoffle/Makefile
+++ b/www/wwwoffle/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wwwoffle
PORTVERSION= 2.7
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.demon.co.uk/pub/unix/httpd/ \
${MASTER_SITE_SUNSITE}
diff --git a/www/wwwoffle/files/patch-conf::Makefile.in b/www/wwwoffle/files/patch-conf::Makefile.in
new file mode 100644
index 000000000000..11ae732a3e50
--- /dev/null
+++ b/www/wwwoffle/files/patch-conf::Makefile.in
@@ -0,0 +1,11 @@
+--- conf/Makefile.in- Fri Mar 29 16:40:55 2002
++++ conf/Makefile.in Fri Mar 29 16:39:51 2002
+@@ -49,7 +49,7 @@
+ echo "WWWOFFLE: There is already a config file $(CONFDIR)/wwwoffle.conf." ;\
+ echo "WWWOFFLE: Run 'conf/upgrade-config.pl $(CONFDIR)/wwwoffle.conf' to upgrade it." ;\
+ echo "WWWOFFLE: " )
+- [ ! -f $(CONFDIR)/wwwoffle.conf ] || $(INSTALL) -c -m 640 wwwoffle.conf.install $(CONFDIR)/wwwoffle.conf.install
++ $(INSTALL) -c -m 640 wwwoffle.conf.install $(CONFDIR)/wwwoffle.conf.install
+ [ -f $(CONFDIR)/wwwoffle.conf ] || $(INSTALL) -c -m 640 wwwoffle.conf.install $(CONFDIR)/wwwoffle.conf
+
+ ######## CONF FILE ########
diff --git a/www/wwwoffle/files/wwwoffled.sh b/www/wwwoffle/files/wwwoffled.sh
index 3764e197d88b..f57aef7bc533 100644
--- a/www/wwwoffle/files/wwwoffled.sh
+++ b/www/wwwoffle/files/wwwoffled.sh
@@ -3,7 +3,7 @@
case $1 in
start)
[ -x %PREFIX%/sbin/wwwoffled ] && \
- %PREFIX%/sbin/wwwoffled > /dev/null && echo -n ' wwwoffled'
+ %PREFIX%/sbin/wwwoffled >/dev/null 2>&1 && echo -n ' wwwoffled'
;;
stop)
killall wwwoffled && echo -n ' wwwoffled'