aboutsummaryrefslogtreecommitdiffstats
path: root/www/wwwstat
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1997-03-03 02:26:18 +0800
committerandreas <andreas@FreeBSD.org>1997-03-03 02:26:18 +0800
commit6ebe6bd60009d4302fe1c8f2897f6437e4074e72 (patch)
tree02a987e30426b85b412e010f77537f2cc651b980 /www/wwwstat
parent3d46b183de044d9029af508cd1753c72c3a2cd78 (diff)
downloadfreebsd-ports-gnome-6ebe6bd60009d4302fe1c8f2897f6437e4074e72.tar.gz
freebsd-ports-gnome-6ebe6bd60009d4302fe1c8f2897f6437e4074e72.tar.zst
freebsd-ports-gnome-6ebe6bd60009d4302fe1c8f2897f6437e4074e72.zip
New port wwwstat.
Nice Web statistic package. Requires something like apache and perl. Patched the init files, so that apaches access.log file will be found. The local domain name has to be configured by hand. The rc files are located in ${PREFIX}/lib/perl5/site_perl/i386-freebsd: wwwstat.rc splitlog.rc The next commit will be a package, that makes graphical bars from wwwstat's output ;-) This would be something for all of our webservers !!! We could see, which domains access the webservers, traffic analysis and so on !!!
Diffstat (limited to 'www/wwwstat')
-rw-r--r--www/wwwstat/Makefile45
-rw-r--r--www/wwwstat/distinfo2
-rw-r--r--www/wwwstat/files/patch-aa10
-rw-r--r--www/wwwstat/files/patch-ab15
-rw-r--r--www/wwwstat/pkg-comment1
-rw-r--r--www/wwwstat/pkg-descr11
-rw-r--r--www/wwwstat/pkg-plist10
7 files changed, 94 insertions, 0 deletions
diff --git a/www/wwwstat/Makefile b/www/wwwstat/Makefile
new file mode 100644
index 000000000000..168e4829d052
--- /dev/null
+++ b/www/wwwstat/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: wwwstat
+# Version required: 2.01
+# Date created: So 2 Mär 1997 18:10:49 MET
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+#
+# $Id$
+#
+
+DISTNAME= wwwstat-2.01
+CATEGORIES= www
+MASTER_SITES= ftp://www.ics.uci.edu/pub/websoft/wwwstat/
+DISTFILES= wwwstat-2.0.tar.gz
+DIST_SUBDIR= wwwstat-2.01
+
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= patch-2.01.txt
+
+MAINTAINER= andreas@FreeBSD.ORG
+
+RUN_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5 \
+ ${PREFIX}/etc/apache/srm.conf:${PORTSDIR}/www/apache
+
+WRKSRC= ${WRKDIR}/wwwstat-2.0
+MAN1= wwwstat.1 splitlog.1
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/wwwstat ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/splitlog ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/monthly ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/wwwerrs ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/oldlog2new ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/wwwstat.rc \
+ ${PREFIX}/lib/perl5/site_perl/i386-freebsd
+ @${INSTALL_DATA} ${WRKSRC}/splitlog.rc \
+ ${PREFIX}/lib/perl5/site_perl/i386-freebsd
+ @${INSTALL_DATA} ${WRKSRC}/domains.pl \
+ ${PREFIX}/lib/perl5/site_perl/i386-freebsd
+ @${INSTALL_MAN} ${WRKSRC}/wwwstat.1 ${PREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/splitlog.1 ${PREFIX}/man/man1
+ @${ECHO_MSG} "Edit the wwwstat.rc and splitlog.rc file ..."
+ @${ECHO_MSG} "If needed, edit wwwstat and splitlog directly ..."
+ @${ECHO_MSG} "These files are located in:"
+ @${ECHO_MSG} " ${PREFIX}/lib/perl5/site_perl/i386-freebsd"
+
+.include <bsd.port.mk>
diff --git a/www/wwwstat/distinfo b/www/wwwstat/distinfo
new file mode 100644
index 000000000000..d236f33d5c41
--- /dev/null
+++ b/www/wwwstat/distinfo
@@ -0,0 +1,2 @@
+MD5 (wwwstat-2.01/wwwstat-2.0.tar.gz) = de42bfca14e3aad9a345ae1c9a4740b6
+MD5 (wwwstat-2.01/patch-2.01.txt) = 85a3e314dfcd74f5119fac280cd2668c
diff --git a/www/wwwstat/files/patch-aa b/www/wwwstat/files/patch-aa
new file mode 100644
index 000000000000..ec6b330a095c
--- /dev/null
+++ b/www/wwwstat/files/patch-aa
@@ -0,0 +1,10 @@
+--- wwwstat.rc.orig Sun Mar 2 18:49:48 1997
++++ wwwstat.rc Sun Mar 2 18:52:17 1997
+@@ -93,6 +93,7 @@
+ # Specify the default location of your access log
+ #
+ ## $DefaultLog = '/usr/local/etc/httpd/logs/access_log';
++$DefaultLog = '/var/log/httpd-access.log';
+ #
+ # Specify the command for displaying compressed files to STDOUT
+ #
diff --git a/www/wwwstat/files/patch-ab b/www/wwwstat/files/patch-ab
new file mode 100644
index 000000000000..a01033117ae4
--- /dev/null
+++ b/www/wwwstat/files/patch-ab
@@ -0,0 +1,15 @@
+--- splitlog.rc.orig Sun Mar 2 18:50:00 1997
++++ splitlog.rc Sun Mar 2 18:51:21 1997
+@@ -41,10 +41,12 @@
+ # Specify the default location of your access log
+ #
+ ## $DefaultLog = '/usr/local/etc/httpd/logs/access_log';
++$DefaultLog = '/var/log/httpd-access.log';
+ #
+ # Specify the default destination directory for the split logfiles
+ #
+ ## $DestDir = ''; # current directory
++$DestDir = '/tmp'; # current directory
+ #
+ # Specify the filename (no .ext) for non-matching, non-split log entries
+ #
diff --git a/www/wwwstat/pkg-comment b/www/wwwstat/pkg-comment
new file mode 100644
index 000000000000..12d6b19643c2
--- /dev/null
+++ b/www/wwwstat/pkg-comment
@@ -0,0 +1 @@
+webserver logfile analysis package
diff --git a/www/wwwstat/pkg-descr b/www/wwwstat/pkg-descr
new file mode 100644
index 000000000000..7b30eab7d44d
--- /dev/null
+++ b/www/wwwstat/pkg-descr
@@ -0,0 +1,11 @@
+wwwstat: httpd logfile analysis package
+
+Copyright (c) 1994, 1996 Regents of the University of California.
+
+ wwwstat processes a sequence of httpd Common Logfile Format access_log
+ files and prior summary outputs, and then outputs a summary of
+ the access statistics in a nice HTML format.
+
+ splitlog processes a sequence of httpd Common Logfile Format access_log
+ files (or CLF with a one-field prefix) and splits the entries into
+ separate files according to the requested URL and/or vhost prefix.
diff --git a/www/wwwstat/pkg-plist b/www/wwwstat/pkg-plist
new file mode 100644
index 000000000000..e63273ab4d36
--- /dev/null
+++ b/www/wwwstat/pkg-plist
@@ -0,0 +1,10 @@
+bin/monthly
+bin/oldlog2new
+bin/splitlog
+bin/wwwerrs
+bin/wwwstat
+lib/perl5/site_perl/i386-freebsd/domains.pl
+lib/perl5/site_perl/i386-freebsd/splitlog.rc
+lib/perl5/site_perl/i386-freebsd/wwwstat.rc
+man/man1/splitlog.1.gz
+man/man1/wwwstat.1.gz