aboutsummaryrefslogtreecommitdiffstats
path: root/www/wyvern/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-03-05 17:18:47 +0800
committerknu <knu@FreeBSD.org>2001-03-05 17:18:47 +0800
commita3cf52842335c1a0dc81651d18c191ccabb69c72 (patch)
tree3f19fdcd62576a0305e5e31b88abb7a7682275e9 /www/wyvern/Makefile
parentdc0ff1000a1168256b8855de935dae0021288fc0 (diff)
downloadfreebsd-ports-gnome-a3cf52842335c1a0dc81651d18c191ccabb69c72.tar.gz
freebsd-ports-gnome-a3cf52842335c1a0dc81651d18c191ccabb69c72.tar.zst
freebsd-ports-gnome-a3cf52842335c1a0dc81651d18c191ccabb69c72.zip
Add wyvern, a lightweight HTTP server with the simple design, easy
setup and small size.
Diffstat (limited to 'www/wyvern/Makefile')
-rw-r--r--www/wyvern/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/wyvern/Makefile b/www/wyvern/Makefile
new file mode 100644
index 000000000000..d2903e6029e2
--- /dev/null
+++ b/www/wyvern/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Wyvern
+# Date created: 3 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wyvern
+PORTVERSION= 1.0.3
+CATEGORIES= www ipv6
+MASTER_SITES= http://www.MysticWALL.com/software/src/
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_BZIP2= yes
+USE_OPENSSL= yes
+USE_GMAKE= yes
+USE_AUTOCONF= yes
+PREFIX= ${LOCALBASE}/wyvern
+CONFIGURE_ARGS= --with-ssl=yes \
+ --with-ssl-includes="${OPENSSLINC}" \
+ --with-ssl-libraries="${OPENSSLLIB}"
+MAKE_ARGS= rcdir="${LOCALBASE}/etc/rc.d"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400014
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+post-install:
+ ${LN} -sf ${PREFIX}/sbin/* ${LOCALBASE}/sbin/
+ @${CAT} ${PKGMESSAGE}
+
+certificate:
+ cd ${PREFIX} && openssl req -config conf/ssl.cnf -new -x509 -nodes \
+ -out conf/wyvern.pem -keyout conf/wyvern.pem
+
+.include <bsd.port.post.mk>