aboutsummaryrefslogtreecommitdiffstats
path: root/www/wyvern
diff options
context:
space:
mode:
authorsimon <simon@FreeBSD.org>2006-09-23 21:14:52 +0800
committersimon <simon@FreeBSD.org>2006-09-23 21:14:52 +0800
commitf3620e51b58adcbc1c853bd162f23c19bb2accbd (patch)
treea0140677c2165356e2d7039add5581c5e8d789c0 /www/wyvern
parent48c1c30f5f65c4e95b4c454f398e67045dcc6eaf (diff)
downloadfreebsd-ports-gnome-f3620e51b58adcbc1c853bd162f23c19bb2accbd.tar.gz
freebsd-ports-gnome-f3620e51b58adcbc1c853bd162f23c19bb2accbd.tar.zst
freebsd-ports-gnome-f3620e51b58adcbc1c853bd162f23c19bb2accbd.zip
Fix compile with OpenSSL 0.9.8b in -CURRENT and remove BROKEN.
PR: ports/102837 Approved by: maintainer
Diffstat (limited to 'www/wyvern')
-rw-r--r--www/wyvern/Makefile4
-rw-r--r--www/wyvern/files/patch-src_modules_auth.c13
-rw-r--r--www/wyvern/files/patch-src_wyvern.h13
3 files changed, 26 insertions, 4 deletions
diff --git a/www/wyvern/Makefile b/www/wyvern/Makefile
index 093ddf78c2df..625d090f4d88 100644
--- a/www/wyvern/Makefile
+++ b/www/wyvern/Makefile
@@ -28,10 +28,6 @@ MAKE_ARGS= rcdir="${LOCALBASE}/etc/rc.d"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700019
-BROKEN= Does not compile on FreeBSD >= 7.0
-.endif
-
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.endif
diff --git a/www/wyvern/files/patch-src_modules_auth.c b/www/wyvern/files/patch-src_modules_auth.c
new file mode 100644
index 000000000000..dce7c322d7f4
--- /dev/null
+++ b/www/wyvern/files/patch-src_modules_auth.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/modules/auth.c.orig
++++ src/modules/auth.c
+@@ -44,6 +44,7 @@
+ #include "config.h"
+ #endif /* HAVE_CONFIG_H */
+
++#include <sys/types.h>
+ #include <stdio.h>
+ #if HAVE_STDLIB_H
+ #include <stdlib.h>
diff --git a/www/wyvern/files/patch-src_wyvern.h b/www/wyvern/files/patch-src_wyvern.h
new file mode 100644
index 000000000000..45c74c558ab3
--- /dev/null
+++ b/www/wyvern/files/patch-src_wyvern.h
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/wyvern.h.orig
++++ src/wyvern.h
+@@ -56,6 +56,7 @@
+ #include <netdb.h>
+ #if USE_SSL
+ #include <openssl/ssl.h>
++#include <openssl/md5.h>
+ #endif /* USE_SSL */
+ #include <sys/time.h>
+ #include "status.h"