aboutsummaryrefslogtreecommitdiffstats
path: root/www/xpi-adblock/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-04-17 00:24:07 +0800
committerthierry <thierry@FreeBSD.org>2006-04-17 00:24:07 +0800
commit973400bf35d3461b776a3fa0ae5d7771773b8604 (patch)
tree52a60bd9100f2df4b4df05dd34731f7103001cc6 /www/xpi-adblock/Makefile
parent8296a7b9467a33865c2ac2be1cc4ca43538ac32e (diff)
downloadfreebsd-ports-gnome-973400bf35d3461b776a3fa0ae5d7771773b8604.tar.gz
freebsd-ports-gnome-973400bf35d3461b776a3fa0ae5d7771773b8604.tar.zst
freebsd-ports-gnome-973400bf35d3461b776a3fa0ae5d7771773b8604.zip
Adblock is a content filtering plug-in for the Mozilla and Firefox browsers.
It is both more robust and more precise than the built-in image blocker. Adblock allows the user to specify filters, which remove unwanted content based on the source-address. WWW: http://adblock.mozdev.org/ Note: the included www/xpi-adblock/Makefile.xpi is used for browsers based on Gecko >= 1.8 (e.g. Firefox >= 1.5). Older browsers must use extensions which rely on www/mozex/Makefile.xpi. PR: ports/95076 Submitted by: Andrew Pantyukhin <infofarmer (at) gmail.com>
Diffstat (limited to 'www/xpi-adblock/Makefile')
-rw-r--r--www/xpi-adblock/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/www/xpi-adblock/Makefile b/www/xpi-adblock/Makefile
new file mode 100644
index 000000000000..41d152dfedce
--- /dev/null
+++ b/www/xpi-adblock/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: xpi-adblock
+# Date created: 28 March 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= adblock
+PORTVERSION= 0.5.3.042
+DISTVERSIONSUFFIX= -fx+fl+mz+ns
+CATEGORIES= www
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A content filtering extension
+
+XPI_ID= {34274bf4-1d97-a289-e984-17e546307e4f}
+XPI_FILES= chrome/adblock.jar chrome.manifest components/.autoreg \
+ components/nsAdblock.js defaults/preferences/adblock.js \
+ install.js install.rdf license.txt
+XPI_DIRS= chrome components defaults/preferences defaults
+
+.include "../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>