aboutsummaryrefslogtreecommitdiffstats
path: root/www/xshttpd-devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-03-21 21:44:59 +0800
committergarga <garga@FreeBSD.org>2006-03-21 21:44:59 +0800
commit41cbf0f603fcb29d4eff15ef13805ffb9297d55b (patch)
treead4372d6611f997d24089fb366effcdef1df6662 /www/xshttpd-devel
parent16300c4c026c5647596c7786653b01acd34dbab2 (diff)
downloadfreebsd-ports-gnome-41cbf0f603fcb29d4eff15ef13805ffb9297d55b.tar.gz
freebsd-ports-gnome-41cbf0f603fcb29d4eff15ef13805ffb9297d55b.tar.zst
freebsd-ports-gnome-41cbf0f603fcb29d4eff15ef13805ffb9297d55b.zip
- Rename DATADIR -> WWWDIR to prevent confusion
- Use a REINPLACE_CMD to don't install mime.types instead remove it after installed - Use PORTDOCS facility Approved by: maintainer at IIRC
Diffstat (limited to 'www/xshttpd-devel')
-rw-r--r--www/xshttpd-devel/Makefile21
-rw-r--r--www/xshttpd-devel/pkg-plist138
2 files changed, 79 insertions, 80 deletions
diff --git a/www/xshttpd-devel/Makefile b/www/xshttpd-devel/Makefile
index a2265de3acc8..dab1a2d84e01 100644
--- a/www/xshttpd-devel/Makefile
+++ b/www/xshttpd-devel/Makefile
@@ -9,7 +9,7 @@ PORTNAME= xshttpd
DISTVERSION= 3.4b06
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/ \
- ftp://mud.stack.nl/pub/xs-httpd/release/
+ ftp://mud.stack.nl/pub/xs-httpd/release/
PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}-${DISTVERSION:S/.//}
@@ -34,10 +34,12 @@ OPTIONS= SSL "Enable https support" On \
PCRE "Enable pcre rewriting support" Off \
PERSISTENT_PERL "Enable persistent perl interpreter" Off
+PORTDOCS= README BUGS COPYING ChangeLog
+
# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
-DATADIR= ${PREFIX}/www
-PLIST_SUB= WWWDIR=${DATADIR}
-CONFIGURE_ARGS+=--with-rootdir=${DATADIR}
+WWWDIR?= ${PREFIX}/www
+PLIST_SUB= WWWDIR=${WWWDIR:S,^${PREFIX}/,,}
+CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
.include <bsd.port.pre.mk>
@@ -74,20 +76,23 @@ post-patch:
.for i in man/httpd.1 man/httpd.conf.5 config/httpd.conf.sample \
contrib/SSL-Makefile contrib/logrotate.sh
@${REINPLACE_CMD} \
- -e 's|/wwwsys|${DATADIR}|g' \
- -e 's|/usr/local/lib/httpd|${DATADIR}|g' \
+ -e 's|/wwwsys|${WWWDIR}|g' \
+ -e 's|/usr/local/lib/httpd|${WWWDIR}|g' \
-e 's|nobody|${WWWOWN}|g' \
-e 's|nogroup|${WWWGRP}|g' \
${WRKSRC}/$i
.endfor
@${REINPLACE_CMD} -e 's|\(MIMETYPESFILE\ "\).*|\1${LOCALBASE}/etc/mime.types"|' \
${WRKSRC}/src/confuser.h
+ @${REINPLACE_CMD} -e 's|mime.types ||g' \
+ ${WRKSRC}/config/Makefile.in
post-install:
- @${RM} ${DATADIR}/mime.types
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} README BUGS COPYING ChangeLog ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
.endif
.include <bsd.port.post.mk>
diff --git a/www/xshttpd-devel/pkg-plist b/www/xshttpd-devel/pkg-plist
index 9513b6bbc929..1735ff2bdf58 100644
--- a/www/xshttpd-devel/pkg-plist
+++ b/www/xshttpd-devel/pkg-plist
@@ -4,75 +4,69 @@ bin/httpdc
bin/readxs
bin/xsindex
bin/xspasswd
-%%DATADIR%%/cgi-bin/error
-%%DATADIR%%/cgi-bin/gfxcount
-%%DATADIR%%/cgi-bin/imagemap
-%%DATADIR%%/cgi-bin/xschpass
-%%DATADIR%%/contrib/SSL-Makefile
-%%DATADIR%%/contrib/agentstats.pl
-%%DATADIR%%/contrib/caroot.pem
-%%DATADIR%%/contrib/logrotate.sh
-%%DATADIR%%/contrib/persistent.pl
-%%DATADIR%%/contrib/powered-by-xs.gif
-%%DATADIR%%/contrib/wwwstats.pl
-%%DATADIR%%/compress.methods.sample
-%%DATADIR%%/gfxcount/digital0.ppm
-%%DATADIR%%/gfxcount/digital1.ppm
-%%DATADIR%%/gfxcount/digital2.ppm
-%%DATADIR%%/gfxcount/digital3.ppm
-%%DATADIR%%/gfxcount/digital4.ppm
-%%DATADIR%%/gfxcount/digital5.ppm
-%%DATADIR%%/gfxcount/digital6.ppm
-%%DATADIR%%/gfxcount/digital7.ppm
-%%DATADIR%%/gfxcount/digital8.ppm
-%%DATADIR%%/gfxcount/digital9.ppm
-%%DATADIR%%/gfxcount/large0.ppm
-%%DATADIR%%/gfxcount/large1.ppm
-%%DATADIR%%/gfxcount/large2.ppm
-%%DATADIR%%/gfxcount/large3.ppm
-%%DATADIR%%/gfxcount/large4.ppm
-%%DATADIR%%/gfxcount/large5.ppm
-%%DATADIR%%/gfxcount/large6.ppm
-%%DATADIR%%/gfxcount/large7.ppm
-%%DATADIR%%/gfxcount/large8.ppm
-%%DATADIR%%/gfxcount/large9.ppm
-%%DATADIR%%/gfxcount/largecol0.ppm
-%%DATADIR%%/gfxcount/largecol1.ppm
-%%DATADIR%%/gfxcount/largecol2.ppm
-%%DATADIR%%/gfxcount/largecol3.ppm
-%%DATADIR%%/gfxcount/largecol4.ppm
-%%DATADIR%%/gfxcount/largecol5.ppm
-%%DATADIR%%/gfxcount/largecol6.ppm
-%%DATADIR%%/gfxcount/largecol7.ppm
-%%DATADIR%%/gfxcount/largecol8.ppm
-%%DATADIR%%/gfxcount/largecol9.ppm
-%%DATADIR%%/httpd.conf.sample
-%%DATADIR%%/icons/xs-audio.gif
-%%DATADIR%%/icons/xs-back.gif
-%%DATADIR%%/icons/xs-base.gif
-%%DATADIR%%/icons/xs-bin.gif
-%%DATADIR%%/icons/xs-dir.gif
-%%DATADIR%%/icons/xs-gif.gif
-%%DATADIR%%/icons/xs-html.gif
-%%DATADIR%%/icons/xs-image.gif
-%%DATADIR%%/icons/xs-jpeg.gif
-%%DATADIR%%/icons/xs-ps.gif
-%%DATADIR%%/icons/xs-tar.gif
-%%DATADIR%%/icons/xs-txt.gif
-%%DATADIR%%/icons/xs-unknown.gif
-%%DATADIR%%/icons/xs-video.gif
-%%DATADIR%%/icons/xs-zip.gif
-%%DATADIR%%/mime.index
-%%DATADIR%%/script.methods.sample
-@dirrm %%DATADIR%%/contrib
-@dirrm %%DATADIR%%/gfxcount
-@dirrm %%DATADIR%%/icons
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/BUGS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@cwd %%WWWDIR%%
-@dirrmtry cgi-bin
-@dirrmtry htdocs
-@dirrmtry logs
+%%WWWDIR%%/cgi-bin/error
+%%WWWDIR%%/cgi-bin/gfxcount
+%%WWWDIR%%/cgi-bin/imagemap
+%%WWWDIR%%/cgi-bin/xschpass
+%%WWWDIR%%/contrib/SSL-Makefile
+%%WWWDIR%%/contrib/agentstats.pl
+%%WWWDIR%%/contrib/caroot.pem
+%%WWWDIR%%/contrib/logrotate.sh
+%%WWWDIR%%/contrib/persistent.pl
+%%WWWDIR%%/contrib/powered-by-xs.gif
+%%WWWDIR%%/contrib/wwwstats.pl
+%%WWWDIR%%/compress.methods.sample
+%%WWWDIR%%/gfxcount/digital0.ppm
+%%WWWDIR%%/gfxcount/digital1.ppm
+%%WWWDIR%%/gfxcount/digital2.ppm
+%%WWWDIR%%/gfxcount/digital3.ppm
+%%WWWDIR%%/gfxcount/digital4.ppm
+%%WWWDIR%%/gfxcount/digital5.ppm
+%%WWWDIR%%/gfxcount/digital6.ppm
+%%WWWDIR%%/gfxcount/digital7.ppm
+%%WWWDIR%%/gfxcount/digital8.ppm
+%%WWWDIR%%/gfxcount/digital9.ppm
+%%WWWDIR%%/gfxcount/large0.ppm
+%%WWWDIR%%/gfxcount/large1.ppm
+%%WWWDIR%%/gfxcount/large2.ppm
+%%WWWDIR%%/gfxcount/large3.ppm
+%%WWWDIR%%/gfxcount/large4.ppm
+%%WWWDIR%%/gfxcount/large5.ppm
+%%WWWDIR%%/gfxcount/large6.ppm
+%%WWWDIR%%/gfxcount/large7.ppm
+%%WWWDIR%%/gfxcount/large8.ppm
+%%WWWDIR%%/gfxcount/large9.ppm
+%%WWWDIR%%/gfxcount/largecol0.ppm
+%%WWWDIR%%/gfxcount/largecol1.ppm
+%%WWWDIR%%/gfxcount/largecol2.ppm
+%%WWWDIR%%/gfxcount/largecol3.ppm
+%%WWWDIR%%/gfxcount/largecol4.ppm
+%%WWWDIR%%/gfxcount/largecol5.ppm
+%%WWWDIR%%/gfxcount/largecol6.ppm
+%%WWWDIR%%/gfxcount/largecol7.ppm
+%%WWWDIR%%/gfxcount/largecol8.ppm
+%%WWWDIR%%/gfxcount/largecol9.ppm
+%%WWWDIR%%/httpd.conf.sample
+%%WWWDIR%%/icons/xs-audio.gif
+%%WWWDIR%%/icons/xs-back.gif
+%%WWWDIR%%/icons/xs-base.gif
+%%WWWDIR%%/icons/xs-bin.gif
+%%WWWDIR%%/icons/xs-dir.gif
+%%WWWDIR%%/icons/xs-gif.gif
+%%WWWDIR%%/icons/xs-html.gif
+%%WWWDIR%%/icons/xs-image.gif
+%%WWWDIR%%/icons/xs-jpeg.gif
+%%WWWDIR%%/icons/xs-ps.gif
+%%WWWDIR%%/icons/xs-tar.gif
+%%WWWDIR%%/icons/xs-txt.gif
+%%WWWDIR%%/icons/xs-unknown.gif
+%%WWWDIR%%/icons/xs-video.gif
+%%WWWDIR%%/icons/xs-zip.gif
+%%WWWDIR%%/mime.index
+%%WWWDIR%%/script.methods.sample
+@dirrm %%WWWDIR%%/contrib
+@dirrm %%WWWDIR%%/gfxcount
+@dirrm %%WWWDIR%%/icons
+@dirrmtry %%WWWDIR%%%/cgi-bin
+@dirrmtry %%WWWDIR%%%/htdocs
+@dirrmtry %%WWWDIR%%%/logs