aboutsummaryrefslogtreecommitdiffstats
path: root/www/youtube_dl
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2013-09-27 17:10:59 +0800
committeraraujo <araujo@FreeBSD.org>2013-09-27 17:10:59 +0800
commit48c53f186ac590ff34834b0ad50b3f22a8dabbca (patch)
tree2eb49808b6a5715887876db62268f969267e9d2e /www/youtube_dl
parente9c429e41c673ed92bcd845735628d91b7c7bbaf (diff)
downloadfreebsd-ports-gnome-48c53f186ac590ff34834b0ad50b3f22a8dabbca.tar.gz
freebsd-ports-gnome-48c53f186ac590ff34834b0ad50b3f22a8dabbca.tar.zst
freebsd-ports-gnome-48c53f186ac590ff34834b0ad50b3f22a8dabbca.zip
- now it is stagify.
- bump PORTREVISION. Submitted by: Jimmy Olgeni <olgeni@olgeni.com>
Diffstat (limited to 'www/youtube_dl')
-rw-r--r--www/youtube_dl/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index ee2887852abe..78176605798a 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -2,6 +2,7 @@
PORTNAME= youtube_dl
PORTVERSION= 2013.09.24.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://youtube-dl.org/downloads/${PORTVERSION}/ \
http://ftp.de.netbsd.org/pub/unix/Linux/MIRROR.gentoo/distfiles/
@@ -26,8 +27,8 @@ OPTIONS_DEFAULT=RTMPDUMP
BASH_DESC= Install programmable completions for Bash
RTMPDUMP_DESC= Use RTMPDUMP to download rtmp video streams
-PLIST_FILES= bin/youtube-dl
-MAN1= youtube-dl.1
+PLIST_FILES= bin/youtube-dl \
+ man/man1/youtube-dl.1.gz
WRKSRC= ${WRKDIR}/youtube-dl
@@ -55,12 +56,12 @@ post-extract:
@${RM} -f ${WRKSRC}/youtube-dl
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/youtube-dl ${PREFIX}/bin/youtube-dl
- @${INSTALL_DATA} ${WRKSRC}/youtube-dl.1 ${PREFIX}/man/man1
+ @${INSTALL_SCRIPT} ${WRKSRC}/youtube-dl ${STAGEDIR}${PREFIX}/bin/youtube-dl
+ @${INSTALL_DATA} ${WRKSRC}/youtube-dl.1 ${STAGEDIR}${PREFIX}/man/man1
.if ${PORT_OPTIONS:MBASH}
- ${MKDIR} ${PREFIX}/etc/bash_completion.d
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
${INSTALL_DATA} ${WRKSRC}/youtube-dl.bash-completion \
- ${PREFIX}/etc/bash_completion.d/youtube-dl.sh
+ ${STAGEDIR}${PREFIX}/etc/bash_completion.d/youtube-dl.sh
.endif
.if ${PORT_OPTIONS:MFFMPEG}